update to transmission 4.0.2.

includes many local patches.  fixes download limits.
This commit is contained in:
mrg 2023-03-30 05:37:07 +00:00
parent a1a93cb768
commit b77bee2309
8 changed files with 13 additions and 111 deletions

View file

@ -1,6 +1,4 @@
# $NetBSD: Makefile,v 1.35 2023/02/20 17:01:51 abs Exp $
PKGREVISION= 2
# $NetBSD: Makefile,v 1.36 2023/03/30 05:37:07 mrg Exp $
DEPENDS+= transmission-common>=${VERSION}:../../net/transmission-common

View file

@ -1,11 +1,11 @@
# $NetBSD: Makefile.common,v 1.13 2023/02/14 09:45:39 wiz Exp $
# $NetBSD: Makefile.common,v 1.14 2023/03/30 05:37:07 mrg Exp $
#
# used by net/transmission-common/Makefile
# used by net/transmission-gtk/Makefile
# used by net/transmission-qt/Makefile
# used by net/transmission/Makefile
VERSION= 4.0.0
VERSION= 4.0.2
DISTNAME= transmission-${VERSION}
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GITHUB:=transmission/}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.6 2023/02/14 09:45:39 wiz Exp $
@comment $NetBSD: PLIST,v 1.7 2023/03/30 05:37:07 mrg Exp $
bin/transmission-create
bin/transmission-daemon
bin/transmission-edit
@ -37,9 +37,11 @@ share/doc/transmission/news/news-2.92.md
share/doc/transmission/news/news-2.93.md
share/doc/transmission/news/news-2.94.md
share/doc/transmission/news/news-3.00.md
share/doc/transmission/news/news-${PKGVERSION}-beta-1.md
share/doc/transmission/news/news-${PKGVERSION}-beta-2.md
share/doc/transmission/news/news-${PKGVERSION}-beta-3.md
share/doc/transmission/news/news-4.0.0-beta-1.md
share/doc/transmission/news/news-4.0.0-beta-2.md
share/doc/transmission/news/news-4.0.0-beta-3.md
share/doc/transmission/news/news-4.0.0.md
share/doc/transmission/news/news-4.0.1.md
share/doc/transmission/news/news-${PKGVERSION}.md
share/doc/transmission/rpc-spec.md
share/doc/transmission/send-email-when-torrent-done.sh

View file

@ -1,9 +1,5 @@
$NetBSD: distinfo,v 1.23 2023/02/20 17:01:51 abs Exp $
$NetBSD: distinfo,v 1.24 2023/03/30 05:37:07 mrg Exp $
BLAKE2s (transmission-4.0.0.tar.xz) = 4b701562e5b72b5eb60b203c3f682135404feed2083cb04801a42818361eae39
SHA512 (transmission-4.0.0.tar.xz) = 79945af73fe7226dddadba7cc039516f2f878e05a9cf6c6d799b636b8298e2b2fa25c4426789bd41ef4d2b00d75a3c1c115c1676b4d2a9f09a1526456dceb3f8
Size (transmission-4.0.0.tar.xz) = 10351556 bytes
SHA1 (patch-CMakeLists.txt) = 3be8d125e64759e190dd2acae746a9f505b52763
SHA1 (patch-libtransmission_CMakeLists.txt) = b4f697ecd5dd22fafa38fa72d0bc47b2d940e8dc
SHA1 (patch-libtransmission_completion.cc) = e774dd8781571728384c59a87c293dcbe05c53cf
SHA1 (patch-libtransmission_completion.h) = 31171a30d079f313b74f05e7c058a62a6dbc80d0
BLAKE2s (transmission-4.0.2.tar.xz) = 209147d4cdf734cab45dec811bf0a4efa3d9344d2fc88c637c88bcaad0f672cf
SHA512 (transmission-4.0.2.tar.xz) = 84784e0c06d4595674710dbc3caac545e0bcf69bef44f2d681ed80ed6722dbb24fc4b8cba39dd957e0e3a276b6b664f8a938087d930f633ebfe9af16e7afcbf4
Size (transmission-4.0.2.tar.xz) = 10055708 bytes

View file

@ -1,19 +0,0 @@
$NetBSD: patch-CMakeLists.txt,v 1.2 2023/02/13 13:48:11 wiz Exp $
Detect and use libquota.
https://github.com/transmission/transmission/pull/4863
--- CMakeLists.txt.orig 2023-02-07 23:39:47.000000000 +0000
+++ CMakeLists.txt
@@ -695,6 +695,11 @@ if(HAVE_LIBM)
set(LIBM_LIBRARY m)
endif()
+check_library_exists(quota quotacursor_skipidtype "" HAVE_LIBQUOTA)
+if(HAVE_LIBQUOTA)
+ set(LIBQUOTA_LIBRARY quota)
+endif()
+
set(TR_NETWORK_LIBRARIES)
if(WIN32)
list(APPEND TR_NETWORK_LIBRARIES iphlpapi ws2_32)

View file

@ -1,15 +0,0 @@
$NetBSD: patch-libtransmission_CMakeLists.txt,v 1.2 2023/02/13 13:48:11 wiz Exp $
Detect and use libquota.
https://github.com/transmission/transmission/pull/4863
--- libtransmission/CMakeLists.txt.orig 2023-02-01 03:51:15.000000000 +0000
+++ libtransmission/CMakeLists.txt
@@ -279,6 +279,7 @@ target_link_libraries(${TR_NAME}
libb64::libb64
${LIBINTL_LIBRARY}
${LIBM_LIBRARY}
+ ${LIBQUOTA_LIBRARY}
${TR_NETWORK_LIBRARIES}
jsonsl
utf8::cpp

View file

@ -1,42 +0,0 @@
$NetBSD: patch-libtransmission_completion.cc,v 1.1 2023/02/20 17:01:51 abs Exp $
patch to fix "assertion failed leftUntilDone <= sizeWhenDone"
https://github.com/transmission/transmission/pull/4879/commits/57ff8bda34e7d752b76b750b699932500664198d
file 1/2
--- libtransmission/completion.cc.orig 2023-01-30 05:23:05.000000000 +0000
+++ libtransmission/completion.cc
@@ -156,13 +156,28 @@ void tr_completion::addPiece(tr_piece_in
}
}
-void tr_completion::removePiece(tr_piece_index_t piece)
+void tr_completion::removeBlock(tr_block_index_t block)
{
- auto const [begin, end] = block_info_->blockSpanForPiece(piece);
- size_now_ -= countHasBytesInPiece(piece);
+ if (!hasBlock(block))
+ {
+ return; // already didn't have it
+ }
+
+ blocks_.unset(block);
+ size_now_ -= block_info_->blockSize(block);
+
size_when_done_.reset();
has_valid_.reset();
- blocks_.unsetSpan(begin, end);
+}
+
+void tr_completion::removePiece(tr_piece_index_t piece)
+{
+ auto const [begin, end] = block_info_->blockSpanForPiece(piece);
+
+ for (auto block = begin; block < end; ++block)
+ {
+ removeBlock(block);
+ }
}
uint64_t tr_completion::countHasBytesInSpan(tr_byte_span_t span) const

View file

@ -1,18 +0,0 @@
$NetBSD: patch-libtransmission_completion.h,v 1.1 2023/02/20 17:01:51 abs Exp $
patch to fix "assertion failed leftUntilDone <= sizeWhenDone"
https://github.com/transmission/transmission/pull/4879/commits/57ff8bda34e7d752b76b750b699932500664198d
file 2/2
--- libtransmission/completion.h.orig 2023-01-30 05:23:05.000000000 +0000
+++ libtransmission/completion.h
@@ -172,6 +172,8 @@ private:
return countHasBytesInSpan(block_info_->byteSpanForPiece(piece));
}
+ void removeBlock(tr_block_index_t block);
+
torrent_view const* tor_;
tr_block_info const* block_info_;