Update to 4.0. Excerpt of changes since 3.12:

* Language:
  . New command @anchor for cross references to arbitrary points.
  . New commands @documentlanguage sets the main document language,
    and @documentencoding sets the document input encoding (although not
    much is done yet with either).
  . New command @pagesizes allows limited control of text area for typesetting.
  . New command @acronym for abbreviations in all caps, such as `NASA'.
  . New command @alias for simple command aliases.
  . New command @definfoenclose for better control of info output.
  . New commands @deftypeivar for typed instance variables of a class
    and @deftypeop for typed operations of a class.
  . New command @novalidate suppresses cross-reference checking and (in
    TeX) auxiliary file creation.
  . New commands @setcontentsaftertitlepage and
    @setshortcontentsaftertitlepage to force printing the table of
    contents after @end titlepage.  Also, @contents and @shortcontents
    themselves can now appear at the beginning of the document as
    well as the end.
  . New markup commands: @env (for environment variables), @command (for
    command names), @option (for command-line options).
  . New commands @smallformat and @smalldisplay, a la @smallexample.
  . New command @exampleindent to set indentation of example-like
    environments a la @paragraphindent.
  . @uref takes an optional third argument of text to show instead of
    (rather than in addition to) the url for info and dvi output.
  . @footnote works in an @item for a @table.
* texinfo.tex:
  . implements @macro.
  . implements @paragraphindent (except asis).
  . @emph and @i use true italic type (cmti) instead of slanted (cmsl).
  . implements pdf output when run with pdftex.
  . better support for internationalization via txi-??.tex files.
* makeinfo:
  . supports HTML output with the --html option.
  . implication of --html: @top nodes should be wrapped in @ifnottex
    rather than @ifinfo.  @ifinfo conditionals are not expanded with --html.
  . new option --number-sections to output chapter/section numbers.
  . dashes and quotes are not treated specially in node names.
  . new option --commands-in-node-names to allow @-commands in node names.
    (Not implemented in TeX, and most likely never will be.)
  . @emph output uses _underscores_.
  . @image looks for .png files before .jpg.
  . only output `Making ... file' line when verbose.
  . allow -v as synonym for --verbose.
  . new command line options to specify which conditionals to process
    (but --iftex is not fully implemented).
  . warns if @var contains any of ,[]().
  . @quote-arg implicitly done for all one-argument macros, so commas in
    the argument text are allowed.
  . \\ required in macro body to get single \, no other `escapes' defined.
* info:
  . ISO Latin 1 characters are displayed and input as-is by default.
  . new option --vi-keys to enable vi-like and less-like key bindings.
  . new command S does case-sensitive searching.
  . new commands C-x n and C-x N repeat last search, respectively, in the
    same and in reverse direction, without prompting for the string.  These
    commands are bound to n and N under --vi-keys, like in Less.
  . new command G menu1 menu2 ... searches for menu items from (dir),
    as allowed on the command line.
  . new command O (capital o, not zero) goes directly to the node that
    describes command-line options.
  . new command-line option --show-options causes the node which
    describes command-line options to be the first node displayed.
  . M-prior and M-DEL do new command info-scroll-other-window-backward.
  . / searches like s does.
  . If the search string includes upper-case letters, in both incremental
    and non-incremental search, the search is case-sensitive.
  . S searches case-sensitively even if the search string is all
    lower-case.
  . - makes the argument negative (so e.g. `- /' searches backward).
  . l restores point in the window returned to.
  . SPC/DEL do not move outside the current document.
  . foo.info is found before foo.
  . `info foo --index-search=bar' now searches for bar in foo's index.
  . support for files compressed with bzip2.
* install-info:
  . handles gzipped dir files.
  . sort entries into alphabetical order.
  . install direntries only in preceding dircategory, not in all.
  . --delete does not require the info file to exist.
  . --delete can handle XEmacs-style dir entries.
* texi2dvi:
  . bug fixed: now uses only the @iftex and @tex parts of the source.
  . process LaTeX source as well as Texinfo source.
  . output PDF (using pdftex) with new option --pdf.
  . handles --OPTION=ARG style of command line arguments.
  . new option --batch for progress reports but no interaction.
  . new option --clean to remove all auxiliary files.
  . new option --quiet for silence (unless there are errors).
  . new option -I for specifying directories for @include to search.
  . handles LaTeX files (running BibTeX etc.).
* Fixes to util/gen-dir-node and util/fix-info-dir (formerly util/update-info).
This commit is contained in:
wiz 2001-12-25 14:48:34 +00:00
parent dc3933cbd2
commit b7aee58e99
13 changed files with 88 additions and 128 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.24 2001/06/18 22:09:16 jlam Exp $
# $NetBSD: Makefile,v 1.25 2001/12/25 14:48:34 wiz Exp $
#
DISTNAME= texinfo-3.12
PKGNAME= gtexinfo-3.12
DISTNAME= texinfo-4.0
PKGNAME= gtexinfo-4.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU:=texinfo/}
@ -14,14 +14,9 @@ USE_BUILDLINK_ONLY= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-catgets
CONFIGURE_ENV+= PKGLOCALEDIR="${PKGLOCALEDIR}"
PLIST_SRC= ${WRKDIR}/.PLIST_SRC
.include "../../devel/zlib/buildlink.mk"
.if exists(/usr/bin/install-info)
IGNORE= "${PKGNAME} is included with your NetBSD distribution"
.endif
post-patch:
${MV} -f ${WRKSRC}/info/filesys.h ${WRKSRC}/info/filesys.h.orig
${SED} -e 's|@PREFIX@|${PREFIX}|g' \
@ -34,6 +29,5 @@ post-install:
${PREFIX}/bin/install-info --info-dir=${PREFIX}/info ${PREFIX}/info/texinfo
${PREFIX}/bin/install-info --info-dir=${PREFIX}/info ${PREFIX}/info/info.info
${PREFIX}/bin/install-info --info-dir=${PREFIX}/info ${PREFIX}/info/info-stnd.info
${CAT} ${PKGDIR}/PLIST.common ${PKGDIR}/PLIST.${LOWER_OPSYS} > ${PLIST_SRC}
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST.common,v 1.1 2001/11/01 01:31:17 zuntum Exp $
@comment $NetBSD: PLIST,v 1.1 2001/12/25 14:48:34 wiz Exp $
@unexec install-info --delete --info-dir=%D/info %D/info/info-stnd.info
@unexec install-info --delete --info-dir=%D/info %D/info/info.info
@unexec install-info --delete --info-dir=%D/info %D/info/texinfo
@ -8,12 +8,15 @@ bin/texindex
bin/install-info
bin/info
info/info-stnd.info
info/info-stnd.info-1
info/info-stnd.info-2
info/info.info
info/texinfo
info/texinfo-1
info/texinfo-10
info/texinfo-11
info/texinfo-12
info/texinfo-13
info/texinfo-2
info/texinfo-3
info/texinfo-4
@ -25,3 +28,18 @@ info/texinfo-9
@exec install-info --info-dir=%D/info %D/info/info-stnd.info
@exec install-info --info-dir=%D/info %D/info/info.info
@exec install-info --info-dir=%D/info %D/info/texinfo
man/man1/info.1
man/man1/install-info.1
man/man1/makeinfo.1
man/man1/texi2dvi.1
man/man1/texindex.1
man/man5/info.5
man/man5/texinfo.5
${PKGLOCALEDIR}/locale/cs/LC_MESSAGES/texinfo.mo
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/texinfo.mo
${PKGLOCALEDIR}/locale/de_AT/LC_MESSAGES/texinfo.mo
${PKGLOCALEDIR}/locale/eo/LC_MESSAGES/texinfo.mo
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/texinfo.mo
${PKGLOCALEDIR}/locale/nl/LC_MESSAGES/texinfo.mo
${PKGLOCALEDIR}/locale/no/LC_MESSAGES/texinfo.mo
${PKGLOCALEDIR}/locale/ru/LC_MESSAGES/texinfo.mo

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST.darwin,v 1.1 2001/12/06 14:17:56 agc Exp $
share/locale/de/LC_MESSAGES/texinfo.cat
share/locale/fr/LC_MESSAGES/texinfo.cat

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST.linux,v 1.1 2001/11/01 01:31:17 zuntum Exp $
share/locale/de/LC_MESSAGES/texinfo.mo
share/locale/fr/LC_MESSAGES/texinfo.mo

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST.netbsd,v 1.1 2001/11/01 01:31:18 zuntum Exp $
share/locale/de/LC_MESSAGES/texinfo.cat
share/locale/fr/LC_MESSAGES/texinfo.cat

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST.solaris,v 1.1 2001/11/01 01:31:18 zuntum Exp $
lib/locale/de/LC_MESSAGES/texinfo.mo
lib/locale/fr/LC_MESSAGES/texinfo.mo

View file

@ -1,11 +1,10 @@
$NetBSD: distinfo,v 1.3 2001/06/18 22:09:16 jlam Exp $
$NetBSD: distinfo,v 1.4 2001/12/25 14:48:37 wiz Exp $
SHA1 (texinfo-3.12.tar.gz) = 297a3baeb7c20635aa3a74697b71fdc13b2e82a5
Size (texinfo-3.12.tar.gz) = 756883 bytes
SHA1 (patch-aa) = 904f238dfc9aea94ed023c4cb3f72c8cdda814ec
SHA1 (patch-ab) = 55aae466b7bae2cdeeb5ff544e7084906d1fb719
SHA1 (patch-ac) = 8956b859a443c17893ea113a6a365b1f202685ee
SHA1 (patch-ad) = b39433e8cfef85fcb71011bae1bc64c0f825cd67
SHA1 (patch-ae) = 3b24bf945215ab0f67cf7a55130a14677f18e331
SHA1 (texinfo-4.0.tar.gz) = 09e944520672fcd8384f7b9fa96a20d9ec2b54c9
Size (texinfo-4.0.tar.gz) = 1133487 bytes
SHA1 (patch-aa) = 09fb1b3eb0cd689bd9214e5c5b3c58f76f4d7c4a
SHA1 (patch-ab) = be452b7e30edf9eae26875422efbe45e3ddc4caf
SHA1 (patch-ac) = e884e0532808d7915d4730223753c696d398355d
SHA1 (patch-ae) = 5b81d7eee82a745f297ce890940e99a591512461
SHA1 (patch-af) = aaf33281da19658906eee6a922397968a200f186
SHA1 (patch-ag) = ae8aaf53f6ebea49a19a3d6f0c30505b72d47e44
SHA1 (patch-ag) = 986c7172e0f71f1d107a59e89f0a74330d91cd40

View file

@ -1,22 +1,13 @@
$NetBSD: patch-aa,v 1.5 2000/01/20 11:48:04 agc Exp $
$NetBSD: patch-aa,v 1.6 2001/12/25 14:48:38 wiz Exp $
--- util/Makefile.in 1998/02/13 13:13:54 1.1
+++ util/Makefile.in 1998/02/13 13:14:34
@@ -46,7 +46,7 @@
--- util/Makefile.in.orig Tue Sep 28 21:40:56 1999
+++ util/Makefile.in
@@ -48,7 +48,7 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_PROGRAM = @INSTALL_PROGRAM@ $(AM_INSTALL_PROGRAM_FLAGS)
INSTALL_DATA = @INSTALL_DATA@
-INSTALL_SCRIPT = @INSTALL_SCRIPT@
+INSTALL_SCRIPT = ${BSD_INSTALL_SCRIPT}
transform = @program_transform_name@
NORMAL_INSTALL = :
@@ -270,7 +270,7 @@
all: Makefile $(PROGRAMS) $(SCRIPTS)
install-strip:
- $(MAKE) INSTALL_PROGRAM='$(INSTALL_PROGRAM) -s' INSTALL_SCRIPT='$(INSTALL_PROGRAM)' install
+ $(MAKE) INSTALL_PROGRAM='$(INSTALL_PROGRAM) -s' INSTALL_SCRIPT='$(INSTALL_SCRIPT)' install
installdirs:
$(mkinstalldirs) $(bindir) $(bindir)

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ab,v 1.3 1998/08/07 10:40:24 agc Exp $
$NetBSD: patch-ab,v 1.4 2001/12/25 14:48:38 wiz Exp $
--- info/Makefile.in.orig Mon Mar 9 08:42:23 1998
+++ info/Makefile.in Mon Mar 9 08:42:44 1998
--- info/Makefile.in.orig Tue Sep 28 21:40:50 1999
+++ info/Makefile.in
@@ -97,7 +97,7 @@
# Automake puts -I.. and -I$(srcdir) into DEFS by default, but
# we need to override it, so include them ourselves.
@ -10,4 +10,4 @@ $NetBSD: patch-ab,v 1.3 1998/08/07 10:40:24 agc Exp $
+DEFS = -DPORTSINFODIR=\"$(prefix)/info\" -DINFODIR=\"$(infodir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
LDADD = ../lib/libtxi.a @TERMLIBS@ @INTLLIBS@
makedoc_SOURCES = makedoc.c
EXTRA_DIST = README pcterm.c

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ac,v 1.5 1999/02/11 17:54:32 tv Exp $
$NetBSD: patch-ac,v 1.6 2001/12/25 14:48:38 wiz Exp $
--- info/filesys.h.orig Mon Aug 4 22:21:35 1997
+++ info/filesys.h Wed May 6 23:00:23 1998
@@ -71,7 +71,7 @@
--- info/filesys.h.orig Wed Jul 22 00:25:44 1998
+++ info/filesys.h
@@ -76,7 +76,7 @@
/* The default value of INFOPATH. */
#if !defined (DEFAULT_INFOPATH)

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ad,v 1.3 1998/08/07 10:40:24 agc Exp $
--- util/texindex.c.orig Mon Mar 9 08:48:33 1998
+++ util/texindex.c Mon Mar 9 08:48:45 1998
@@ -1683,7 +1683,8 @@
}
#if !defined (HAVE_STRERROR)
-extern char *sys_errlist[];
+# error patch-ad really needed (sys_errlist prototype)
+extern __const char *__const sys_errlist[];
extern int sys_nerr;
char *

View file

@ -1,58 +1,42 @@
$NetBSD: patch-ae,v 1.5 1998/08/07 10:40:25 agc Exp $
$NetBSD: patch-ae,v 1.6 2001/12/25 14:48:39 wiz Exp $
*** info/terminal.c.orig Tue Jul 29 17:42:05 1997
--- info/terminal.c Sat Nov 15 17:07:42 1997
***************
*** 31,43 ****
#ifdef HAVE_NCURSES_TERMCAP_H
#include <ncurses/termcap.h>
#else
! #ifdef HAVE_TERMCAP_H
#include <termcap.h>
#else
/* On Solaris2, sys/types.h #includes sys/reg.h, which #defines PC.
Unfortunately, PC is a global variable used by the termcap library. */
#undef PC
/* Termcap requires these variables, whether we access them or not. */
char *BC, *UP;
char PC; /* Pad character */
--- 31,47 ----
#ifdef HAVE_NCURSES_TERMCAP_H
#include <ncurses/termcap.h>
#else
! #if defined(HAVE_TERMCAP_H) && !defined(__NetBSD__)
#include <termcap.h>
#else
/* On Solaris2, sys/types.h #includes sys/reg.h, which #defines PC.
Unfortunately, PC is a global variable used by the termcap library. */
#undef PC
+ #if defined(__NetBSD__)
+ #include <termcap.h>
+ #endif
+
/* Termcap requires these variables, whether we access them or not. */
char *BC, *UP;
char PC; /* Pad character */
***************
*** 114,125 ****
--- 118,135 ----
/* Although I can't find any documentation that says this is supposed to
return its argument, all the code I've looked at (termutils, less)
does so, so fine. */
+ #ifdef __NetBSD__
+ void
+ #else
static int
+ #endif
output_character_function (c)
int c;
{
putc (c, stdout);
+ #ifndef __NetBSD__
return c;
+ #endif
}
/* Macro to send STRING to the terminal. */
--- info/terminal.c.orig Mon Sep 20 14:28:54 1999
+++ info/terminal.c
@@ -32,13 +32,17 @@
#ifdef HAVE_NCURSES_TERMCAP_H
#include <ncurses/termcap.h>
#else
-#ifdef HAVE_TERMCAP_H
+#if defined(HAVE_TERMCAP_H) && !defined(__NetBSD__)
#include <termcap.h>
#else
/* On Solaris2, sys/types.h #includes sys/reg.h, which #defines PC.
Unfortunately, PC is a global variable used by the termcap library. */
#undef PC
+#if defined(__NetBSD__)
+#include <termcap.h>
+#endif
+
/* Termcap requires these variables, whether we access them or not. */
char *BC, *UP;
char PC; /* Pad character */
@@ -116,12 +120,18 @@
/* Although I can't find any documentation that says this is supposed to
return its argument, all the code I've looked at (termutils, less)
does so, so fine. */
+#ifdef __NetBSD__
+void
+#else
static int
+#endif
output_character_function (c)
int c;
{
putc (c, stdout);
+#ifndef __NetBSD__
return c;
+#endif
}
/* Macro to send STRING to the terminal. */

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ag,v 1.5 2001/06/18 22:09:17 jlam Exp $
$NetBSD: patch-ag,v 1.6 2001/12/25 14:48:39 wiz Exp $
--- configure.orig Tue Mar 3 13:30:18 1998
+++ configure Sun Oct 4 15:53:12 1998
@@ -3443,7 +3443,7 @@
--- configure.orig Tue Sep 28 21:39:56 1999
+++ configure
@@ -4019,7 +4019,7 @@
USE_INCLUDED_LIBINTL=yes
CATOBJEXT=.cat
INSTOBJEXT=.cat