LibTorrent is a BitTorrent library written in C++ for *nix. It is designed to
avoid redundant copying and storing of data that other clients and libraries suffer from. Licensed under the GPL.
This commit is contained in:
parent
7afebea02b
commit
b7e0ea16f5
6 changed files with 75 additions and 0 deletions
3
net/libtorrent/DESCR
Normal file
3
net/libtorrent/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
LibTorrent is a BitTorrent library written in C++ for *nix. It is designed to
|
||||
avoid redundant copying and storing of data that other clients and libraries
|
||||
suffer from. Licensed under the GPL.
|
18
net/libtorrent/Makefile
Normal file
18
net/libtorrent/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2005/07/22 22:24:39 adam Exp $
|
||||
|
||||
DISTNAME= libtorrent-0.7.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
|
||||
|
||||
MAINTAINER= imil@gcu.info
|
||||
HOMEPAGE= http://libtorrent.rakshasa.no/
|
||||
COMMENT= BitTorrent library written in C++ for *nix
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-openssl=${BUILDLINK_PREFIX.openssl}
|
||||
|
||||
.include "../../devel/libsigc++2/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
14
net/libtorrent/PLIST
Normal file
14
net/libtorrent/PLIST
Normal file
|
@ -0,0 +1,14 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2005/07/22 22:24:39 adam Exp $
|
||||
include/torrent/bencode.h
|
||||
include/torrent/common.h
|
||||
include/torrent/download.h
|
||||
include/torrent/entry.h
|
||||
include/torrent/exceptions.h
|
||||
include/torrent/http.h
|
||||
include/torrent/peer.h
|
||||
include/torrent/rate.h
|
||||
include/torrent/torrent.h
|
||||
include/torrent/tracker.h
|
||||
lib/libtorrent.la
|
||||
lib/pkgconfig/libtorrent.pc
|
||||
@dirrm include/torrent
|
21
net/libtorrent/buildlink3.mk
Normal file
21
net/libtorrent/buildlink3.mk
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2005/07/22 22:24:39 adam Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
LIBTORRENT_BUILDLINK3_MK:= ${LIBTORRENT_BUILDLINK3_MK}+
|
||||
|
||||
.if !empty(BUILDLINK_DEPTH:M+)
|
||||
BUILDLINK_DEPENDS+= libtorrent
|
||||
.endif
|
||||
|
||||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nlibtorrent}
|
||||
BUILDLINK_PACKAGES+= libtorrent
|
||||
|
||||
.if !empty(LIBTORRENT_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_DEPENDS.libtorrent+= libtorrent>=0.7.0
|
||||
BUILDLINK_PKGSRCDIR.libtorrent?= ../../wip/libtorrent
|
||||
.endif # LIBTORRENT_BUILDLINK3_MK
|
||||
|
||||
.include "../../devel/libsigc++2/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
6
net/libtorrent/distinfo
Normal file
6
net/libtorrent/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2005/07/22 22:24:39 adam Exp $
|
||||
|
||||
SHA1 (libtorrent-0.7.0.tar.gz) = a14bfdb15eb078ff0ae8dc4445381c01b04486fe
|
||||
RMD160 (libtorrent-0.7.0.tar.gz) = 042911fd5d74c55320bcad85ca6a0f3058f24afa
|
||||
Size (libtorrent-0.7.0.tar.gz) = 317298 bytes
|
||||
SHA1 (patch-aa) = bb40555e2f7507879711000d510c0d3d9e3d6cd0
|
13
net/libtorrent/patches/patch-aa
Normal file
13
net/libtorrent/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2005/07/22 22:24:39 adam Exp $
|
||||
|
||||
--- configure.orig 2005-07-22 20:40:20.000000000 +0000
|
||||
+++ configure
|
||||
@@ -8053,7 +8053,7 @@ esac
|
||||
echo "$as_me:$LINENO: checking for user-defined CXXFLAGS" >&5
|
||||
echo $ECHO_N "checking for user-defined CXXFLAGS... $ECHO_C" >&6
|
||||
|
||||
- if test $CXXFLAGS; then
|
||||
+ if test "$CXXFLAGS"; then
|
||||
echo "$as_me:$LINENO: result: user-defined \"$CXXFLAGS\"" >&5
|
||||
echo "${ECHO_T}user-defined \"$CXXFLAGS\"" >&6
|
||||
else
|
Loading…
Reference in a new issue