Add DragonFlyBSD support, from Joerg Sonnenberger.
This commit is contained in:
parent
e9de543098
commit
b83ca794ce
4 changed files with 25 additions and 13 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.5 2005/06/17 03:50:23 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2005/07/13 13:16:36 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libmpeg3-1.3
|
||||
|
@ -10,12 +10,18 @@ MAINTAINER= tech-pkg@NetBSD.org
|
|||
HOMEPAGE= http://heroines.sourceforge.net/libmpeg3.php3
|
||||
COMMENT= MPEG decoding library
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if (${MACHINE_ARCH} == "i386")
|
||||
BUILD_DEPENDS+= nasm-[0-9]*:../../devel/nasm
|
||||
.else
|
||||
CONFIGURE_ARGS+= --no-mmx --no-css
|
||||
.endif
|
||||
|
||||
.if ${OPSYS} == "DragonFly"
|
||||
CONFIGURE_ARGS+= --no-css
|
||||
.endif
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: distinfo,v 1.3 2005/06/07 23:38:34 hubertf Exp $
|
||||
$NetBSD: distinfo,v 1.4 2005/07/13 13:16:36 wiz Exp $
|
||||
|
||||
SHA1 (libmpeg3-1.3.tar.gz) = e7e8b03ab45d5593558b0d19e31f0694cfdfa2b5
|
||||
RMD160 (libmpeg3-1.3.tar.gz) = b1751f681d26758873746aa38368150eb0a4bafd
|
||||
Size (libmpeg3-1.3.tar.gz) = 154062 bytes
|
||||
SHA1 (patch-aa) = a5665a330234b964aca00a5c4c6f00a9f1bd11ff
|
||||
SHA1 (patch-aa) = 88e1c193bb00056f757830c98f6bbbc58c1b16da
|
||||
SHA1 (patch-ab) = 844cfcbd99269f1f0b4bef76e0a8567522070707
|
||||
SHA1 (patch-ac) = 2893fe6a8973bdf63302b868e2827e496e82d77d
|
||||
SHA1 (patch-ac) = 68576efb30a0d6f4cfe23fd543a04c4f3ada8936
|
||||
SHA1 (patch-ad) = 86edf9af264370bf89050b02e956b5bacc86881e
|
||||
SHA1 (patch-ae) = 8b42cf175aab6f72386b56f324e5bb631134496f
|
||||
SHA1 (patch-ae) = 05209b31a53a25945907088377772861ff0a38bf
|
||||
SHA1 (patch-af) = 7e62a236ee0a7398c1b1a3e994261ebb9be50bae
|
||||
SHA1 (patch-ag) = bf321ac689b82889ca1a2bb8a96cb6e387280f32
|
||||
SHA1 (patch-ah) = 58ffda3df9be3b089de362451ddf249a74fac5be
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.1 2004/06/26 18:00:21 grant Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2005/07/13 13:16:36 wiz Exp $
|
||||
|
||||
--- Makefile.orig Sun May 20 05:05:26 2001
|
||||
+++ Makefile Tue Jul 31 17:34:17 2001
|
||||
@@ -2,7 +2,7 @@
|
||||
--- Makefile.orig 2001-05-20 05:05:26.000000000 +0200
|
||||
+++ Makefile
|
||||
@@ -2,7 +2,7 @@ include global_config
|
||||
|
||||
CFLAGS +=
|
||||
|
||||
|
@ -11,12 +11,12 @@ $NetBSD: patch-aa,v 1.1 2004/06/26 18:00:21 grant Exp $
|
|||
|
||||
$(shell sh -c 'if ! test -d $(OBJDIR)\; then \
|
||||
mkdir $(OBJDIR)\; \
|
||||
@@ -69,7 +69,7 @@
|
||||
@@ -69,7 +69,7 @@ OBJS = \
|
||||
|
||||
OUTPUT = $(OBJDIR)/libmpeg3.a
|
||||
UTILS = $(OBJDIR)/dump $(OBJDIR)/mpeg3cat $(OBJDIR)/mpeg3toc $(OBJDIR)/mpeg3split
|
||||
-LIBS = -lm -lpthread
|
||||
+LIBS = -L${LOCALBASE}/lib -Wl,-R${LOCALBASE}/lib -lm -lpthread
|
||||
+LIBS = -L${LOCALBASE}/lib -Wl,-R${LOCALBASE}/lib -lm ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}
|
||||
|
||||
all: $(OUTPUT) util
|
||||
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.3 2005/07/13 13:16:36 wiz Exp $
|
||||
|
||||
--- mpeg3ifo.c.orig 2001-05-20 05:05:26.000000000 +0200
|
||||
+++ mpeg3ifo.c 2005-06-08 01:20:54.000000000 +0200
|
||||
@@ -1,10 +1,22 @@
|
||||
+++ mpeg3ifo.c
|
||||
@@ -1,10 +1,26 @@
|
||||
-#include <byteswap.h>
|
||||
#include <dirent.h>
|
||||
#include <fcntl.h>
|
||||
|
@ -13,6 +15,10 @@
|
|||
+# include <machine/bswap.h>
|
||||
+# define bswap_16(x) bswap16(x)
|
||||
+# define bswap_32(x) bswap32(x)
|
||||
+#elif defined(__DragonFly__)
|
||||
+# include <sys/endian.h>
|
||||
+# define bswap_16(x) bswap16(x)
|
||||
+# define bswap_32(x) bswap32(x)
|
||||
+#elif defined(linux)
|
||||
+# include <byteswap.h>
|
||||
+#elif defined(__APPLE__) || defined(__MACH__) /* MacOS X */
|
||||
|
|
Loading…
Reference in a new issue