Update gvfs to 1.2.0.
Major changes in 1.2.0 ====================== * sftp: Don't hang if ssh no authentication method availible * Don't leak file monitors * computer: don't show shadowed mounts Major changes in 1.1.8 ====================== * Fix crashers and leaks * Handle file:// uris with anchors in gvfs-open * fuse: Support ftruncate to the current file size * escape/unescape hostname part in uris, allowing spaces in e.g. smb domains * hal: Fix "No mount object" error on mount * Change details of the new .xdg-volume-info file format * Fix races in cancellation of gvfs streams * Remove debug spew from backends * ftp: Fix anonymous login * gphoto2: Ignore broken storages with no capacity * Don't globally modify COMP_WORDBREAKS in bash completion script * Don't ask for username when getting ssh key passphrase Major changes in 1.1.7 ====================== * Fix build on some platforms * ftp: Fix short read errors * gphoto2: Make it work on iphone * sftp: Fix symlink creation * fuse: Better support of truncation, fixing OOo save * proxy monitors: Support mount operations, etc * gvfs-mount: add --device commandline support * sftp: Fix protocol bug that made some servers not work * general support for query_info over streams, implemented for smb, sftp * Initial support for .xdg-volume-info reading Major changes in 1.1.6 ====================== * Fix crashes * trash: Better messages * Clean up glib and gtk includes * archive: Build with later versions of libarchive * dav: Fix folder creation * dav: Fix redirection when user is specified in url * http: fix error propagation * sftp: Try to preserve ownership when replacing a file Major changes in 1.1.5 ====================== * network: Pick up SMB shares from zeroconf * obexftp: Write support for * obexftp: Support obexftp over usb * trash: Don't follow symlinks on delete * fix crashes Major changes in 1.1.4 ====================== * Trash performance fixes * Fuse performance fixes Major changes in 1.1.3 ====================== * ftp: fix limited number of connections causes commands to fail (#565504) * trash: fix parallel build doesn't work (#562955) * trash: add trash::orig-path and trash::deletion-date info * trash: set files to mode 700 before deleting to deal with users trashing read-only directories * smb-browse: browsing authentication support (#524485) * smb-browse: make backend not automounted anymore Major changes in 1.1.2 ====================== * New trash backend * Use the new shadow mount facility in gio * gphoto2: Use shadow mounts * obex: Fix icon for root directory * http: Fix major memory leak * http: Support proxies Major changes in 1.1.1 ====================== * Reverse map FUSE pathnames to gvfs locations * Fix crashes * Show better icon info in gvfs-info * Support custom icons for gvfs backends * dav: support uris (dav+sd://) which specify dns-sd services instead of resolved ip+port * ftp: Fix time parsing * ftp: Show username in auth dialog if specified in uri * ftp: Support UTF8 server feature * ftp: Use LIST -a instead of LIST on unix servers * fuse: Fix major race in that caused crashes * fuse: Set st_blocks so that e.g. the "du" command works * gphoto: use custom icons for faster thumbnails * obexftp: Port to bluez 4 API * sftp: If name specified in mount, use in name too so that fuse paths are unique * sftp: Support /etc/favicon.png * smb: Don't ask for password twice if cancelled * smb: support setting timestamp
This commit is contained in:
parent
44314dbc1e
commit
b83fa1741c
4 changed files with 17 additions and 95 deletions
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.14 2009/03/02 02:00:51 jmcneill Exp $
|
||||
# $NetBSD: Makefile,v 1.15 2009/03/16 13:06:40 jmcneill Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gvfs-1.0.3
|
||||
PKGREVISION= 2
|
||||
DISTNAME= gvfs-1.2.0
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gvfs/1.0/}
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gvfs/1.2/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
|
@ -66,7 +65,7 @@ BUILDLINK_API_DEPENDS.glib2+= glib2>=2.17.6
|
|||
.include "../../sysutils/dbus/buildlink3.mk"
|
||||
.include "../../archivers/libarchive/buildlink3.mk"
|
||||
.include "../../net/samba/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.libsoup24+= libsoup24>=2.23.91
|
||||
BUILDLINK_API_DEPENDS.libsoup24+= libsoup24>=2.25.1
|
||||
.include "../../net/libsoup24/buildlink3.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
.include "../../devel/GConf/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2009/03/02 02:00:51 jmcneill Exp $
|
||||
@comment $NetBSD: PLIST,v 1.8 2009/03/16 13:06:40 jmcneill Exp $
|
||||
bin/gvfs-cat
|
||||
bin/gvfs-copy
|
||||
bin/gvfs-info
|
||||
|
@ -21,6 +21,7 @@ lib/gio/modules/libgiogconf.la
|
|||
lib/gio/modules/libgioremote-volume-monitor.la
|
||||
lib/gio/modules/libgvfsdbus.la
|
||||
lib/libgvfscommon.la
|
||||
${PLIST.avahi}lib/libgvfscommon-dnssd.la
|
||||
${PLIST.fuse}libexec/gvfs-fuse-daemon
|
||||
${PLIST.hal}libexec/gvfs-hal-volume-monitor
|
||||
libexec/gvfsd
|
||||
|
@ -45,6 +46,7 @@ share/gvfs/mounts/burn.mount
|
|||
${PLIST.hal}share/gvfs/mounts/cdda.mount
|
||||
share/gvfs/mounts/computer.mount
|
||||
share/gvfs/mounts/dav.mount
|
||||
${PLIST.avahi}share/gvfs/mounts/dav+sd.mount
|
||||
${PLIST.avahi}share/gvfs/mounts/dns-sd.mount
|
||||
share/gvfs/mounts/ftp.mount
|
||||
share/gvfs/mounts/http.mount
|
||||
|
@ -56,6 +58,7 @@ share/gvfs/mounts/smb.mount
|
|||
share/gvfs/mounts/trash.mount
|
||||
${PLIST.hal}share/gvfs/remote-volume-monitors/hal.monitor
|
||||
share/locale/ar/LC_MESSAGES/gvfs.mo
|
||||
share/locale/as/LC_MESSAGES/gvfs.mo
|
||||
share/locale/be@latin/LC_MESSAGES/gvfs.mo
|
||||
share/locale/bg/LC_MESSAGES/gvfs.mo
|
||||
share/locale/bn_IN/LC_MESSAGES/gvfs.mo
|
||||
|
@ -82,16 +85,19 @@ share/locale/kn/LC_MESSAGES/gvfs.mo
|
|||
share/locale/ko/LC_MESSAGES/gvfs.mo
|
||||
share/locale/ku/LC_MESSAGES/gvfs.mo
|
||||
share/locale/lt/LC_MESSAGES/gvfs.mo
|
||||
share/locale/lv/LC_MESSAGES/gvfs.mo
|
||||
share/locale/mk/LC_MESSAGES/gvfs.mo
|
||||
share/locale/ml/LC_MESSAGES/gvfs.mo
|
||||
share/locale/mr/LC_MESSAGES/gvfs.mo
|
||||
share/locale/nb/LC_MESSAGES/gvfs.mo
|
||||
share/locale/nl/LC_MESSAGES/gvfs.mo
|
||||
share/locale/nn/LC_MESSAGES/gvfs.mo
|
||||
share/locale/or/LC_MESSAGES/gvfs.mo
|
||||
share/locale/pa/LC_MESSAGES/gvfs.mo
|
||||
share/locale/pl/LC_MESSAGES/gvfs.mo
|
||||
share/locale/pt/LC_MESSAGES/gvfs.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/gvfs.mo
|
||||
share/locale/ro/LC_MESSAGES/gvfs.mo
|
||||
share/locale/ru/LC_MESSAGES/gvfs.mo
|
||||
share/locale/sk/LC_MESSAGES/gvfs.mo
|
||||
share/locale/sl/LC_MESSAGES/gvfs.mo
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.8 2009/03/02 02:00:51 jmcneill Exp $
|
||||
$NetBSD: distinfo,v 1.9 2009/03/16 13:06:40 jmcneill Exp $
|
||||
|
||||
SHA1 (gvfs-1.0.3.tar.bz2) = 2beb736acc7b38e99c9fcb0585de6918fad5e7b7
|
||||
RMD160 (gvfs-1.0.3.tar.bz2) = 2d12e1f6690773e3aad5d59c826c509fa40a9443
|
||||
Size (gvfs-1.0.3.tar.bz2) = 920742 bytes
|
||||
SHA1 (patch-aa) = c21578643eaedf8b614b4d0e55a6ddb8b8217784
|
||||
SHA1 (gvfs-1.2.0.tar.bz2) = b0e1fa9e384b60bdcc1ce5e82e103d610ec38695
|
||||
RMD160 (gvfs-1.2.0.tar.bz2) = 05c0bd7a36295add557818e8108714d8812d8af1
|
||||
Size (gvfs-1.2.0.tar.bz2) = 1049792 bytes
|
||||
SHA1 (patch-aa) = 0fa44ac3a58ba98609d877f7fec1c4e3ea46f9ed
|
||||
SHA1 (patch-ab) = 6e8d4959f36df50e42b233becc80b14dac706112
|
||||
SHA1 (patch-ac) = 6ee347b43bcf98cf80c552463890a624a4d21f2f
|
||||
|
|
|
@ -1,90 +1,7 @@
|
|||
$NetBSD: patch-aa,v 1.3 2008/10/16 13:59:39 drochner Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2009/03/16 13:06:40 jmcneill Exp $
|
||||
|
||||
--- configure.orig 2008-09-24 14:29:37.000000000 +0200
|
||||
+++ configure
|
||||
@@ -16260,7 +16260,7 @@ if test "x$enable_http" != "xno"; then
|
||||
msg_http=yes
|
||||
fi
|
||||
|
||||
- if test "x$msg_http" == "xyes"; then
|
||||
+ if test "x$msg_http" = "xyes"; then
|
||||
|
||||
pkg_failed=no
|
||||
{ echo "$as_me:$LINENO: checking for HTTP" >&5
|
||||
@@ -16528,7 +16528,7 @@ if test "x$enable_fuse" != "xno"; then
|
||||
msg_fuse=yes
|
||||
fi
|
||||
|
||||
- if test "x$msg_fuse" == "xyes"; then
|
||||
+ if test "x$msg_fuse" = "xyes"; then
|
||||
|
||||
pkg_failed=no
|
||||
{ echo "$as_me:$LINENO: checking for FUSE" >&5
|
||||
@@ -16679,7 +16679,7 @@ if test "x$enable_gconf" != "xno"; then
|
||||
msg_gconf=yes
|
||||
fi
|
||||
|
||||
- if test "x$msg_gconf" == "xyes"; then
|
||||
+ if test "x$msg_gconf" = "xyes"; then
|
||||
|
||||
pkg_failed=no
|
||||
{ echo "$as_me:$LINENO: checking for GCONF" >&5
|
||||
@@ -16832,7 +16832,7 @@ if test "x$enable_hal" != "xno"; then
|
||||
msg_hal=yes
|
||||
fi
|
||||
|
||||
- if test "x$msg_hal" == "xyes"; then
|
||||
+ if test "x$msg_hal" = "xyes"; then
|
||||
|
||||
pkg_failed=no
|
||||
{ echo "$as_me:$LINENO: checking for HAL" >&5
|
||||
@@ -17016,7 +17016,7 @@ if test $ac_cv_lib_hal_libhal_get_all_de
|
||||
have_hal_fast_init=yes
|
||||
fi
|
||||
|
||||
- if test "x$have_hal_fast_init" == "xyes"; then
|
||||
+ if test "x$have_hal_fast_init" = "xyes"; then
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_HAL_FAST_INIT 1
|
||||
@@ -17058,7 +17058,7 @@ if test "x$enable_cdda" != "xno"; then
|
||||
msg_cdda=yes
|
||||
fi
|
||||
|
||||
- if test "x$msg_cdda" == "xyes"; then
|
||||
+ if test "x$msg_cdda" = "xyes"; then
|
||||
|
||||
pkg_failed=no
|
||||
{ echo "$as_me:$LINENO: checking for CDDA" >&5
|
||||
@@ -17418,7 +17418,7 @@ else
|
||||
fi
|
||||
|
||||
|
||||
- if test "x$msg_obexftp" == "xyes" -a "x$have_expat" == "xtrue"; then
|
||||
+ if test "x$msg_obexftp" = "xyes" -a "x$have_expat" = "xtrue"; then
|
||||
|
||||
pkg_failed=no
|
||||
{ echo "$as_me:$LINENO: checking for OBEXFTP" >&5
|
||||
@@ -17587,8 +17587,8 @@ fi
|
||||
;;
|
||||
esac
|
||||
|
||||
- if test "x$msg_gphoto2" == "xyes"; then
|
||||
- if test "x$use_gphoto2" == "xyes"; then
|
||||
+ if test "x$msg_gphoto2" = "xyes"; then
|
||||
+ if test "x$use_gphoto2" = "xyes"; then
|
||||
|
||||
pkg_failed=no
|
||||
{ echo "$as_me:$LINENO: checking for GPHOTO2" >&5
|
||||
@@ -17744,7 +17744,7 @@ if test "x$enable_keyring" != "xno"; the
|
||||
msg_keyring=yes
|
||||
fi
|
||||
|
||||
- if test "x$msg_keyring" == "xyes"; then
|
||||
+ if test "x$msg_keyring" = "xyes"; then
|
||||
|
||||
pkg_failed=no
|
||||
{ echo "$as_me:$LINENO: checking for KEYRING" >&5
|
||||
@@ -18337,7 +18337,7 @@ _ACEOF
|
||||
|
||||
msg_samba="yes"
|
||||
|
|
Loading…
Reference in a new issue