Update to 2.26.0:

===============
Version 2.26.0
===============
 Applet - changes
   * Final fixes to utf-8 and Python 2.6 sqlite

 Updated translations
   * as (Amitakhya Phukan)
   * ca (David Planella)
   * de (Hendrik Richter)
   * el (Jennie Petoumenou)
   * gu (Ankit Patel)
   * ja (Takeshi AIHANA)
   * lt (Gintautas Miliauskas)
   * mr (Sandeep Shedmake)
   * pa (Amanpreet Singh Alam)
   * ro (Adi Roiban)
   * ru (Yuriy Penkin)
   * ta (I. Felix)
   * te (Krishna Babu K)

===============
Version 2.25.92
===============
 Applet - changes
    * Fixed problems with utf-8 and Python 2.6 sqlite
    * Escaping user input so they don't break UI where pango is used
    * Stop tracking on shutdown was ignoring user preference

  Updated translations
    * cs (Adrian Gunis)
    * en_GB (Philip Withnall)
    * fi (Timo Jyrinki)
    * fr (Claude Paroz)
    * he (Yair Hershkovitz)
    * it (Milo Casagrande)
    * ko (Changwoo Ryu)
    * or (Arun Mohapatra)
    * pt (Duarte Loreto)
    * pt_BR (Vladimir Melo)
    * sl (Matej Urbančič)
    * tr (Baris Cicek)


===============
Version 2.25.91
===============
 Applet - changes
    * Show day totals in statistics (patch by Daniel Watkins)
    * Better keyboard support (Enter / Escape, patch by Daniel Watkins)
    * Fixes to detect alternative pygtk (Frederic Peters)
    * Fixes to support Japanese better (Takao Fujiwara)
    * Python 2.6 support (Patryk Zawadzki)
    * Better duplicate entry checks in activities / categories

  Updated translations
    * bg (Alexander Shopov)
    * ca (Gil Forcada)
    * da (Kenneth Nielsen)
    * es (Juanje Ojeda Croissier)
    * eu (Inaki Larranaga Murgoitio)
    * fi (Ilkka Tuohela)
    * he (Yair Hershkovitz)
    * ko (Changwoo Ryu)
    * nb (Kjartan Maraas)
    * nl (Wouter Bolsterlee)
    * pl (Tomasz Dominikowski)
    * pt_BR (Henrique P. Machado)
    * sl (Matej Urbančič)
    * sv (Daniel Nylander)
    * th (Theppitak Karoonboonyanan)
    * zh_cn (甘露(Gan Lu))
    * zh_HK (Chao-Hsiung Liao)
    * zh_TW (Chao-Hsiung Liao)


===============
Version 2.25.3
===============
  We were late for 2.25.1 and 2.25.2, so here we go - changes since 2.24.0!

  Applet - changes
    * Now it is possible to add description after activity, delimiting with
      comma: "watering flowers, begonias" will add activity "watering flowers"
      with description "begonias". Likewise you can go for cacti, and
      forgetmenots
    * Task category can be seen in dropdown and can be specified on fly to
      autocreate: working@new project - will create category "new project"
      and add activity "working" to it
    * Hamster now can remind of itself every once in a while, interval is set
      in preferences (George Logiotatidis)
    * Sending dbus signals on activity change (Juanje Croissier)

  Applet - love
    * Applet now again can be found in applet list by searching for 'hamster'
    * Get instant totals per category for today, in applet dropdown
    * Improvements in report - somewhat nicer look and there are also totals
      (Giorgos Logiotatidis)
    * Use vertical space if we have some on panel and show applet in two lines

  Updated translations
    * bg.po (Alexander Shopov)
    * el (Nick Agianniotis)
    * he (Yair Hershkovitz)
    * ku (Erdal Ronahi)
    * lv (Toms Bauģis)
    * sv (Daniel Nylander)
    * zh_CN (Ray Wang)
This commit is contained in:
wiz 2009-03-22 19:38:38 +00:00
parent b1076bb765
commit b861398a54
4 changed files with 39 additions and 15 deletions

View file

@ -1,18 +1,20 @@
# $NetBSD: Makefile,v 1.5 2009/02/09 22:56:27 joerg Exp $
# $NetBSD: Makefile,v 1.6 2009/03/22 19:38:38 wiz Exp $
#
DISTNAME= hamster-applet-2.24.3
PKGREVISION= 1
DISTNAME= hamster-applet-2.26.0
CATEGORIES= time
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/hamster-applet/2.24/}
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/hamster-applet/2.26/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://projecthamster.wordpress.com/
COMMENT= Time tracking applet for GNOME
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
CONFIGURE_ENV+= GCONF_SCHEMA_FILE_DIR=${PREFIX}/share/gconf/schemas/
MAKE_ENV+= GCONF_SCHEMA_FILE_DIR=${PREFIX}/share/gconf/schemas/
USE_DIRS+= xdg-1.4
USE_LIBTOOL= yes
USE_TOOLS+= gmake intltool pkg-config
@ -35,6 +37,7 @@ DEPENDS+= ${PYPKGPREFIX}-sqlite3-[0-9]*:../../databases/py-sqlite3
.endif
.include "../../devel/GConf/schemas.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/libbonobo/buildlink3.mk"
BUILDLINK_API_DEPENDS.pygobject+= ${PYPKGPREFIX}-gobject>=2.14
.include "../../devel/py-gobject/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2008/12/02 22:36:35 wiz Exp $
@comment $NetBSD: PLIST,v 1.2 2009/03/22 19:38:38 wiz Exp $
lib/bonobo/servers/Hamster_Applet.server
lib/hamster-applet/hamster-applet
${PYSITELIB}/hamster/Configuration.py
@ -34,6 +34,9 @@ ${PYSITELIB}/hamster/dispatcher.pyo
${PYSITELIB}/hamster/eds.py
${PYSITELIB}/hamster/eds.pyc
${PYSITELIB}/hamster/eds.pyo
${PYSITELIB}/hamster/hamsterdbus.py
${PYSITELIB}/hamster/hamsterdbus.pyc
${PYSITELIB}/hamster/hamsterdbus.pyo
${PYSITELIB}/hamster/idle.py
${PYSITELIB}/hamster/idle.pyc
${PYSITELIB}/hamster/idle.pyo
@ -73,6 +76,7 @@ share/icons/hicolor/32x32/apps/hamster-applet.png
share/icons/hicolor/48x48/apps/hamster-applet.png
share/icons/hicolor/scalable/apps/hamster-applet.svg
share/locale/ar/LC_MESSAGES/hamster-applet.mo
share/locale/as/LC_MESSAGES/hamster-applet.mo
share/locale/bg/LC_MESSAGES/hamster-applet.mo
share/locale/bn_IN/LC_MESSAGES/hamster-applet.mo
share/locale/ca/LC_MESSAGES/hamster-applet.mo
@ -95,6 +99,7 @@ share/locale/it/LC_MESSAGES/hamster-applet.mo
share/locale/ja/LC_MESSAGES/hamster-applet.mo
share/locale/kn/LC_MESSAGES/hamster-applet.mo
share/locale/ko/LC_MESSAGES/hamster-applet.mo
share/locale/ku/LC_MESSAGES/hamster-applet.mo
share/locale/lt/LC_MESSAGES/hamster-applet.mo
share/locale/lv/LC_MESSAGES/hamster-applet.mo
share/locale/mk/LC_MESSAGES/hamster-applet.mo
@ -102,10 +107,12 @@ share/locale/ml/LC_MESSAGES/hamster-applet.mo
share/locale/mr/LC_MESSAGES/hamster-applet.mo
share/locale/nb/LC_MESSAGES/hamster-applet.mo
share/locale/nl/LC_MESSAGES/hamster-applet.mo
share/locale/or/LC_MESSAGES/hamster-applet.mo
share/locale/pa/LC_MESSAGES/hamster-applet.mo
share/locale/pl/LC_MESSAGES/hamster-applet.mo
share/locale/pt/LC_MESSAGES/hamster-applet.mo
share/locale/pt_BR/LC_MESSAGES/hamster-applet.mo
share/locale/ro/LC_MESSAGES/hamster-applet.mo
share/locale/ru/LC_MESSAGES/hamster-applet.mo
share/locale/sl/LC_MESSAGES/hamster-applet.mo
share/locale/sq/LC_MESSAGES/hamster-applet.mo
@ -113,11 +120,25 @@ share/locale/sr/LC_MESSAGES/hamster-applet.mo
share/locale/sr@latin/LC_MESSAGES/hamster-applet.mo
share/locale/sv/LC_MESSAGES/hamster-applet.mo
share/locale/ta/LC_MESSAGES/hamster-applet.mo
share/locale/te/LC_MESSAGES/hamster-applet.mo
share/locale/th/LC_MESSAGES/hamster-applet.mo
share/locale/tr/LC_MESSAGES/hamster-applet.mo
share/locale/vi/LC_MESSAGES/hamster-applet.mo
share/locale/zh_CN/LC_MESSAGES/hamster-applet.mo
share/locale/zh_HK/LC_MESSAGES/hamster-applet.mo
share/locale/zh_TW/LC_MESSAGES/hamster-applet.mo
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/scalable/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/scalable
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/48x48/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/48x48
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/32x32/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/32x32
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/22x22/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/22x22
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/16x16/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/16x16
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor
@comment in xdg-dirs: @dirrm share/icons
@dirrm share/hamster-applet/art
@dirrm share/hamster-applet
@comment in GConf: @dirrm share/gconf/schemas

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.3 2009/01/16 14:38:54 wiz Exp $
$NetBSD: distinfo,v 1.4 2009/03/22 19:38:38 wiz Exp $
SHA1 (hamster-applet-2.24.3.tar.gz) = 897cd2e221f61fbe18d90ec873523410e89c8ab8
RMD160 (hamster-applet-2.24.3.tar.gz) = 0a31acf94a7e1b1a8411a7ceb92bb7e043fbc013
Size (hamster-applet-2.24.3.tar.gz) = 482565 bytes
SHA1 (patch-aa) = 0bcbf0a0894b3bb506ddee5dec8f0ee858f2d12b
SHA1 (hamster-applet-2.26.0.tar.gz) = 063a8de2b8617e2784d1865ccbc283264106f6a9
RMD160 (hamster-applet-2.26.0.tar.gz) = 718a822c8a19eb25de0b34b59360cfc460038a62
Size (hamster-applet-2.26.0.tar.gz) = 512973 bytes
SHA1 (patch-aa) = 51a04c92c148fbd148af71a4982f8f34e7f3c03d

View file

@ -1,13 +1,13 @@
$NetBSD: patch-aa,v 1.1 2008/12/06 00:59:42 jmcneill Exp $
$NetBSD: patch-aa,v 1.2 2009/03/22 19:38:38 wiz Exp $
--- hamster/__init__.py.orig 2008-10-25 17:15:16.000000000 -0400
--- hamster/__init__.py.orig 2009-03-12 18:19:20.000000000 +0000
+++ hamster/__init__.py
@@ -22,7 +22,7 @@
import os, sys
import os
from os.path import join, exists, isdir, isfile, dirname, abspath, expanduser
-from shutil import copy as copyfile
+from shutil import copyfile
import gtk, gnome.ui
import gtk, gnome.ui
from gtk import glade
import gettext