time: Remove hamster-applet.
Dead GNOME 2 applet. This is no longer part of GNOME.
This commit is contained in:
parent
4cd144acca
commit
b873044789
6 changed files with 1 additions and 213 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.193 2020/01/03 05:32:28 pho Exp $
|
||||
# $NetBSD: Makefile,v 1.194 2020/01/04 13:16:20 nia Exp $
|
||||
#
|
||||
|
||||
COMMENT= Clocks, calendars, daily planners and other time related applications
|
||||
|
@ -31,7 +31,6 @@ SUBDIR+= gnutime
|
|||
SUBDIR+= gnyaclock
|
||||
SUBDIR+= grdc
|
||||
SUBDIR+= gtodo
|
||||
SUBDIR+= hamster-applet
|
||||
SUBDIR+= hebcal
|
||||
SUBDIR+= heirloom-date
|
||||
SUBDIR+= hs-clock
|
||||
|
|
|
@ -1,2 +0,0 @@
|
|||
This applet allows you to keep track on where are you spending your
|
||||
time.
|
|
@ -1,45 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.65 2019/09/02 13:20:04 adam Exp $
|
||||
|
||||
DISTNAME= hamster-applet-2.28.1
|
||||
PKGREVISION= 40
|
||||
CATEGORIES= time
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/hamster-applet/2.28/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://projecthamster.wordpress.com/
|
||||
COMMENT= Time tracking applet for GNOME
|
||||
LICENSE= gnu-gpl-v3
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake intltool pkg-config msgfmt
|
||||
|
||||
GCONF_SCHEMAS+= hamster-applet.schemas
|
||||
PY_PATCHPLIST= yes
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 27 # py-ORBit via py-gnome2, py-gtk2
|
||||
|
||||
SUBST_CLASSES+= python
|
||||
SUBST_MESSAGE.python= Fixing path to Python interpreter.
|
||||
SUBST_STAGE.python= pre-configure
|
||||
SUBST_FILES.python= hamster/hamster-applet.py
|
||||
SUBST_SED.python= -e 's@/usr/bin/env python@${PYTHONBIN}@g'
|
||||
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
|
||||
DEPENDS+= ${PYPKGPREFIX}-sqlite3-[0-9]*:../../databases/py-sqlite3
|
||||
.include "../../devel/GConf/schemas.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../devel/libbonobo/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.pygobject+= ${PYPKGPREFIX}-gobject>=2.14
|
||||
.include "../../devel/py-gobject/buildlink3.mk"
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../sysutils/py-dbus/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.gtk2+= gtk2+>=2.12.0
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../x11/py-gnome2/buildlink3.mk"
|
||||
.include "../../x11/py-gnome2-desktop/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.pygtk2+= ${PYPKGPREFIX}-gtk2>=2.12
|
||||
.include "../../x11/py-gtk2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,144 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2009/11/17 17:29:49 wiz Exp $
|
||||
lib/bonobo/servers/Hamster_Applet.server
|
||||
lib/hamster-applet/hamster-applet
|
||||
${PYSITELIB}/hamster/KeyBinder.py
|
||||
${PYSITELIB}/hamster/KeyBinder.pyc
|
||||
${PYSITELIB}/hamster/KeyBinder.pyo
|
||||
${PYSITELIB}/hamster/__init__.py
|
||||
${PYSITELIB}/hamster/__init__.pyc
|
||||
${PYSITELIB}/hamster/__init__.pyo
|
||||
${PYSITELIB}/hamster/about.py
|
||||
${PYSITELIB}/hamster/about.pyc
|
||||
${PYSITELIB}/hamster/about.pyo
|
||||
${PYSITELIB}/hamster/applet.py
|
||||
${PYSITELIB}/hamster/applet.pyc
|
||||
${PYSITELIB}/hamster/applet.pyo
|
||||
${PYSITELIB}/hamster/charting.py
|
||||
${PYSITELIB}/hamster/charting.pyc
|
||||
${PYSITELIB}/hamster/charting.pyo
|
||||
${PYSITELIB}/hamster/configuration.py
|
||||
${PYSITELIB}/hamster/configuration.pyc
|
||||
${PYSITELIB}/hamster/configuration.pyo
|
||||
${PYSITELIB}/hamster/db.py
|
||||
${PYSITELIB}/hamster/db.pyc
|
||||
${PYSITELIB}/hamster/db.pyo
|
||||
${PYSITELIB}/hamster/defs.py
|
||||
${PYSITELIB}/hamster/defs.pyc
|
||||
${PYSITELIB}/hamster/defs.pyo
|
||||
${PYSITELIB}/hamster/dispatcher.py
|
||||
${PYSITELIB}/hamster/dispatcher.pyc
|
||||
${PYSITELIB}/hamster/dispatcher.pyo
|
||||
${PYSITELIB}/hamster/edit_activity.py
|
||||
${PYSITELIB}/hamster/edit_activity.pyc
|
||||
${PYSITELIB}/hamster/edit_activity.pyo
|
||||
${PYSITELIB}/hamster/eds.py
|
||||
${PYSITELIB}/hamster/eds.pyc
|
||||
${PYSITELIB}/hamster/eds.pyo
|
||||
${PYSITELIB}/hamster/graphics.py
|
||||
${PYSITELIB}/hamster/graphics.pyc
|
||||
${PYSITELIB}/hamster/graphics.pyo
|
||||
${PYSITELIB}/hamster/hamsterdbus.py
|
||||
${PYSITELIB}/hamster/hamsterdbus.pyc
|
||||
${PYSITELIB}/hamster/hamsterdbus.pyo
|
||||
${PYSITELIB}/hamster/i18n.py
|
||||
${PYSITELIB}/hamster/i18n.pyc
|
||||
${PYSITELIB}/hamster/i18n.pyo
|
||||
${PYSITELIB}/hamster/idle.py
|
||||
${PYSITELIB}/hamster/idle.pyc
|
||||
${PYSITELIB}/hamster/idle.pyo
|
||||
${PYSITELIB}/hamster/keybinder/__init__.py
|
||||
${PYSITELIB}/hamster/keybinder/__init__.pyc
|
||||
${PYSITELIB}/hamster/keybinder/__init__.pyo
|
||||
${PYSITELIB}/hamster/keybinder/_keybinder.la
|
||||
${PYSITELIB}/hamster/preferences.py
|
||||
${PYSITELIB}/hamster/preferences.pyc
|
||||
${PYSITELIB}/hamster/preferences.pyo
|
||||
${PYSITELIB}/hamster/reports.py
|
||||
${PYSITELIB}/hamster/reports.pyc
|
||||
${PYSITELIB}/hamster/reports.pyo
|
||||
${PYSITELIB}/hamster/stats.py
|
||||
${PYSITELIB}/hamster/stats.pyc
|
||||
${PYSITELIB}/hamster/stats.pyo
|
||||
${PYSITELIB}/hamster/storage.py
|
||||
${PYSITELIB}/hamster/storage.pyc
|
||||
${PYSITELIB}/hamster/storage.pyo
|
||||
${PYSITELIB}/hamster/stuff.py
|
||||
${PYSITELIB}/hamster/stuff.pyc
|
||||
${PYSITELIB}/hamster/stuff.pyo
|
||||
${PYSITELIB}/hamster/widgets.py
|
||||
${PYSITELIB}/hamster/widgets.pyc
|
||||
${PYSITELIB}/hamster/widgets.pyo
|
||||
share/gconf/schemas/hamster-applet.schemas
|
||||
share/hamster-applet/Hamster_Applet.xml
|
||||
share/hamster-applet/applet.ui
|
||||
share/hamster-applet/art/hamster-applet.png
|
||||
share/hamster-applet/art/stock_calendar-view-day.png
|
||||
share/hamster-applet/art/stock_calendar-view-month.png
|
||||
share/hamster-applet/art/stock_calendar-view-week.png
|
||||
share/hamster-applet/edit_activity.ui
|
||||
share/hamster-applet/hamster.db
|
||||
share/hamster-applet/preferences.ui
|
||||
share/hamster-applet/stats.ui
|
||||
share/icons/hicolor/16x16/apps/hamster-applet.png
|
||||
share/icons/hicolor/22x22/apps/hamster-applet.png
|
||||
share/icons/hicolor/32x32/apps/hamster-applet.png
|
||||
share/icons/hicolor/48x48/apps/hamster-applet.png
|
||||
share/icons/hicolor/scalable/apps/hamster-applet.svg
|
||||
share/locale/ar/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/as/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/be/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/bg/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/bn/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/bn_IN/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/ca/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/ca@valencia/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/cs/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/da/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/de/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/el/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/en_GB/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/es/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/et/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/eu/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/fi/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/fr/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/gl/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/gu/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/he/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/hi/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/hu/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/it/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/ja/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/kn/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/ko/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/ku/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/lt/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/lv/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/mai/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/mk/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/ml/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/mr/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/nb/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/nl/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/or/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/pa/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/pl/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/pt/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/ro/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/ru/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/si/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/sl/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/sq/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/sr/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/sr@latin/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/sv/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/ta/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/te/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/th/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/tr/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/uk/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/vi/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/zh_HK/LC_MESSAGES/hamster-applet.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/hamster-applet.mo
|
|
@ -1,7 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.8 2015/11/02 23:31:37 agc Exp $
|
||||
|
||||
SHA1 (hamster-applet-2.28.1.tar.gz) = 0ac2b8fe9dd395ed142c5e998d4e838318b700f9
|
||||
RMD160 (hamster-applet-2.28.1.tar.gz) = 552177320c5c0c3d62d682087a4fe680631198a5
|
||||
SHA512 (hamster-applet-2.28.1.tar.gz) = 7581216a553fd4978fbbe1ed93d3f8351cf854bef07f35bf26aadd9370ea56400db0fd291fbc72165ee9f88b4e9bab0b7ccecf58ef176fb19f36a3551b014c47
|
||||
Size (hamster-applet-2.28.1.tar.gz) = 639186 bytes
|
||||
SHA1 (patch-aa) = 39e3520d24d2b934139015253659838c801ba72e
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.3 2009/11/17 17:29:49 wiz Exp $
|
||||
|
||||
--- hamster/db.py.orig 2009-10-20 10:38:32.000000000 +0000
|
||||
+++ hamster/db.py
|
||||
@@ -35,7 +35,7 @@ import os, time
|
||||
import datetime
|
||||
import storage
|
||||
import stuff
|
||||
-from shutil import copy as copyfile
|
||||
+from shutil import copyfile
|
||||
import datetime as dt
|
||||
import gettext
|
||||
|
Loading…
Reference in a new issue