update to 0.8.4

changes:
-bugfixes
-build fix for qt4 (which doesn't work)
The security fix for CVE-2008-2950 is not yet integrated upstream.
This commit is contained in:
drochner 2008-07-15 10:34:21 +00:00
parent b77301c201
commit b88e673a02
6 changed files with 40 additions and 23 deletions

View file

@ -1,10 +1,8 @@
# $NetBSD: Makefile,v 1.30 2008/07/09 10:30:37 drochner Exp $
# $NetBSD: Makefile,v 1.31 2008/07/15 10:34:21 drochner Exp $
#
.include "../../print/poppler/Makefile.common"
PKGREVISION= 1
COMMENT= PDF rendering library
USE_TOOLS+= gmake

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile.common,v 1.16 2008/06/05 21:03:37 drochner Exp $
# $NetBSD: Makefile.common,v 1.17 2008/07/15 10:34:21 drochner Exp $
# used by print/poppler/Makefile
# used by print/poppler-qt4/Makefile
POPPLER_VERS= 0.8.3
POPPLER_VERS= 0.8.4
DISTNAME= poppler-${POPPLER_VERS}
CATEGORIES= print
MASTER_SITES= http://poppler.freedesktop.org/

View file

@ -1,9 +1,11 @@
$NetBSD: distinfo,v 1.30 2008/07/09 10:30:37 drochner Exp $
$NetBSD: distinfo,v 1.31 2008/07/15 10:34:21 drochner Exp $
SHA1 (poppler-0.8.3.tar.gz) = 763d18d9f0e625a936b3a3fbbcd00b58ddd2f84f
RMD160 (poppler-0.8.3.tar.gz) = f6553fdf468bd67ec8a7f943ba2cc7f141052302
Size (poppler-0.8.3.tar.gz) = 1463306 bytes
SHA1 (poppler-0.8.4.tar.gz) = 2ad0acfea3a8787b19c2882a2eac2f9d0afd5a48
RMD160 (poppler-0.8.4.tar.gz) = 96a5109d03211575c00a49d3efe1d583dd710dec
Size (poppler-0.8.4.tar.gz) = 1465322 bytes
SHA1 (patch-aa) = 43c63c16d3a845e394a8eb0c3a321944fcf17615
SHA1 (patch-ab) = e3d413ec50a098af06cb2efc2fac2042064498dd
SHA1 (patch-ag) = d1581a1ca40bba34146a4a6f4ee7d38b8f6ff3b7
SHA1 (patch-ag) = 258b8bff3d167914539e40c3263d36ce55e2ea01
SHA1 (patch-ah) = decbe82914bb0e710389b0b35bfd360942edf123
SHA1 (patch-ai) = d3d4411092b5c6dd61d3f197c01c3bcdad88cc0e
SHA1 (patch-aj) = 7599a5c14b4d2bdd83283275e71c5a720360f362

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ag,v 1.2 2008/04/15 19:57:00 drochner Exp $
$NetBSD: patch-ag,v 1.3 2008/07/15 10:34:21 drochner Exp $
--- qt4/src/Makefile.in.orig 2008-03-26 19:40:20.000000000 +0100
--- qt4/src/Makefile.in.orig 2008-06-28 17:18:39.000000000 +0200
+++ qt4/src/Makefile.in
@@ -61,7 +61,7 @@ libLTLIBRARIES_INSTALL = $(INSTALL)
@@ -62,7 +62,7 @@ libLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(lib_LTLIBRARIES)
am__DEPENDENCIES_1 =
libpoppler_qt4_la_DEPENDENCIES = \
@ -11,7 +11,7 @@ $NetBSD: patch-ag,v 1.2 2008/04/15 19:57:00 drochner Exp $
$(am__DEPENDENCIES_1) $(am__append_1)
am_libpoppler_qt4_la_OBJECTS = poppler-document.lo poppler-page.lo \
poppler-fontinfo.lo poppler-embeddedfile.lo poppler-textbox.lo \
@@ -297,7 +297,7 @@ libpoppler_qt4_la_SOURCES = \
@@ -303,7 +303,7 @@ libpoppler_qt4_la_SOURCES = \
poppler-export.h \
poppler-private.h
@ -20,12 +20,3 @@ $NetBSD: patch-ag,v 1.2 2008/04/15 19:57:00 drochner Exp $
$(FONTCONFIG_LIBS) $(POPPLER_QT4_LIBS) $(am__append_1)
libpoppler_qt4_la_LDFLAGS = -version-info 3:0:0
all: all-am
@@ -622,7 +622,7 @@ SUFFIXES: .moc
# This rule lets GNU make create any *.moc from the equivalent *.h
.h.moc:
- moc -i $< -o $@
+ ${QTDIR}/bin/moc -i $< -o $@
poppler-optcontent.lo: poppler-optcontent.moc

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ah,v 1.5 2008/07/15 10:34:21 drochner Exp $
--- poppler/Page.cc.orig 2008-07-02 15:45:43.000000000 +0200
+++ poppler/Page.cc
@@ -466,7 +466,7 @@ GBool Page::loadThumb(unsigned char **da
/* Get stream dict */
thumb.fetch(xref, &fetched_thumb);
- if (fetched_thumb.isNull()) {
+ if (!fetched_thumb.isStream()) {
fetched_thumb.free();
return gFalse;
}

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ai,v 1.5 2008/07/15 10:34:21 drochner Exp $
--- configure.orig 2008-07-02 16:30:43.000000000 +0200
+++ configure
@@ -27984,7 +27984,7 @@ fi
if test x$enable_poppler_qt4 = xyes; then
{ echo "$as_me:$LINENO: checking for Qt4 moc" >&5
echo $ECHO_N "checking for Qt4 moc... $ECHO_C" >&6; }
- MOCQT4=`which moc`
+ MOCQT4=${QTDIR}/bin/moc
mocversion=`$MOCQT4 -v 2>&1`
mocversiongrep=`echo $mocversion | grep "Qt 4"`
if test x"$mocversiongrep" != x"$mocversion"; then