Remove dependency to ruby-amstd package and bump PKG_REVISION.
This commit is contained in:
parent
6b2ef68415
commit
b8a99f5fbd
3 changed files with 32 additions and 4 deletions
|
@ -1,8 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.8 2003/08/30 05:56:26 taca Exp $
|
||||
# $NetBSD: Makefile,v 1.9 2004/02/11 15:46:32 taca Exp $
|
||||
# FreeBSD: ports/textproc/ruby-rdtool/Makefile,v 1.15 2001/01/30 19:20:09 knu Exp
|
||||
|
||||
DISTNAME= rdtool-${RUBY_RD_VERSION}
|
||||
PKGNAME= ${RUBY_PKGNAMEPREFIX}${DISTNAME}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://www2.pos.to/~tosh/ruby/rdtool/archive/
|
||||
|
||||
|
@ -17,7 +18,6 @@ DEPENDS+= ${RUBY_PKGNAMEPREFIX}strscan>=0.6.1:../../devel/ruby-strscan
|
|||
|
||||
DIST_SUBDIR= ruby
|
||||
USE_RUBY= yes
|
||||
USE_RUBY_AMSTD= yes
|
||||
INSTALL_TARGET= install install-rmi2html
|
||||
|
||||
REPLACE_RUBY= rmi2html.rb utils/rdswap.rb
|
||||
|
@ -46,6 +46,5 @@ post-install:
|
|||
${INSTALL_DATA} ${RUBY_SITELIBDIR}/rd/dot.rd2rc ${RUBY_EXAMPLESDIR}/rd
|
||||
|
||||
.include "Makefile.common"
|
||||
.include "../../devel/ruby-amstd/Makefile.common"
|
||||
.include "../../lang/ruby-base/Makefile.common"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.6 2003/09/10 15:57:31 taca Exp $
|
||||
$NetBSD: distinfo,v 1.7 2004/02/11 15:46:32 taca Exp $
|
||||
|
||||
SHA1 (ruby/rdtool-0.6.14.tar.gz) = 6c61ffad85c62c7d3708c19a8793c1f8b395a1c0
|
||||
Size (ruby/rdtool-0.6.14.tar.gz) = 58750 bytes
|
||||
SHA1 (patch-ac) = ba37c47329e4165cef8ccd9985566661bfee4791
|
||||
|
|
28
textproc/ruby-rdtool/patches/patch-ac
Normal file
28
textproc/ruby-rdtool/patches/patch-ac
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-ac,v 1.1 2004/02/11 15:46:32 taca Exp $
|
||||
|
||||
--- rdtoolconf.rb.orig 2003-03-08 21:45:07.000000000 +0900
|
||||
+++ rdtoolconf.rb
|
||||
@@ -4,12 +4,11 @@
|
||||
|
||||
require 'mkmf'
|
||||
require 'rbconfig'
|
||||
-require 'amstd/rbparams'
|
||||
|
||||
STDERR.print "creating Makefile\n"
|
||||
|
||||
-$bindir = RubyParams::BINDIR
|
||||
-$siterubydir = RubyParams::SITE_RB
|
||||
+$bindir = CONFIG["bindir"]
|
||||
+$siterubydir = CONFIG["sitedir"]
|
||||
$rddir = CONFIG["datadir"] + "/ruby/rd"
|
||||
$racc = "racc"
|
||||
|
||||
@@ -18,6 +17,8 @@ mfile.print <<"EOM"
|
||||
#
|
||||
# RDtool makefile
|
||||
|
||||
+prefix = #{CONFIG["prefix"]}
|
||||
+exec_prefix = #{CONFIG["exec_prefix"]}
|
||||
BIN_DIR = #{$bindir}
|
||||
SITE_RUBY = #{$siterubydir}
|
||||
RD_DIR = #{$rddir}
|
Loading…
Reference in a new issue