Check for __STDC_HOSTED__ to see whether or not to use prototypes and

<stdargs.h>, as well as __STDC__, so this'll build with gcc-3.2.2.
This commit is contained in:
fredb 2003-11-09 06:15:24 +00:00
parent e58d4e544b
commit b8a9c642b2
4 changed files with 50 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.3 2001/04/21 00:44:41 wiz Exp $
$NetBSD: distinfo,v 1.4 2003/11/09 06:15:24 fredb Exp $
SHA1 (pccts-1.33.22/pccts133mr22.zip) = ccdfaf8f69ddc59ad6d7e3f05922c693db0cf987
Size (pccts-1.33.22/pccts133mr22.zip) = 717522 bytes
@ -6,3 +6,6 @@ SHA1 (patch-aa) = f44db7a7fb0c8a81e8b5445b2ec7d6160c9a2fdc
SHA1 (patch-ab) = b9ebaf849cb738bd975cdee733afa3a3c0d8e0c9
SHA1 (patch-ac) = b249a362461e460be6be7195d96ea7705485105f
SHA1 (patch-ad) = 0af7bb8491402f8fb2e96fb0e5aa6cc117ffae0c
SHA1 (patch-ae) = bdfbc276cbf7217bdf48bb1b6df787d61f1d6267
SHA1 (patch-af) = 5910279eb5d9d216c1051c48038792fc3841c568
SHA1 (patch-ag) = 6637240de0c79b4f41f34d658ed99001adeab539

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ae,v 1.1 2003/11/09 06:15:24 fredb Exp $
--- h/pcctscfg.h.orig 1999-10-07 21:19:11.000000000 -0500
+++ h/pcctscfg.h
@@ -44,7 +44,7 @@
/* should test __STDC__ for 1, but some compilers don't set value, just def */
#ifndef __USE_PROTOS
-#ifdef __STDC__
+#if defined(__STDC__) || defined(__STDC_HOSTED__)
#define __USE_PROTOS
#endif
#ifdef __cplusplus
@@ -335,7 +335,7 @@ void special_fopen_actions(char * s)
#endif
#endif
-#ifdef __STDC__
+#if defined(__STDC__) || defined(__STDC_HOSTED__)
#ifndef PCCTS_USE_STDARG
#define PCCTS_USE_STDARG
#endif

View file

@ -0,0 +1,12 @@
$NetBSD: patch-af,v 1.1 2003/11/09 06:15:24 fredb Exp $
--- sorcerer/lib/sintstack.c.orig 1999-06-30 08:08:06.000000000 -0500
+++ sorcerer/lib/sintstack.c
@@ -26,6 +26,7 @@
* AHPCRC, University of Minnesota
* 1992-1994
*/
+#include "pcctscfg.h"
#include <stdio.h>
#include <setjmp.h>

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ag,v 1.1 2003/11/09 06:15:24 fredb Exp $
--- sorcerer/lib/sorlist.c.orig 1999-06-29 20:15:56.000000000 -0500
+++ sorcerer/lib/sorlist.c
@@ -26,6 +26,7 @@
* AHPCRC, University of Minnesota
* 1992-1994
*/
+#include "pcctscfg.h"
#include <stdio.h>
#include <setjmp.h>