Import py-roman-1.4.0 as math/py-roman.
This Python module provides methods for converting Integer from/to Roman.
This commit is contained in:
parent
9743eabf9e
commit
b8ca74a9c8
5 changed files with 52 additions and 0 deletions
1
math/py-roman/DESCR
Normal file
1
math/py-roman/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
This Python module provides methods for converting Integer from/to Roman.
|
21
math/py-roman/Makefile
Normal file
21
math/py-roman/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/10/05 07:43:12 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= roman-1.4.0
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= http://pypi.python.org/packages/source/r/roman/
|
||||
|
||||
MAINTAINER= obache@NetBSD.org
|
||||
HOMEPAGE= http://pypi.python.org/pypi/roman/
|
||||
COMMENT= Integer to Roman numerals converter for Python
|
||||
LICENSE= python-software-foundation
|
||||
|
||||
CONFLICTS+= ${PYPKGPREFIX}-docutils<=0.7
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
USE_LANGUAGES= # none
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
9
math/py-roman/PLIST
Normal file
9
math/py-roman/PLIST
Normal file
|
@ -0,0 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/10/05 07:43:12 obache Exp $
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/zip-safe
|
||||
${PYSITELIB}/roman.py
|
||||
${PYSITELIB}/roman.pyc
|
||||
${PYSITELIB}/roman.pyo
|
6
math/py-roman/distinfo
Normal file
6
math/py-roman/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/10/05 07:43:12 obache Exp $
|
||||
|
||||
SHA1 (roman-1.4.0.tar.gz) = 3d9cf0c46a4e3558785a9f7c90cd96a2d31dc9b0
|
||||
RMD160 (roman-1.4.0.tar.gz) = 9c9f1d8de8e19f6dcab02a28b2a28a1a7f3dd546
|
||||
Size (roman-1.4.0.tar.gz) = 3033 bytes
|
||||
SHA1 (patch-src_roman.py) = 3cbe70896a19b5d177b329f18dcb37a051f0305a
|
15
math/py-roman/patches/patch-src_roman.py
Normal file
15
math/py-roman/patches/patch-src_roman.py
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_roman.py,v 1.1.1.1 2011/10/05 07:43:12 obache Exp $
|
||||
|
||||
* replace deprecated operator `<>' with `!='
|
||||
|
||||
--- src/roman.py.orig 2009-07-23 16:34:18.000000000 +0000
|
||||
+++ src/roman.py
|
||||
@@ -41,7 +41,7 @@ def toRoman(n):
|
||||
"""convert integer to Roman numeral"""
|
||||
if not (0 < n < 5000):
|
||||
raise OutOfRangeError, "number out of range (must be 1..4999)"
|
||||
- if int(n) <> n:
|
||||
+ if int(n) != n:
|
||||
raise NotIntegerError, "decimals can not be converted"
|
||||
|
||||
result = ""
|
Loading…
Reference in a new issue