mlterm: pull an XIM fix commit from upstream.

Bump PKGREVISION.
This commit is contained in:
tsutsui 2024-02-23 12:44:28 +00:00
parent c106e9f132
commit b8d588e1f0
4 changed files with 73 additions and 3 deletions

View File

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.189 2023/11/23 16:20:41 tsutsui Exp $
# $NetBSD: Makefile,v 1.190 2024/02/23 12:44:28 tsutsui Exp $
DISTNAME= mlterm-3.9.3
PKGREVISION= 6
PKGREVISION= 7
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GITHUB:=arakiken/}
GITHUB_PROJECT= ${PKGBASE}

View File

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.98 2023/04/04 16:53:34 tsutsui Exp $
$NetBSD: distinfo,v 1.99 2024/02/23 12:44:28 tsutsui Exp $
BLAKE2s (mlterm-3.9.3.tar.gz) = d3730227673c203bd24c786b95a6c49751a3f554251e2b708a262994526207ec
SHA512 (mlterm-3.9.3.tar.gz) = 67c22ee8411cef499620a37e43af5609bb52cf8be6b617f0dfa6605217eb7f66227bfe073ca9b878606392fac26f94299221b5890fba1d90a3afc35a0f3132a1
@ -6,4 +6,6 @@ Size (mlterm-3.9.3.tar.gz) = 4272090 bytes
SHA1 (patch-configure) = 23e153937f154a2464fe6c76a3e7bfbe35a50805
SHA1 (patch-etc_font-fb) = 52c18f512c67ff530c0c326394fdf43956d71cb0
SHA1 (patch-tool_mlconfig_Makefile.in) = d1a8e0310d621a0b4a700d243bffbd445d28a95f
SHA1 (patch-uitoolkit_ui__xic.h) = 71f7c2c3e03d734afa87326a5d24616fda5ca82e
SHA1 (patch-uitoolkit_xlib_ui__xic.c) = eea01b83b844c517ea5b892cbf797ef8c78decd0
SHA1 (patch-vtemu_Makefile.in) = 172f12f73408489f782d63c8b0b7915af441d368

View File

@ -0,0 +1,15 @@
$NetBSD: patch-uitoolkit_ui__xic.h,v 1.1 2024/02/23 12:44:28 tsutsui Exp $
- pull an XIM fix commit to avoid possible stall with ibus-mozc
https://github.com/arakiken/mlterm/commit/b8750c1
--- uitoolkit/ui_xic.h.orig 2023-04-01 13:54:40.000000000 +0000
+++ uitoolkit/ui_xic.h
@@ -23,6 +23,7 @@ typedef struct ui_xic {
#elif defined(USE_XLIB)
XFontSet fontset;
XIMStyle style;
+ XPoint spot;
#endif
} ui_xic_t;

View File

@ -0,0 +1,53 @@
$NetBSD: patch-uitoolkit_xlib_ui__xic.c,v 1.1 2024/02/23 12:44:29 tsutsui Exp $
- pull an XIM fix commit to avoid possible stall with ibus-mozc
https://github.com/arakiken/mlterm/commit/b8750c1
--- uitoolkit/xlib/ui_xic.c.orig 2023-04-01 13:54:40.000000000 +0000
+++ uitoolkit/xlib/ui_xic.c
@@ -201,6 +201,7 @@ static int create_xic(ui_window_t *win)
win->xic->ic = xic;
win->xic->fontset = fontset;
win->xic->style = selected_style;
+ win->xic->spot = spot;
xim_ev_mask = 0;
@@ -352,6 +353,10 @@ int ui_xic_resized(ui_window_t *win) {
spot.y = 0;
}
+ if (spot.x == win->xic->spot.x && spot.y == win->xic->spot.y) {
+ return 0;
+ }
+
if ((preedit_attr = XVaCreateNestedList(0,
#ifdef SET_XNAREA_ATTR
XNArea, &rect,
@@ -365,6 +370,7 @@ int ui_xic_resized(ui_window_t *win) {
}
XSetICValues(win->xic->ic, XNPreeditAttributes, preedit_attr, NULL);
+ win->xic->spot = spot;
XFree(preedit_attr);
@@ -385,6 +391,10 @@ int ui_xic_set_spot(ui_window_t *win) {
return 0;
}
+ if (spot.x == win->xic->spot.x && spot.y == win->xic->spot.y) {
+ return 0;
+ }
+
if ((preedit_attr = XVaCreateNestedList(0, XNSpotLocation, &spot, NULL)) == NULL) {
#ifdef DEBUG
bl_warn_printf(BL_DEBUG_TAG " XvaCreateNestedList failed.\n");
@@ -394,6 +404,7 @@ int ui_xic_set_spot(ui_window_t *win) {
}
XSetICValues(win->xic->ic, XNPreeditAttributes, preedit_attr, NULL);
+ win->xic->spot = spot;
XFree(preedit_attr);