Third attempt to get a correct PLIST for qalculate:

Add locale message for sv. Bump revision.
Fix configure to detect libintl correctly on NetBSD.

Don't remove the entry again, fix the script if necessary!
This commit is contained in:
joerg 2006-06-08 12:00:03 +00:00
parent d56bb48be7
commit b90656bef9
4 changed files with 21 additions and 6 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.22 2006/05/26 23:38:59 wiz Exp $
# $NetBSD: Makefile,v 1.23 2006/06/08 12:00:03 joerg Exp $
DISTNAME= libqalculate-0.9.3
PKGNAME= qalculate-0.9.3
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=qalculate/}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.10 2006/05/26 23:38:59 wiz Exp $
@comment $NetBSD: PLIST,v 1.11 2006/06/08 12:00:04 joerg Exp $
bin/qalc
include/libqalculate/BuiltinFunctions.h
include/libqalculate/Calculator.h
@ -15,6 +15,7 @@ include/libqalculate/qalculate.h
include/libqalculate/util.h
lib/libqalculate.la
lib/pkgconfig/libqalculate.pc
share/locale/sv/LC_MESSAGES/libqalculate.mo
share/qalculate/currencies.xml
share/qalculate/datasets.xml
share/qalculate/elements.xml

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.10 2006/04/17 07:48:51 adam Exp $
$NetBSD: distinfo,v 1.11 2006/06/08 12:00:04 joerg Exp $
SHA1 (libqalculate-0.9.3.tar.gz) = 4944811a1bfb2f49d3dc59386dcd2aa740fc2ac1
RMD160 (libqalculate-0.9.3.tar.gz) = 9be6842126364fbd6b82127c92b2bfdbf7864777
Size (libqalculate-0.9.3.tar.gz) = 739562 bytes
SHA1 (patch-aa) = 6d54e5ad2fde952ec96df7638ce73ea47cf684b1
SHA1 (patch-ab) = 13947abbad4fc11fba6ea46fe503ccf9dda6f857
SHA1 (patch-ab) = 774b5328af0392c9b211b1394482e4b6cb0fb6f7
SHA1 (patch-ac) = 98e817d60fc4cd521e7d227ecd330364ec072ecd

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ab,v 1.5 2006/04/17 07:48:51 adam Exp $
$NetBSD: patch-ab,v 1.6 2006/06/08 12:00:04 joerg Exp $
--- configure.orig 2006-03-11 11:28:32.000000000 +0100
+++ configure
@ -41,3 +41,17 @@ $NetBSD: patch-ab,v 1.5 2006/04/17 07:48:51 adam Exp $
fi
@@ -23143,11 +23141,11 @@ extern "C"
#endif
/* We use char because int might match the return type of a gcc2
builtin and then its argument prototype would still apply. */
-char dgettext ();
+char dgettext (const char *, const char *);
int
main ()
{
-dgettext ();
+dgettext ("", "");
;
return 0;
}