Add iperf3 as version 3.0.11.
Iperf3 is a tool for active measurements of the maximum achievable bandwidth on IP networks. It supports tuning of various parameters related to timing, protocols, and buffers. For each test it reports the bandwidth, loss, and other parameters. This version, sometimes referred to as iperf3, is a redesign of an original version developed at NLANR/DAST. iperf3 is a new implementation from scratch, with the goal of a smaller, simpler code base, and a library version of the functionality that can be used in other programs. Iperf3 also has a number of features found in other tools such as nuttcp and netperf, but were missing from the original iperf. These include, for example, a zero-copy mode and optional JSON output. Note that iperf3 is NOT backwards compatible with the original iperf.
This commit is contained in:
parent
fb4857daa5
commit
b92df5d094
8 changed files with 103 additions and 0 deletions
13
net/iperf3/DESCR
Normal file
13
net/iperf3/DESCR
Normal file
|
@ -0,0 +1,13 @@
|
|||
Iperf3 is a tool for active measurements of the maximum achievable
|
||||
bandwidth on IP networks. It supports tuning of various parameters
|
||||
related to timing, protocols, and buffers. For each test it reports
|
||||
the bandwidth, loss, and other parameters.
|
||||
|
||||
This version, sometimes referred to as iperf3, is a redesign of an
|
||||
original version developed at NLANR/DAST. iperf3 is a new
|
||||
implementation from scratch, with the goal of a smaller, simpler code
|
||||
base, and a library version of the functionality that can be used in
|
||||
other programs. Iperf3 also has a number of features found in other tools
|
||||
such as nuttcp and netperf, but were missing from the original iperf.
|
||||
These include, for example, a zero-copy mode and optional JSON output.
|
||||
Note that iperf3 is NOT backwards compatible with the original iperf.
|
17
net/iperf3/Makefile
Normal file
17
net/iperf3/Makefile
Normal file
|
@ -0,0 +1,17 @@
|
|||
# $NetBSD: Makefile,v 1.1 2015/02/02 12:25:20 he Exp $
|
||||
|
||||
DISTNAME= iperf-3.0.11
|
||||
PKGNAME= ${DISTNAME:S/iperf/iperf3/}
|
||||
CATEGORIES= net benchmarks
|
||||
MASTER_SITES= http://downloads.es.net/pub/iperf/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://software.es.net/iperf/
|
||||
COMMENT= TCP and UDP bandwidth performance measurement tool
|
||||
LICENSE= modified-bsd
|
||||
|
||||
USE_LANGUAGES= c
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
6
net/iperf3/PLIST
Normal file
6
net/iperf3/PLIST
Normal file
|
@ -0,0 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2015/02/02 12:25:20 he Exp $
|
||||
bin/iperf3
|
||||
include/iperf_api.h
|
||||
lib/libiperf.la
|
||||
man/man1/iperf3.1
|
||||
man/man3/libiperf.3
|
9
net/iperf3/distinfo
Normal file
9
net/iperf3/distinfo
Normal file
|
@ -0,0 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.1 2015/02/02 12:25:20 he Exp $
|
||||
|
||||
SHA1 (iperf-3.0.11.tar.gz) = 35e31cc320e4f2264bf51f6ad1e7e0d81341135a
|
||||
RMD160 (iperf-3.0.11.tar.gz) = eb371c0879fad6f2068a279704d637123bbd9162
|
||||
Size (iperf-3.0.11.tar.gz) = 424267 bytes
|
||||
SHA1 (patch-src_cjson.c) = b195f308ea6d7652a5fc65f1031e5642da2e611b
|
||||
SHA1 (patch-src_iperf__api.h) = e84175a031c5dcde5ade975a3a63c5fad898bf97
|
||||
SHA1 (patch-src_iperf__server__api.c) = 124d2a57ad8d6694a4eea57366e9d88cc4b4a578
|
||||
SHA1 (patch-src_units.c) = 95e1e22af16b4996f6ec0e39fc14d137425003a4
|
15
net/iperf3/patches/patch-src_cjson.c
Normal file
15
net/iperf3/patches/patch-src_cjson.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_cjson.c,v 1.1 2015/02/02 12:25:20 he Exp $
|
||||
|
||||
Avoid compiler warning for using signed chars with tolower().
|
||||
|
||||
--- src/cjson.c.orig 2015-01-09 17:44:11.000000000 +0000
|
||||
+++ src/cjson.c
|
||||
@@ -56,7 +56,7 @@ static int cJSON_strcasecmp( const char
|
||||
return ( s1 == s2 ) ? 0 : 1;
|
||||
if ( ! s2 )
|
||||
return 1;
|
||||
- for ( ; tolower(*s1) == tolower(*s2); ++s1, ++s2)
|
||||
+ for ( ; tolower((u_char)*s1) == tolower((u_char)*s2); ++s1, ++s2)
|
||||
if( *s1 == 0 )
|
||||
return 0;
|
||||
return tolower(*(const unsigned char *)s1) - tolower(*(const unsigned char *)s2);
|
14
net/iperf3/patches/patch-src_iperf__api.h
Normal file
14
net/iperf3/patches/patch-src_iperf__api.h
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-src_iperf__api.h,v 1.1 2015/02/02 12:25:20 he Exp $
|
||||
|
||||
Include <sys/time.h> for struct timeval definition.
|
||||
|
||||
--- src/iperf_api.h.orig 2015-01-09 17:44:11.000000000 +0000
|
||||
+++ src/iperf_api.h
|
||||
@@ -27,6 +27,7 @@
|
||||
#ifndef __IPERF_API_H
|
||||
#define __IPERF_API_H
|
||||
|
||||
+#include <sys/time.h>
|
||||
#include <setjmp.h>
|
||||
|
||||
struct iperf_test;
|
14
net/iperf3/patches/patch-src_iperf__server__api.c
Normal file
14
net/iperf3/patches/patch-src_iperf__server__api.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-src_iperf__server__api.c,v 1.1 2015/02/02 12:25:20 he Exp $
|
||||
|
||||
Unused variable.
|
||||
|
||||
--- src/iperf_server_api.c.orig 2015-01-09 17:44:11.000000000 +0000
|
||||
+++ src/iperf_server_api.c
|
||||
@@ -128,7 +128,6 @@ iperf_accept(struct iperf_test *test)
|
||||
{
|
||||
int s;
|
||||
signed char rbuf = ACCESS_DENIED;
|
||||
- char cookie[COOKIE_SIZE];
|
||||
socklen_t len;
|
||||
struct sockaddr_storage addr;
|
||||
|
15
net/iperf3/patches/patch-src_units.c
Normal file
15
net/iperf3/patches/patch-src_units.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_units.c,v 1.1 2015/02/02 12:25:20 he Exp $
|
||||
|
||||
Avoid warning for using toupper() with signed chars.
|
||||
|
||||
--- src/units.c.orig 2015-01-09 17:44:11.000000000 +0000
|
||||
+++ src/units.c
|
||||
@@ -259,7 +259,7 @@ extern "C"
|
||||
{
|
||||
inNum *= 8;
|
||||
}
|
||||
- switch (toupper(inFormat))
|
||||
+ switch (toupper((u_char)inFormat))
|
||||
{
|
||||
case 'B':
|
||||
conv = UNIT_CONV;
|
Loading…
Reference in a new issue