Add dynipclient, a client program for the dynip.com commercial dynamic-DNS

service.  (Unlike many dynamic-DNS services, this one detects an offline
condition and can change the IP address to a user-specified offline IP.)
This commit is contained in:
tv 2001-08-28 13:10:46 +00:00
parent f0a2d8ef15
commit b938466153
6 changed files with 112 additions and 0 deletions

23
net/dynipclient/Makefile Normal file
View file

@ -0,0 +1,23 @@
# $NetBSD: Makefile,v 1.1.1.1 2001/08/28 13:10:46 tv Exp $
#
DISTNAME= dynip_3.00
PKGNAME= dynipclient-3.00
CATEGORIES= net
MASTER_SITES= ftp://ftp.dynip.com/software/unix/
MAINTAINER= tv@netbsd.org
HOMEPAGE= http://www.dynip.com/
COMMENT= Client for the dynip.com dynamic DNS service
WRKSRC= ${WRKDIR}
do-build:
cd ${WRKSRC} && ./Configure freebsd ${PREFIX}/bin /etc ${PREFIX}/man
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dynipadmin ${PREFIX}/bin/
${INSTALL_PROGRAM} ${WRKSRC}/dynipclient ${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/*.1 ${PREFIX}/man/man1/
.include "../../mk/bsd.pkg.mk"

6
net/dynipclient/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2001/08/28 13:10:46 tv Exp $
SHA1 (dynip_3.00.tar.gz) = 51f92eb9fbfcf2f12349c5e3673ea967cc3256d4
Size (dynip_3.00.tar.gz) = 37239 bytes
SHA1 (patch-aa) = ff1a5be64b46675f331b73415acdb04abc62936b
SHA1 (patch-ab) = d17b71dababab0149322e6954757eb3e46d9383c

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.1.1.1 2001/08/28 13:10:46 tv Exp $
--- opt.c.orig Mon Aug 27 12:19:27 2001
+++ opt.c Mon Aug 27 12:19:42 2001
@@ -80,6 +80,7 @@
*/
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include "opt.h"

View file

@ -0,0 +1,50 @@
$NetBSD: patch-ab,v 1.1.1.1 2001/08/28 13:10:46 tv Exp $
--- Makefile.X.orig Tue Aug 28 08:52:40 2001
+++ Makefile.X Tue Aug 28 08:54:08 2001
@@ -4,8 +4,8 @@
# instead! #
# #
#################################################################
-CFLAGS=%cflags%
-LIBS=%libs%
+CFLAGS+=%cflags%
+LIBS=%libs% ${LDFLAGS}
MANPATH=%manpath%
OSTYPE=-DDYNIP_OSTYPE=%ostype%
BINDIR=%bindir%
@@ -15,27 +15,25 @@
all: dynipclient dynipadmin
dynipclient.o: dynipclient.c dynipclient.h dynipgbl.h
- cc -O ${CFLAGS} ${CFGDIRDEF} -c dynipclient.c
+ ${CC} ${CFLAGS} ${CFGDIRDEF} -c dynipclient.c
dynipclient: dynipclient.o prof.o opt.o log.o
- cc -o dynipclient dynipclient.o prof.o opt.o log.o ${LIBS}
- strip dynipclient
+ ${CC} -o dynipclient dynipclient.o prof.o opt.o log.o ${LIBS}
dynipadmin.o: dynipadmin.c dynipadmin.h prof.h dynipgbl.h opt.c opt.h
- cc -O ${OSTYPE} ${CFLAGS} ${CFGDIRDEF} -c dynipadmin.c
+ ${CC} ${OSTYPE} ${CFLAGS} ${CFGDIRDEF} -c dynipadmin.c
dynipadmin: dynipadmin.o prof.o opt.o
- cc -o dynipadmin dynipadmin.o opt.o prof.o ${LIBS}
- strip dynipadmin
+ ${CC} -o dynipadmin dynipadmin.o opt.o prof.o ${LIBS}
prof.o: prof.c prof.h
- cc -O -c prof.c
+ ${CC} ${CFLAGS} -c prof.c
opt.o: opt.c opt.h
- cc -O -c opt.c
+ ${CC} ${CFLAGS} -c opt.c
log.o: log.c log.h
- cc -O -c log.c
+ ${CC} ${CFLAGS} -c log.c
# Copy the MAN pages for the dynipclient and dynipadmin program.
# Must run with ROOT in order to save in the man directory

16
net/dynipclient/pkg/DESCR Normal file
View file

@ -0,0 +1,16 @@
Dynip(sm) is a Dynamic IP Management System which allows Internet
hosts with dynamic IP addresses, such as dial-up users, to have a
permanent static Internet Name. Now, you can register your own
personal Internet Name that constantly refers to your dynamic
IP address, anywhere in the world! Your Internet Name becomes
integrated into the existing Domain Name System (DNS) on the
Internet within seconds of your name registration! People
can refer to your machine by means of a simple static Internet
name, allowing you to make your own unix servers available to
the public by publishing your Internet name. You never again
have to post your dynamic IP address to a web page, or run a
silly finger server informing others of your current IP address.
Current Pricing for DynIP Services are available from our
Web Site at http://www.dynip.com. Corporate pricing and custom
service quote requests can be send by email to sales@dynip.com.

View file

@ -0,0 +1,5 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2001/08/28 13:10:46 tv Exp $
bin/dynipadmin
bin/dynipclient
man/man1/dynipadmin.1
man/man1/dynipclient.1