Prepare configure for changes in the libtool m4 macros of libtool 2.2:
- explicitly request finding the C++ compiler before trying to run it
This commit is contained in:
parent
10be49f154
commit
b938911f20
2 changed files with 18 additions and 10 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.13 2009/07/26 18:42:04 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.14 2009/09/14 15:18:36 joerg Exp $
|
||||
|
||||
SHA1 (hal-0.5.11.tar.bz2) = 1ddb7895d2ddc2464b553ad11f7ba38860478ae9
|
||||
RMD160 (hal-0.5.11.tar.bz2) = 741cfe82f0bc2d67106b24cfe526a754ab36e45f
|
||||
|
@ -20,7 +20,7 @@ SHA1 (patch-an) = 0307b2f0f6bb5e4a6d7bf837163e74749b7d24b2
|
|||
SHA1 (patch-ao) = 9099fa4783921a0389b874b8f6d3f7b890810b34
|
||||
SHA1 (patch-ap) = 4846d30f51239cca5ea895c700d7a7b15efd948e
|
||||
SHA1 (patch-aq) = 7d0b224b4b1e6052983a6512217eee4f530e0720
|
||||
SHA1 (patch-na) = f4344e2aa02e67c968f9723495c533c3a9a199fd
|
||||
SHA1 (patch-na) = eff415fbf9b591f4be7b7a45ee8996e20eaf28ea
|
||||
SHA1 (patch-nb) = 1693b7a2faa5bee20a594f0b60b8ff6caea0efdc
|
||||
SHA1 (patch-nc) = 32453e49734902749ce24eb4364fc7f531986227
|
||||
SHA1 (patch-nd) = 40159d1d171c3e0dc53ac83e0e37e6be409dfbd3
|
||||
|
|
|
@ -1,8 +1,16 @@
|
|||
$NetBSD: patch-na,v 1.4 2009/01/03 01:28:34 obache Exp $
|
||||
$NetBSD: patch-na,v 1.5 2009/09/14 15:18:36 joerg Exp $
|
||||
|
||||
--- configure.in.orig 2008-05-07 23:24:31.000000000 +0000
|
||||
--- configure.in.orig 2008-05-08 01:24:31.000000000 +0200
|
||||
+++ configure.in
|
||||
@@ -448,7 +448,7 @@ AM_CONDITIONAL([HAVE_LIBPCI], [test "x$U
|
||||
@@ -30,6 +30,7 @@ AC_SUBST(LT_AGE)
|
||||
AC_ISC_POSIX
|
||||
AC_PROG_CC
|
||||
AM_PROG_CC_C_O
|
||||
+AC_PROG_CXX
|
||||
AC_HEADER_STDC
|
||||
AC_PROG_LIBTOOL
|
||||
AC_PROG_MAKE_SET
|
||||
@@ -448,7 +449,7 @@ AM_CONDITIONAL([HAVE_LIBPCI], [test "x$U
|
||||
|
||||
AC_ARG_WITH([backend],
|
||||
AS_HELP_STRING([--with-backend=<name>],
|
||||
|
@ -11,7 +19,7 @@ $NetBSD: patch-na,v 1.4 2009/01/03 01:28:34 obache Exp $
|
|||
[backend=$withval])
|
||||
if ! test -z "$with_backend" ; then
|
||||
HALD_BACKEND="$with_backend"
|
||||
@@ -457,6 +457,9 @@ else
|
||||
@@ -457,6 +458,9 @@ else
|
||||
*-*-solaris*)
|
||||
HALD_BACKEND="solaris"
|
||||
;;
|
||||
|
@ -21,7 +29,7 @@ $NetBSD: patch-na,v 1.4 2009/01/03 01:28:34 obache Exp $
|
|||
*-*-freebsd*)
|
||||
HALD_BACKEND="freebsd"
|
||||
;;
|
||||
@@ -472,6 +475,7 @@ AM_CONDITIONAL(HALD_COMPILE_DUMMY, [test
|
||||
@@ -472,6 +476,7 @@ AM_CONDITIONAL(HALD_COMPILE_DUMMY, [test
|
||||
AM_CONDITIONAL(HALD_COMPILE_LINUX, [test x$HALD_BACKEND = xlinux], [Compiling for Linux])
|
||||
AM_CONDITIONAL(HALD_COMPILE_FREEBSD, [test x$HALD_BACKEND = xfreebsd], [Compiling for FreeBSD])
|
||||
AM_CONDITIONAL(HALD_COMPILE_SOLARIS, [test x$HALD_BACKEND = xsolaris], [Compiling for Solaris])
|
||||
|
@ -29,7 +37,7 @@ $NetBSD: patch-na,v 1.4 2009/01/03 01:28:34 obache Exp $
|
|||
AC_SUBST(HALD_BACKEND)
|
||||
|
||||
dnl DBUS API is subject to changes
|
||||
@@ -641,13 +645,14 @@ fi
|
||||
@@ -641,13 +646,14 @@ fi
|
||||
AC_MSG_RESULT($have_glib_2_14)
|
||||
|
||||
# volume_id
|
||||
|
@ -48,7 +56,7 @@ $NetBSD: patch-na,v 1.4 2009/01/03 01:28:34 obache Exp $
|
|||
esac
|
||||
|
||||
# OS specific libs
|
||||
@@ -1004,6 +1009,9 @@ hald/linux/addons/Makefile
|
||||
@@ -1004,6 +1010,9 @@ hald/linux/addons/Makefile
|
||||
hald/solaris/Makefile
|
||||
hald/solaris/probing/Makefile
|
||||
hald/solaris/addons/Makefile
|
||||
|
@ -58,7 +66,7 @@ $NetBSD: patch-na,v 1.4 2009/01/03 01:28:34 obache Exp $
|
|||
hald/freebsd/Makefile
|
||||
hald/freebsd/probing/Makefile
|
||||
hald/freebsd/libprobe/Makefile
|
||||
@@ -1014,6 +1022,7 @@ libhal-storage/Makefile
|
||||
@@ -1014,6 +1023,7 @@ libhal-storage/Makefile
|
||||
tools/Makefile
|
||||
tools/freebsd/Makefile
|
||||
tools/linux/Makefile
|
||||
|
|
Loading…
Reference in a new issue