Properly deal with configuration files by respecting PKG_SYSCONFBASE.

Bump PKGREVISION to 1.
This commit is contained in:
jmmv 2010-11-09 10:37:12 +00:00
parent 4320f5806f
commit b95bc03bb9
5 changed files with 45 additions and 11 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.74 2010/10/27 13:24:09 tsutsui Exp $
# $NetBSD: Makefile,v 1.75 2010/11/09 10:37:12 jmmv Exp $
#
DISTNAME= qemu-0.13.0
PKGREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://download.savannah.gnu.org/releases/qemu/
@ -25,6 +26,13 @@ BUILD_DEPENDS+= texi2html-[0-9]*:../../textproc/texi2html
CONFIGURE_ENV+= mansuffix=/${PKGMANDIR}
CONFIGURE_ARGS+= --prefix=${PREFIX:Q}
CONFIGURE_ARGS+= --interp-prefix=${PREFIX:Q}/share/qemu
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR:Q}
CONF_FILES= ${EGDIR}/target-x86_64.conf \
${PKG_SYSCONFDIR}/target-x86_64.conf
EGDIR= ${PREFIX}/share/examples/qemu
INSTALL_MAKE_FLAGS= egdir=${EGDIR}
PKG_SYSCONFSUBDIR= qemu
# Avoid clash with system include file:
pre-patch:

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.23 2010/10/27 13:24:09 tsutsui Exp $
@comment $NetBSD: PLIST,v 1.24 2010/11/09 10:37:12 jmmv Exp $
bin/qemu
${PLIST.alpha}bin/qemu-alpha
${PLIST.arm}bin/qemu-arm
@ -43,6 +43,7 @@ man/man8/qemu-nbd.8
share/doc/qemu/Makefile.multinode-NetBSD
share/doc/qemu/qemu-doc.html
share/doc/qemu/qemu-tech.html
share/examples/qemu/target-x86_64.conf
share/qemu/bamboo.dtb
share/qemu/bios.bin
share/qemu/gpxe-eepro100-80861209.rom

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.61 2010/10/27 13:24:09 tsutsui Exp $
$NetBSD: distinfo,v 1.62 2010/11/09 10:37:12 jmmv Exp $
SHA1 (qemu-0.13.0.tar.gz) = 250bba1fdb505a787c48331b6b02f54282edfc76
RMD160 (qemu-0.13.0.tar.gz) = 4a6faaf38d5616fb7bedc1a6408de1dbb3ec360c
@ -6,7 +6,7 @@ Size (qemu-0.13.0.tar.gz) = 5184531 bytes
SHA1 (patch-aa) = bc2f9ea4bd468b1c8bd5623b21ea7631fe5466c3
SHA1 (patch-ao) = e515093b6ea99f9cba665de022fd62f3be911569
SHA1 (patch-ba) = 217eb00a0cabd460981026a275d18b6c02914a1c
SHA1 (patch-dd) = 3fe4e1f4eec6a91766253cd7b6ae82472a99adf2
SHA1 (patch-dd) = bd8016bdeab043f2b2c12728b11e8b54e75dcce9
SHA1 (patch-de) = 225eaa996fccc02b17be0099d943c75302600ada
SHA1 (patch-ed) = c30e147005e41fbf6d08457634d94cd90545cbb5
SHA1 (patch-ee) = 54811c6a45dee3aa1a4ad6c956053c23aa14146a
@ -24,3 +24,4 @@ SHA1 (patch-ep) = 03723d2f3ed666616d8e7701bfe32e104df9e3c9
SHA1 (patch-eq) = c6854cb155be431de15ba23f19e619df8cb7fbba
SHA1 (patch-er) = dcc723b1ecdcb78b080b5d05e2b7849e8721beec
SHA1 (patch-es) = 23b89cbcef79fc4f817525a6b8d62b47b2a3fc2c
SHA1 (patch-et) = 1d3fb0fee7fcea551aaa1c2a59cf70aeff85028d

View file

@ -1,13 +1,16 @@
$NetBSD: patch-dd,v 1.4 2010/10/27 13:24:09 tsutsui Exp $
$NetBSD: patch-dd,v 1.5 2010/11/09 10:37:12 jmmv Exp $
Remove confsuffix from sysconfdir so that our PKG_SYSCONFSUBDIR setting
works.
Install man pages into ${PREFIX}/man, not ${PREFIX}/share/man.
Handle arm and armeb case on NetBSD.
XXX: it looks mips is always treated as big endian.
--- configure.orig 2010-07-28 01:55:42.000000000 +0000
+++ configure 2010-08-09 20:36:55.000000000 +0000
@@ -199,13 +199,19 @@
--- configure.orig 2010-10-15 20:56:09.000000000 +0000
+++ configure
@@ -199,13 +199,19 @@ elif check_define __s390__ ; then
else
cpu="s390"
fi
@ -28,7 +31,7 @@ XXX: it looks mips is always treated as big endian.
cpu="$cpu"
;;
i386|i486|i586|i686|i86pc|BePC)
@@ -285,7 +291,7 @@
@@ -285,12 +291,12 @@ bigendian="no"
mingw32="no"
EXESUF=""
prefix="/usr/local"
@ -37,7 +40,13 @@ XXX: it looks mips is always treated as big endian.
datadir="\${prefix}/share/qemu"
docdir="\${prefix}/share/doc/qemu"
bindir="\${prefix}/bin"
@@ -1036,7 +1042,7 @@
sysconfdir="\${prefix}/etc"
-confsuffix="/qemu"
+confsuffix=""
slirp="yes"
fmod_lib=""
fmod_inc=""
@@ -1036,7 +1042,7 @@ else
# if cross compiling, cannot launch a program, so make a static guess
case "$cpu" in
@ -46,7 +55,7 @@ XXX: it looks mips is always treated as big endian.
bigendian=yes
;;
esac
@@ -2212,7 +2218,7 @@
@@ -2212,7 +2218,7 @@ case "$cpu" in
i386|x86_64|alpha|cris|hppa|ia64|m68k|microblaze|mips|mips64|ppc|ppc64|s390|s390x|sparc|sparc64)
ARCH=$cpu
;;

View file

@ -0,0 +1,15 @@
$NetBSD: patch-et,v 1.1 2010/11/09 10:37:12 jmmv Exp $
--- Makefile.orig 2010-10-15 20:56:09.000000000 +0000
+++ Makefile
@@ -179,8 +179,8 @@ ifdef CONFIG_POSIX
endif
install-sysconfig:
- $(INSTALL_DIR) "$(DESTDIR)$(sysconfdir)/qemu"
- $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(DESTDIR)$(sysconfdir)/qemu"
+ $(INSTALL_DIR) "$(DESTDIR)$(egdir)"
+ $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(DESTDIR)$(egdir)"
install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig
$(INSTALL_DIR) "$(DESTDIR)$(bindir)"