fix missed from previous: Darwin 7.x doesn't appear to want the

"-u PyMac_Error" when linking the shared library.
This commit is contained in:
grant 2004-12-19 05:45:39 +00:00
parent beaba1d487
commit b9c5791d74
2 changed files with 20 additions and 8 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.2 2004/12/19 05:30:14 grant Exp $
$NetBSD: distinfo,v 1.3 2004/12/19 05:45:39 grant Exp $
SHA1 (Python-2.4.tar.bz2) = 80c06f491a4b2a629e868540150faf22c5d0e41e
Size (Python-2.4.tar.bz2) = 7840762 bytes
@ -13,5 +13,5 @@ SHA1 (patch-ah) = 6f5cff1f9f2482c59ef442bf019a1f3ad9fe21e8
SHA1 (patch-ai) = 6435c5a7269c14d94eab6fb9777b9d059507e7b8
SHA1 (patch-aj) = e471737ade95423039661b475f2dd0fc27aa9dac
SHA1 (patch-ak) = f2e1d4087a94490bd3589a8c829ec72e04f31f72
SHA1 (patch-al) = bd37238a62dc9a0f99b95aaac8de622a28919761
SHA1 (patch-al) = 789a62b0efa9044ea412d6e1ef47c62d9ea0ec1a
SHA1 (patch-am) = aa71ec2f9cc8f434ff38b19df23b5dd433e13e5a

View file

@ -1,4 +1,4 @@
$NetBSD: patch-al,v 1.2 2004/12/19 05:30:14 grant Exp $
$NetBSD: patch-al,v 1.3 2004/12/19 05:45:39 grant Exp $
--- configure.orig 2004-11-07 12:24:12.000000000 +1100
+++ configure
@ -40,7 +40,19 @@ $NetBSD: patch-al,v 1.2 2004/12/19 05:30:14 grant Exp $
;;
esac
;;
@@ -10295,7 +10310,7 @@ then
@@ -10165,7 +10180,10 @@ fi
case "$enable_toolbox_glue" in
yes)
extra_machdep_objs="Python/mactoolboxglue.o"
- extra_undefs="-u _PyMac_Error"
+ case $ac_sys_release in
+ 7*) extra_undefs=;;
+ *) extra_undefs="-u _PyMac_Error";;
+ esac
cat >>confdefs.h <<\_ACEOF
#define USE_TOOLBOX_OBJECT_GLUE 1
@@ -10295,7 +10313,7 @@ then
LDSHARED="$LDSHARED "'-Wl,-F$(PYTHONFRAMEWORKPREFIX) -framework $(PYTHONFRAMEWORK)'
else
# No framework. Ignore undefined symbols, assuming they come from Python
@ -49,7 +61,7 @@ $NetBSD: patch-al,v 1.2 2004/12/19 05:30:14 grant Exp $
fi ;;
Darwin/1.4*|Darwin/5.*|Darwin/6.*)
LDSHARED='$(CC) $(LDFLAGS) -bundle'
@@ -10305,8 +10320,8 @@ then
@@ -10305,8 +10323,8 @@ then
LDSHARED="$LDSHARED "'-Wl,-F$(PYTHONFRAMEWORKPREFIX) -framework $(PYTHONFRAMEWORK)'
else
# No framework, use the Python app as bundle-loader
@ -60,7 +72,7 @@ $NetBSD: patch-al,v 1.2 2004/12/19 05:30:14 grant Exp $
fi ;;
Darwin/*)
# Use -undefined dynamic_lookup whenever possible (10.3 and later).
@@ -10324,8 +10339,8 @@ then
@@ -10324,8 +10342,8 @@ then
LDSHARED="$LDSHARED "'-Wl,-F$(PYTHONFRAMEWORKPREFIX) -framework $(PYTHONFRAMEWORK)'
else
# No framework, use the Python app as bundle-loader
@ -71,7 +83,7 @@ $NetBSD: patch-al,v 1.2 2004/12/19 05:30:14 grant Exp $
fi
fi
;;
@@ -10370,6 +10385,7 @@ then
@@ -10370,6 +10388,7 @@ then
fi;;
Linux*|GNU*) CCSHARED="-fPIC";;
BSD/OS*/4*) CCSHARED="-fpic";;
@ -79,7 +91,7 @@ $NetBSD: patch-al,v 1.2 2004/12/19 05:30:14 grant Exp $
FreeBSD*|NetBSD*|OpenBSD*) CCSHARED="-fPIC";;
OpenUNIX*|UnixWare*)
if test "$GCC" = "yes"
@@ -14297,6 +14313,7 @@ cat >>conftest.$ac_ext <<_ACEOF
@@ -14297,6 +14316,7 @@ cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include "confdefs.h"