Fix compilation with GCC 3.4+. Let imake decide where to place

the man page, don't install it twice. Bump revision.
This commit is contained in:
joerg 2005-12-04 01:17:43 +00:00
parent 6ff3bdda92
commit ba06453866
4 changed files with 19 additions and 27 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.17 2005/04/11 21:48:14 tv Exp $
# $NetBSD: Makefile,v 1.18 2005/12/04 01:17:43 joerg Exp $
DISTNAME= xautolock-pl15
PKGNAME= xautolock-1.15
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XCONTRIB:=applications/}
EXTRACT_SUFX= .tgz
@ -14,19 +14,4 @@ PKG_INSTALLATION_TYPES= overwrite pkgviews
USE_IMAKE= YES
.include "../../mk/bsd.prefs.mk"
.if (${OPSYS} == SunOS)
PLIST_SRC= ${WRKDIR}/PLIST
post-install:
${GREP} -v '^man/cat' ${PKGDIR}/PLIST >${PLIST_SRC}
.else
INSTALLATION_DIRS= man/man1
post-install:
cd ${WRKSRC}; \
${INSTALL_MAN} xautolock.man ${PREFIX}/man/man1/xautolock.1
.endif
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2001/10/31 22:11:57 zuntum Exp $
@comment $NetBSD: PLIST,v 1.2 2005/12/04 01:17:43 joerg Exp $
bin/xautolock
man/cat1/xautolock.0
man/man1/xautolock.1
${IMAKE_MAN_DIR}/xautolock.${IMAKE_MANNEWSUFFIX}

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.5 2005/02/23 17:36:21 wiz Exp $
$NetBSD: distinfo,v 1.6 2005/12/04 01:17:43 joerg Exp $
SHA1 (xautolock-pl15.tgz) = 5bc632141a4cf76fb6453921f34c2f493a1ff08d
RMD160 (xautolock-pl15.tgz) = 9b6ffc398593bc8bd1de59616fd8e7e7091bd919
Size (xautolock-pl15.tgz) = 39240 bytes
SHA1 (patch-aa) = 1213abeb844c22752c5cda040e7228f1526fa9eb
SHA1 (patch-aa) = 1cd1346fb50827bed5c8cac3ff65519180f30444
SHA1 (patch-ab) = 1299556b89466018de5553febe4bed8df8eab09d

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.4 2003/08/09 08:32:15 tron Exp $
$NetBSD: patch-aa,v 1.5 2005/12/04 01:17:43 joerg Exp $
--- xautolock.c.orig 1999-03-11 23:43:25.000000000 +0100
+++ xautolock.c 2003-08-09 10:29:28.000000000 +0200
--- xautolock.c.orig 1999-03-11 22:43:25.000000000 +0000
+++ xautolock.c
@@ -297,6 +297,8 @@
* with vroot.h, because it needs to know the real root window.
*/
@ -23,7 +23,15 @@ $NetBSD: patch-aa,v 1.4 2003/08/09 08:32:15 tron Exp $
#include <unistd.h>
#endif /* !apollo && !VMS */
@@ -2028,7 +2034,9 @@
@@ -1969,6 +1975,7 @@ Display* d; /* display pointer */
#ifdef __GNUC__
default: /* Makes gcc -Wall shut up. */
+ break;
#endif /* __GNUC__ */
}
}
@@ -2028,7 +2035,9 @@ Display* d; /* display pointer */
#else /* VMS */
if (locker_pid)
{
@ -34,7 +42,7 @@ $NetBSD: patch-aa,v 1.4 2003/08/09 08:32:15 tron Exp $
union wait status; /* childs process status */
#else /* !UTEKV && !SYSV && !SVR4 */
int status = 0; /* childs process status */
@@ -2762,8 +2770,23 @@
@@ -2762,8 +2771,23 @@ String argv[]; /* array of arguments
CheckConnectionAndSendMessage (d);