atkmm: updaetd to 2.28.3

atkmm 2.28.3 (stable):

Build:
* Support building with Visual Studio 2022
* Meson build: Specify 'check' option in run_command()
  Will be necessary with future versions of Meson.
* Meson build: Perl is not required by new versions of mm-common
* Meson build: Avoid unnecessary configuration warnings
* Meson build: Require meson >= 0.55.0
* Require atk >= 2.12.0
  Not a new requirement, but previously it was not specified in
  configure.ac and meson.build.
This commit is contained in:
adam 2022-11-24 05:54:48 +00:00
parent 80e5ee9fdf
commit ba081bfe7d
3 changed files with 8 additions and 23 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.33 2022/06/28 11:31:39 wiz Exp $
# $NetBSD: Makefile,v 1.34 2022/11/24 05:54:48 adam Exp $
DISTNAME= atkmm-2.28.2
PKGREVISION= 2
DISTNAME= atkmm-2.28.3
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/atkmm/${PKGVERSION_NOREV:R}/}
EXTRACT_SUFX= .tar.xz
@ -18,6 +17,8 @@ USE_LANGUAGES= c c++11
USE_TOOLS+= perl pkg-config
PKGCONFIG_OVERRIDE+= atk/atkmm.pc.in
MESON_REQD+= 0.55.0
.include "../../devel/atk/buildlink3.mk"
.include "../../devel/glibmm/buildlink3.mk"
.include "../../devel/meson/build.mk"

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.11 2021/10/26 10:14:17 nia Exp $
$NetBSD: distinfo,v 1.12 2022/11/24 05:54:48 adam Exp $
BLAKE2s (atkmm-2.28.2.tar.xz) = 923143a980c64927798d0a1969ea9ff569f66807360108d2518c4156df77af3a
SHA512 (atkmm-2.28.2.tar.xz) = df20b89b603a6ae419db24b21acbd6a9d0e91c07e374b4b774f6a67581ce1581affb0d079a264f0d7f2e6d8b63210639dd7aa15e7e94fb5904d161e9a2aac286
Size (atkmm-2.28.2.tar.xz) = 689944 bytes
SHA1 (patch-meson.build) = b09516870f4e33aab8d4039f995aedd4dc236832
BLAKE2s (atkmm-2.28.3.tar.xz) = a4a7735d70303b8da1750b5d5875f2fa8923257c74515dbdf9e73b5383bb1580
SHA512 (atkmm-2.28.3.tar.xz) = ebc25e9de4b9de6df7097ab485fb0675d8c83113d99a444eec91df0908073362bfdaa9b03fc4c3e91766109d9b94b88df041851176ecde578cf932b526ef678e
Size (atkmm-2.28.3.tar.xz) = 691164 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-meson.build,v 1.1 2021/04/08 21:12:09 adam Exp $
Fix finding Python.
--- meson.build.orig 2021-04-08 16:35:21.531396769 +0000
+++ meson.build
@@ -43,7 +43,7 @@ project_build_root = meson.current_build
cpp_compiler = meson.get_compiler('cpp')
is_msvc = cpp_compiler.get_id() == 'msvc'
-python3 = import('python').find_installation('python3')
+python3 = import('python').find_installation()
python_version = python3.language_version()
python_version_req = '>= 3.5'