Changes 2.4.1:
Modules: * New LDAP option OPT_X_TLS_PACKAGE available in OpenLDAP 2.4.26+ to determine the name of the SSL/TLS package OpenLDAP was built with Lib/ * ldap.modlist.modifyModlist(): New key-word argument case_ignore_attr_types used to define attribute types for which comparison of old and new values should be case-insensitive * Minor changes to which data is sent to debug output for various trace levels * Now tag [1] is used in ldap.extop.dds.RefreshResponse in compliance with RFC 2589 (fix available for OpenLDAP ITS-6886) * New sub-module ldap.controls.sessiontrack implements request control as described in draft-wahl-ldap-session (needs pyasn1_modules) Changes since 2.4.0: * OpenLDAP 2.4.11+ required to build * Support for extracting LDAPv3 extended controls in LDAP_RES_SEARCH_ENTRY responses (see SF-2829057, thanks to Rich) * Generic support for LDAPv3 extended operations (thanks to Rich) Lib/ * new class API in ldap.controls, not backwards-compatible! * new sub-modules for ldap.controls, some require pyasn1 and pyasn1_modules * New methods LDAPObject.result4() and LDAPObject.extop_result() * New (optional) class ldap.controls.AssertionControl * New helper module ldap.logger contains file-like object which sends trace messages to logging.log() * Removed non-functional method LDAPObject.set_cache_options() * Removed unused dictionary ldap.controls.knownLDAPControls Modules/ * ldapcontrol.c: Fixed encode_assertion_control() and function is no longer hidden behind ifdef-statement
This commit is contained in:
parent
68840ee857
commit
ba108a066d
4 changed files with 49 additions and 22 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.41 2011/02/22 08:44:19 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.42 2011/07/08 10:23:35 adam Exp $
|
||||
|
||||
DISTNAME= python-ldap-2.3.13
|
||||
DISTNAME= python-ldap-2.4.1
|
||||
PKGNAME= ${DISTNAME:S/python/${PYPKGPREFIX}/}
|
||||
CATEGORIES= databases python
|
||||
MASTER_SITES= http://pypi.python.org/packages/source/p/python-ldap/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2010/11/09 07:11:46 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.8 2011/07/08 10:23:35 adam Exp $
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
|
@ -18,12 +18,33 @@ ${PYSITELIB}/ldap/async.pyo
|
|||
${PYSITELIB}/ldap/cidict.py
|
||||
${PYSITELIB}/ldap/cidict.pyc
|
||||
${PYSITELIB}/ldap/cidict.pyo
|
||||
${PYSITELIB}/ldap/controls.py
|
||||
${PYSITELIB}/ldap/controls.pyc
|
||||
${PYSITELIB}/ldap/controls.pyo
|
||||
${PYSITELIB}/ldap/controls/__init__.py
|
||||
${PYSITELIB}/ldap/controls/__init__.pyc
|
||||
${PYSITELIB}/ldap/controls/__init__.pyo
|
||||
${PYSITELIB}/ldap/controls/libldap.py
|
||||
${PYSITELIB}/ldap/controls/libldap.pyc
|
||||
${PYSITELIB}/ldap/controls/libldap.pyo
|
||||
${PYSITELIB}/ldap/controls/ppolicy.py
|
||||
${PYSITELIB}/ldap/controls/ppolicy.pyc
|
||||
${PYSITELIB}/ldap/controls/ppolicy.pyo
|
||||
${PYSITELIB}/ldap/controls/psearch.py
|
||||
${PYSITELIB}/ldap/controls/psearch.pyc
|
||||
${PYSITELIB}/ldap/controls/psearch.pyo
|
||||
${PYSITELIB}/ldap/controls/readentry.py
|
||||
${PYSITELIB}/ldap/controls/readentry.pyc
|
||||
${PYSITELIB}/ldap/controls/readentry.pyo
|
||||
${PYSITELIB}/ldap/controls/simple.py
|
||||
${PYSITELIB}/ldap/controls/simple.pyc
|
||||
${PYSITELIB}/ldap/controls/simple.pyo
|
||||
${PYSITELIB}/ldap/dn.py
|
||||
${PYSITELIB}/ldap/dn.pyc
|
||||
${PYSITELIB}/ldap/dn.pyo
|
||||
${PYSITELIB}/ldap/extop/__init__.py
|
||||
${PYSITELIB}/ldap/extop/__init__.pyc
|
||||
${PYSITELIB}/ldap/extop/__init__.pyo
|
||||
${PYSITELIB}/ldap/extop/dds.py
|
||||
${PYSITELIB}/ldap/extop/dds.pyc
|
||||
${PYSITELIB}/ldap/extop/dds.pyo
|
||||
${PYSITELIB}/ldap/filter.py
|
||||
${PYSITELIB}/ldap/filter.pyc
|
||||
${PYSITELIB}/ldap/filter.pyo
|
||||
|
@ -33,6 +54,9 @@ ${PYSITELIB}/ldap/functions.pyo
|
|||
${PYSITELIB}/ldap/ldapobject.py
|
||||
${PYSITELIB}/ldap/ldapobject.pyc
|
||||
${PYSITELIB}/ldap/ldapobject.pyo
|
||||
${PYSITELIB}/ldap/logger.py
|
||||
${PYSITELIB}/ldap/logger.pyc
|
||||
${PYSITELIB}/ldap/logger.pyo
|
||||
${PYSITELIB}/ldap/modlist.py
|
||||
${PYSITELIB}/ldap/modlist.pyc
|
||||
${PYSITELIB}/ldap/modlist.pyo
|
||||
|
@ -75,7 +99,10 @@ share/doc/py-ldap/Demo/page_control.py
|
|||
share/doc/py-ldap/Demo/passwd_ext_op.py
|
||||
share/doc/py-ldap/Demo/pickle_ldapobject.py
|
||||
share/doc/py-ldap/Demo/pyasn1/README
|
||||
share/doc/py-ldap/Demo/pyasn1/prereadcontrol.py
|
||||
share/doc/py-ldap/Demo/pyasn1/dds.py
|
||||
share/doc/py-ldap/Demo/pyasn1/psearch.py
|
||||
share/doc/py-ldap/Demo/pyasn1/readentrycontrol.py
|
||||
share/doc/py-ldap/Demo/pyasn1/sessiontrack.py
|
||||
share/doc/py-ldap/Demo/reconnect.py
|
||||
share/doc/py-ldap/Demo/rename.py
|
||||
share/doc/py-ldap/Demo/resiter.py
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.13 2011/02/22 08:44:19 adam Exp $
|
||||
$NetBSD: distinfo,v 1.14 2011/07/08 10:23:35 adam Exp $
|
||||
|
||||
SHA1 (python-ldap-2.3.13.tar.gz) = 60199aa06ab85b0b7c9192a8163b9ff0d4633918
|
||||
RMD160 (python-ldap-2.3.13.tar.gz) = 48ae889eefa742f89e226d5da8e26211c2f79464
|
||||
Size (python-ldap-2.3.13.tar.gz) = 112397 bytes
|
||||
SHA1 (patch-aa) = 4e35f1710b049ddf7c6fdabe0b4af04b7a8792fc
|
||||
SHA1 (python-ldap-2.4.1.tar.gz) = 93a7c3e1d815c1d9820cefa4711a9836c3f61871
|
||||
RMD160 (python-ldap-2.4.1.tar.gz) = 9dba76bda112088e3c10d30d4629d051dd2db180
|
||||
Size (python-ldap-2.4.1.tar.gz) = 120944 bytes
|
||||
SHA1 (patch-aa) = eca9fea2c766221751b987feaceb829be4e4a9fd
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.6 2009/05/27 05:38:52 obache Exp $
|
||||
$NetBSD: patch-aa,v 1.7 2011/07/08 10:23:35 adam Exp $
|
||||
|
||||
--- setup.cfg.orig 2009-05-26 11:56:18.000000000 +0000
|
||||
--- setup.cfg.orig 2011-06-02 18:08:10.000000000 +0000
|
||||
+++ setup.cfg
|
||||
@@ -1,9 +1,9 @@
|
||||
[_ldap]
|
||||
extra_objects =
|
||||
extra_compile_args =
|
||||
-libs = ldap_r lber sasl2 ssl crypto
|
||||
-library_dirs = /usr/local/openldap-2.3/lib
|
||||
-include_dirs = /usr/local/openldap-2.3/include /usr/include/sasl
|
||||
+libs = @PY_LDAP_LIBS@
|
||||
-library_dirs = /opt/openldap-RE24/lib
|
||||
-include_dirs = /opt/openldap-RE24/include /usr/include/sasl
|
||||
+library_dirs = @PY_LDAP_LIBRARY_DIRS@
|
||||
+include_dirs = @PY_LDAP_INCLUDE_DIRS@
|
||||
extra_compile_args = -g
|
||||
extra_objects =
|
||||
-libs = ldap_r lber sasl2 ssl crypto
|
||||
+libs = @PY_LDAP_LIBS@
|
||||
|
||||
[egg_info]
|
||||
tag_build =
|
||||
[install]
|
||||
compile = 1
|
||||
|
|
Loading…
Reference in a new issue