Update to 1.8.4:

Release 1.8.4 (2008-11-14 Carl Worth <cworth@cworth.org>)
=========================================================
The cairo community is pleased to announce the 1.8.4 release of the
cairo graphics library. This is the second update to cairo's stable
1.8 series and contains a small number of bug fixes, (in particular a
few fixes for build failures of cairo 1.8.2 on various systems). This
is being released just over two weeks after cairo 1.8.2.

We recommend that everyone using cairo upgrade to 1.8.4.

-Carl

Build fixes
-----------
Fix build with older XRender that doesn't define RepeatNone:

   Build of xlib backend fails against old XRender (RepeatNone undeclared)
   https://bugs.freedesktop.org/show_bug.cgi?id=18385

Fix build with bash version <= 3.0:

   doltlibtool broken on linux with bash 3.00.0
   https://bugs.freedesktop.org/show_bug.cgi?id=18363

Bug fixes
---------
Avoid triggering a bug in X.org server 6.9 resulting in a hung machine
requiring a reboot:

    https://bugs.freedesktop.org/show_bug.cgi?id=15628#c2

Fix display of user fonts as exercised by proposed support for type3
fonts in poppler (unsigned promotion fixes):

    Use cairo user-font for Type 3 fonts
    http://lists.freedesktop.org/archives/poppler/2008-October/004181.html

Avoid miscomputing size of fallback images required when rendering
with CLEAR, IN, or SOURCE operator to vector surfaces, (PS, PDF, SVG,
etc.).

Be more tolerant of broken fonts when subsetting type1 fonts:

   Error handling in cairo_type1_font_subset_get_glyph_names_and_widths
   http://lists.cairographics.org/archives/cairo/2008-October/015569.html

Fix cairo_fill_extents, cairo_stroke_extents, cairo_path_extents, to
correctly allow NULL parameters as documented.

Fix potential crash on emitting a type3 glyph after having drawn text
paths from the same font, (for example with cairo_text_path).
This commit is contained in:
wiz 2008-11-16 17:20:14 +00:00
parent c7d8cb7744
commit ba82622a2d
3 changed files with 13 additions and 14 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.69 2008/10/31 09:46:32 tron Exp $
# $NetBSD: Makefile,v 1.70 2008/11/16 17:20:14 wiz Exp $
DISTNAME= cairo-1.8.2
PKGREVISION= 1
DISTNAME= cairo-1.8.4
CATEGORIES= graphics
MASTER_SITES= http://cairographics.org/releases/

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.46 2008/10/30 21:44:54 wiz Exp $
$NetBSD: distinfo,v 1.47 2008/11/16 17:20:14 wiz Exp $
SHA1 (cairo-1.8.2.tar.gz) = 41e94d94e7f379551f556dd71979aca239a688c6
RMD160 (cairo-1.8.2.tar.gz) = 602008860bf35672cf48c7c8f9e1a6b5a702f6aa
Size (cairo-1.8.2.tar.gz) = 7147742 bytes
SHA1 (cairo-1.8.4.tar.gz) = 57fd2c7e0af16bee7cd53436d7c9dc526784f1da
RMD160 (cairo-1.8.4.tar.gz) = 16e0c6a0342c98219212dac1ff956c2cb839b4e5
Size (cairo-1.8.4.tar.gz) = 7070822 bytes
SHA1 (patch-aa) = 870d57c20afbca75ab5c3ec399409de19726fd66
SHA1 (patch-ab) = 54f0dd3e7afdf88b0ab8cf8f32ed16eed04f0797
SHA1 (patch-ab) = 28af58113b1f495660c5a881ae1e8d168db36e4e

View file

@ -1,11 +1,11 @@
$NetBSD: patch-ab,v 1.10 2008/10/16 10:55:09 drochner Exp $
$NetBSD: patch-ab,v 1.11 2008/11/16 17:20:14 wiz Exp $
--- test/Makefile.in.orig 2008-09-26 00:57:34.000000000 +0200
--- test/Makefile.in.orig 2008-11-14 10:12:09.000000000 +0000
+++ test/Makefile.in
@@ -62,7 +62,7 @@ check_PROGRAMS = imagediff$(EXEEXT) png-
@CAIRO_HAS_XLIB_SURFACE_TRUE@ xlib-surface-source$(EXEEXT)
@CAIRO_HAS_XLIB_XRENDER_SURFACE_TRUE@am__append_8 = get-xrender-format$(EXEEXT)
@CAIRO_HAS_MULTI_PAGE_SURFACES_TRUE@am__append_9 = multi-page$(EXEEXT)
@@ -72,7 +72,7 @@ XFAIL_TESTS = alpha-similar$(EXEEXT) big
surface-pattern-big-scale-down$(EXEEXT) \
surface-pattern-scale-down$(EXEEXT) \
surface-pattern-scale-up$(EXEEXT)
-@HAVE_PTHREAD_TRUE@am__append_10 = -lpthread
+@HAVE_PTHREAD_TRUE@am__append_10 = ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}
@BUILD_ANY2PPM_TRUE@am__append_11 = any2ppm