Remove dnsdoctor package which is not maintained for long time and depends
on ruby18.
This commit is contained in:
parent
13cc34ae03
commit
ba9d1131d3
6 changed files with 0 additions and 309 deletions
|
@ -1,4 +0,0 @@
|
|||
DNSdoctor is intended to help solving misconfigurations or
|
||||
inconsistencies in DNS zones by looking for potential errors, give
|
||||
you a description of the problem and refer you to RFC or other
|
||||
documents.
|
|
@ -1,7 +0,0 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.1.1.1 2006/01/29 10:00:07 seb Exp $
|
||||
|
||||
Before using ${PKGNAME} you may want to edit
|
||||
${PKG_SYSCONFDIR}/dnsdoctor/dnsdoctor.conf.
|
||||
|
||||
===========================================================================
|
|
@ -1,60 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.14 2016/12/18 16:30:12 rillig Exp $
|
||||
#
|
||||
|
||||
DISTNAME= dnsdoctor-1.0.1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= # http://www.dnsdoctor.org/download/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://freecode.com/projects/dnsdoctor
|
||||
COMMENT= DNS zones misconfigurations or inconsistencies diagnostic tool
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
DEPENDS+= ${RUBY_BASE}>=${RUBY_VERSION}:${RUBY_SRCDIR}
|
||||
|
||||
WRKSRC= ${WRKDIR}/dnsdoctor
|
||||
|
||||
# Config name conflict, need many changes.
|
||||
RUBY_VERSIONS_ACCEPTED= 18
|
||||
NO_BUILD= yes
|
||||
|
||||
DDOC_HTML_PATH?= /dnsdoctor
|
||||
EGDIR= share/examples
|
||||
DDOCEGDIR= ${EGDIR}/dnsdoctor
|
||||
# No we don't want to use PKG_SYSCONFSUBDIR
|
||||
DDOCCONFDIR= ${PKG_SYSCONFDIR}/dnsdoctor
|
||||
OWN_DIRS= ${PKG_SYSCONFDIR}/dnsdoctor
|
||||
|
||||
RUBY_ENCODING_ARG= -Ku
|
||||
REPLACE_RUBY+= contrib/dig.rb dnsdoctor/zc.rb
|
||||
|
||||
DDOC_INSTALLER_RB_ARGS+= -DRUBY=${RUBY:Q}
|
||||
DDOC_INSTALLER_RB_ARGS+= -DPREFIX=${PREFIX}
|
||||
DDOC_INSTALLER_RB_ARGS+= -DEGDIR=${PREFIX}/${EGDIR}
|
||||
DDOC_INSTALLER_RB_ARGS+= -DETCDIR=${PKG_SYSCONFDIR}
|
||||
DDOC_INSTALLER_RB_ARGS+= -DHTML_PATH=${DDOC_HTML_PATH:Q}
|
||||
|
||||
CONF_FILES+= ${DDOCEGDIR}/afnic.profile ${DDOCCONFDIR}/afnic.profile
|
||||
CONF_FILES+= ${DDOCEGDIR}/de.profile ${DDOCCONFDIR}/de.profile
|
||||
CONF_FILES+= ${DDOCEGDIR}/default.profile ${DDOCCONFDIR}/default.profile
|
||||
CONF_FILES+= ${DDOCEGDIR}/reverse.profile ${DDOCCONFDIR}/reverse.profile
|
||||
CONF_FILES+= ${DDOCEGDIR}/rootservers ${DDOCCONFDIR}/rootservers
|
||||
CONF_FILES+= ${DDOCEGDIR}/dnsdoctor.conf ${DDOCCONFDIR}/dnsdoctor.conf
|
||||
|
||||
MAKE_ENV+= DESTDIR=${DESTDIR}
|
||||
MAKE_ENV+= MANDIR=${PREFIX}/${PKGMANDIR}
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC} && \
|
||||
${RUBY} ./installer.rb ${DDOC_INSTALLER_RB_ARGS} configure configinfo
|
||||
|
||||
do-install:
|
||||
${RUN} cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
|
||||
${RUBY} ${RUBY_ENCODING_ARG} ./installer.rb \
|
||||
${DDOC_INSTALLER_RB_ARGS} all
|
||||
${INSTALL_DATA} ${WRKSRC}/www/dnsdoctor.conf \
|
||||
${DESTDIR}${PREFIX}/${DDOCEGDIR}/httpd-dnsdoctor.conf
|
||||
|
||||
.include "../../lang/ruby/replace.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,156 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2016/12/18 16:30:12 rillig Exp $
|
||||
bin/dnsdoctor
|
||||
libexec/dnsdoctor/cgi-bin/diagnose.cgi
|
||||
libexec/dnsdoctor/dnsdoctor/cache.rb
|
||||
libexec/dnsdoctor/dnsdoctor/cachemanager.rb
|
||||
libexec/dnsdoctor/dnsdoctor/config.rb
|
||||
libexec/dnsdoctor/dnsdoctor/console.rb
|
||||
libexec/dnsdoctor/dnsdoctor/data/catalog.xml
|
||||
libexec/dnsdoctor/dnsdoctor/data/config.dtd
|
||||
libexec/dnsdoctor/dnsdoctor/data/dnsdoctor.dtd
|
||||
libexec/dnsdoctor/dnsdoctor/data/logo.png
|
||||
libexec/dnsdoctor/dnsdoctor/data/msgcat.dtd
|
||||
libexec/dnsdoctor/dnsdoctor/data/xpm.rb
|
||||
libexec/dnsdoctor/dnsdoctor/dbg.rb
|
||||
libexec/dnsdoctor/dnsdoctor/ext/array.rb
|
||||
libexec/dnsdoctor/dnsdoctor/ext/file.rb
|
||||
libexec/dnsdoctor/dnsdoctor/ext/gtk.rb
|
||||
libexec/dnsdoctor/dnsdoctor/ext/myxml.rb
|
||||
libexec/dnsdoctor/dnsdoctor/framework.rb
|
||||
libexec/dnsdoctor/dnsdoctor/input/cgi.rb
|
||||
libexec/dnsdoctor/dnsdoctor/input/cli.rb
|
||||
libexec/dnsdoctor/dnsdoctor/input/gtk.rb
|
||||
libexec/dnsdoctor/dnsdoctor/input/inetd.rb
|
||||
libexec/dnsdoctor/dnsdoctor/instructions.rb
|
||||
libexec/dnsdoctor/dnsdoctor/locale.rb
|
||||
libexec/dnsdoctor/dnsdoctor/mail.rb
|
||||
libexec/dnsdoctor/dnsdoctor/msgcat.rb
|
||||
libexec/dnsdoctor/dnsdoctor/param.rb
|
||||
libexec/dnsdoctor/dnsdoctor/publisher.rb
|
||||
libexec/dnsdoctor/dnsdoctor/publisher/gtk.rb
|
||||
libexec/dnsdoctor/dnsdoctor/publisher/html.rb
|
||||
libexec/dnsdoctor/dnsdoctor/publisher/text.rb
|
||||
libexec/dnsdoctor/dnsdoctor/publisher/xml.rb
|
||||
libexec/dnsdoctor/dnsdoctor/report.rb
|
||||
libexec/dnsdoctor/dnsdoctor/report/byhost.rb
|
||||
libexec/dnsdoctor/dnsdoctor/report/byseverity.rb
|
||||
libexec/dnsdoctor/dnsdoctor/testmanager.rb
|
||||
libexec/dnsdoctor/dnsdoctor/zc.rb
|
||||
libexec/dnsdoctor/dnsdoctor/zonecheck.rb
|
||||
libexec/dnsdoctor/lib/address.rb
|
||||
libexec/dnsdoctor/lib/address/common.rb
|
||||
libexec/dnsdoctor/lib/address/ipv4.rb
|
||||
libexec/dnsdoctor/lib/address/ipv6.rb
|
||||
libexec/dnsdoctor/lib/nresolv.rb
|
||||
libexec/dnsdoctor/lib/nresolv/compatibility.rb
|
||||
libexec/dnsdoctor/lib/nresolv/config.rb
|
||||
libexec/dnsdoctor/lib/nresolv/constants.rb
|
||||
libexec/dnsdoctor/lib/nresolv/dbg.rb
|
||||
libexec/dnsdoctor/lib/nresolv/dig_output.rb
|
||||
libexec/dnsdoctor/lib/nresolv/dns.rb
|
||||
libexec/dnsdoctor/lib/nresolv/dns_message.rb
|
||||
libexec/dnsdoctor/lib/nresolv/dns_name.rb
|
||||
libexec/dnsdoctor/lib/nresolv/dns_resource.rb
|
||||
libexec/dnsdoctor/lib/nresolv/host.rb
|
||||
libexec/dnsdoctor/lib/nresolv/resolver.rb
|
||||
libexec/dnsdoctor/lib/nresolv/transport.rb
|
||||
libexec/dnsdoctor/lib/nresolv/wire.rb
|
||||
libexec/dnsdoctor/lib/textfmt.rb
|
||||
libexec/dnsdoctor/lib/whois.rb
|
||||
libexec/dnsdoctor/locale/cgi.en
|
||||
libexec/dnsdoctor/locale/cgi.fr
|
||||
libexec/dnsdoctor/locale/cgi.zh
|
||||
libexec/dnsdoctor/locale/cli.en
|
||||
libexec/dnsdoctor/locale/cli.fr
|
||||
libexec/dnsdoctor/locale/dnsdoctor.en
|
||||
libexec/dnsdoctor/locale/dnsdoctor.fr
|
||||
libexec/dnsdoctor/locale/dnsdoctor.zh
|
||||
libexec/dnsdoctor/locale/gtk.en
|
||||
libexec/dnsdoctor/locale/gtk.fr
|
||||
libexec/dnsdoctor/locale/inetd.en
|
||||
libexec/dnsdoctor/locale/inetd.fr
|
||||
libexec/dnsdoctor/locale/test/axfr.en
|
||||
libexec/dnsdoctor/locale/test/axfr.fr
|
||||
libexec/dnsdoctor/locale/test/axfr.zh
|
||||
libexec/dnsdoctor/locale/test/connectivity.en
|
||||
libexec/dnsdoctor/locale/test/connectivity.fr
|
||||
libexec/dnsdoctor/locale/test/connectivity.zh
|
||||
libexec/dnsdoctor/locale/test/generic.en
|
||||
libexec/dnsdoctor/locale/test/generic.fr
|
||||
libexec/dnsdoctor/locale/test/generic.zh
|
||||
libexec/dnsdoctor/locale/test/interop.en
|
||||
libexec/dnsdoctor/locale/test/interop.fr
|
||||
libexec/dnsdoctor/locale/test/interop.zh
|
||||
libexec/dnsdoctor/locale/test/loopback.en
|
||||
libexec/dnsdoctor/locale/test/loopback.fr
|
||||
libexec/dnsdoctor/locale/test/loopback.zh
|
||||
libexec/dnsdoctor/locale/test/mail.en
|
||||
libexec/dnsdoctor/locale/test/mail.fr
|
||||
libexec/dnsdoctor/locale/test/mail.zh
|
||||
libexec/dnsdoctor/locale/test/misc.en
|
||||
libexec/dnsdoctor/locale/test/misc.fr
|
||||
libexec/dnsdoctor/locale/test/misc.zh
|
||||
libexec/dnsdoctor/locale/test/mx.en
|
||||
libexec/dnsdoctor/locale/test/mx.fr
|
||||
libexec/dnsdoctor/locale/test/mx.zh
|
||||
libexec/dnsdoctor/locale/test/nameserver.en
|
||||
libexec/dnsdoctor/locale/test/nameserver.fr
|
||||
libexec/dnsdoctor/locale/test/nameserver.zh
|
||||
libexec/dnsdoctor/locale/test/ns.en
|
||||
libexec/dnsdoctor/locale/test/ns.fr
|
||||
libexec/dnsdoctor/locale/test/ns.zh
|
||||
libexec/dnsdoctor/locale/test/rootserver.en
|
||||
libexec/dnsdoctor/locale/test/rootserver.fr
|
||||
libexec/dnsdoctor/locale/test/rootserver.zh
|
||||
libexec/dnsdoctor/locale/test/soa.en
|
||||
libexec/dnsdoctor/locale/test/soa.fr
|
||||
libexec/dnsdoctor/locale/test/soa.zh
|
||||
libexec/dnsdoctor/test/axfr.rb
|
||||
libexec/dnsdoctor/test/connectivity.rb
|
||||
libexec/dnsdoctor/test/generic.rb
|
||||
libexec/dnsdoctor/test/interop.rb
|
||||
libexec/dnsdoctor/test/loopback.rb
|
||||
libexec/dnsdoctor/test/mail.rb
|
||||
libexec/dnsdoctor/test/misc.rb
|
||||
libexec/dnsdoctor/test/mx.rb
|
||||
libexec/dnsdoctor/test/nameserver.rb
|
||||
libexec/dnsdoctor/test/ns.rb
|
||||
libexec/dnsdoctor/test/rootserver.rb
|
||||
libexec/dnsdoctor/test/soa.rb
|
||||
libexec/dnsdoctor/www/html/form.html.en
|
||||
libexec/dnsdoctor/www/html/form.html.fr
|
||||
libexec/dnsdoctor/www/html/form.html.zh
|
||||
libexec/dnsdoctor/www/img/ddoc-fav.png
|
||||
libexec/dnsdoctor/www/img/details.png
|
||||
libexec/dnsdoctor/www/img/element.png
|
||||
libexec/dnsdoctor/www/img/fatal.png
|
||||
libexec/dnsdoctor/www/img/gear.png
|
||||
libexec/dnsdoctor/www/img/info.png
|
||||
libexec/dnsdoctor/www/img/light.png
|
||||
libexec/dnsdoctor/www/img/logo.png
|
||||
libexec/dnsdoctor/www/img/logo_l.png
|
||||
libexec/dnsdoctor/www/img/loupe.png
|
||||
libexec/dnsdoctor/www/img/notepad.png
|
||||
libexec/dnsdoctor/www/img/ok.png
|
||||
libexec/dnsdoctor/www/img/primary.png
|
||||
libexec/dnsdoctor/www/img/ref.png
|
||||
libexec/dnsdoctor/www/img/secondary.png
|
||||
libexec/dnsdoctor/www/img/warning.png
|
||||
libexec/dnsdoctor/www/img/zone.png
|
||||
libexec/dnsdoctor/www/js/formvalidation.js
|
||||
libexec/dnsdoctor/www/js/popupmenu.js
|
||||
libexec/dnsdoctor/www/js/progress.js
|
||||
libexec/dnsdoctor/www/style/default.css
|
||||
libexec/dnsdoctor/www/style/dnsdoctor.css
|
||||
man/man1/dnsdoctor.1
|
||||
share/doc/dnsdoctor/CREDITS
|
||||
share/doc/dnsdoctor/HISTORY
|
||||
share/doc/dnsdoctor/README
|
||||
share/examples/dnsdoctor/afnic.profile
|
||||
share/examples/dnsdoctor/cn.profile
|
||||
share/examples/dnsdoctor/de.profile
|
||||
share/examples/dnsdoctor/default.profile
|
||||
share/examples/dnsdoctor/dnsdoctor.conf
|
||||
share/examples/dnsdoctor/httpd-dnsdoctor.conf
|
||||
share/examples/dnsdoctor/reverse.profile
|
||||
share/examples/dnsdoctor/rootservers
|
|
@ -1,7 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.4 2015/11/04 00:34:58 agc Exp $
|
||||
|
||||
SHA1 (dnsdoctor-1.0.1.tgz) = 56a5d19d691c54d0fc701a655d1803980cbc1fb5
|
||||
RMD160 (dnsdoctor-1.0.1.tgz) = 9e3d3f577b05558ef543cb7e864e6b0a0b4e098a
|
||||
SHA512 (dnsdoctor-1.0.1.tgz) = 1202cdd3033fa72368037ecf228b4c083fa4f8dce7f2e56d1b8bcf93a8561154993e7d4fc2edff277bb254332fba3cef6451d524570553a9cafc3a41759d5f99
|
||||
Size (dnsdoctor-1.0.1.tgz) = 353555 bytes
|
||||
SHA1 (patch-aa) = 8dab55ecede9f1275a486ab169bcce061d0a48bb
|
|
@ -1,75 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2010/09/10 07:34:35 taca Exp $
|
||||
|
||||
--- installer.rb.orig 2004-09-08 12:14:43.000000000 +0000
|
||||
+++ installer.rb
|
||||
@@ -65,12 +65,13 @@ class Installer
|
||||
ENV['PROGNAME' ] ||= 'dnsdoctor'
|
||||
ENV['HTML_PATH' ] ||= "/#{ENV['PROGNAME']}"
|
||||
ENV['ETCDIST' ] ||= ''
|
||||
- ENV['CHROOT' ] ||= ''
|
||||
+ ENV['CHROOT' ] ||= ENV['DESTDIR']
|
||||
|
||||
ENV['LIBEXEC' ] ||= "#{ENV['PREFIX']}/libexec"
|
||||
ENV['BINDIR' ] ||= "#{ENV['PREFIX']}/bin"
|
||||
ENV['MANDIR' ] ||= "#{ENV['PREFIX']}/man"
|
||||
ENV['DOCDIR' ] ||= "#{ENV['PREFIX']}/share/doc"
|
||||
+ ENV['EGDIR' ] ||= "#{ENV['PREFIX']}/share/examples"
|
||||
ENV['ETCDIR' ] ||= "#{ENV['PREFIX']}/etc"
|
||||
ENV['CGIDIR' ] ||= "#{ENV['LIBEXEC']}/#{ENV['PROGNAME']}/cgi-bin"
|
||||
ENV['WWWDIR' ] ||= "#{ENV['LIBEXEC']}/#{ENV['PROGNAME']}/www"
|
||||
@@ -79,11 +80,13 @@ class Installer
|
||||
|
||||
# Create some shortcut for later
|
||||
@installdir = "#{ENV['LIBEXEC']}/#{ENV['PROGNAME']}"
|
||||
+ @egdir = "#{ENV['EGDIR']}/#{ENV['PROGNAME']}#{ENV['ETCDIST']}"
|
||||
@confdir = "#{ENV['ETCDIR']}/#{ENV['PROGNAME']}#{ENV['ETCDIST']}"
|
||||
@dnsdoctor = "#{@installdir}/dnsdoctor/zc.rb"
|
||||
@wwwdir = "#{ENV['WWWDIR']}"
|
||||
|
||||
@ch_installdir = "#{ENV['CHROOT']}#{@installdir}"
|
||||
+ @ch_egdir = "#{ENV['CHROOT']}#{@egdir}"
|
||||
@ch_confdir = "#{ENV['CHROOT']}#{@confdir}"
|
||||
@ch_dnsdoctor = "#{ENV['CHROOT']}#{@dnsdoctor}"
|
||||
@ch_wwwdir = "#{ENV['CHROOT']}#{@wwwdir}"
|
||||
@@ -141,8 +144,7 @@ class Installer
|
||||
def patch_common
|
||||
puts "==> Patching core components"
|
||||
dnsdoctor_content = File.readlines(@ch_dnsdoctor)
|
||||
- [ [ /^\#!.*ruby/, "#!#{ENV['RUBY']}" ],
|
||||
- [ 'DDOC_INSTALL_PATH', "\\1\"#{@installdir}\"" ],
|
||||
+ [ [ 'DDOC_INSTALL_PATH', "\\1\"#{@installdir}\"" ],
|
||||
[ 'DDOC_CONFIG_DIR', "\\1\"#{ENV['ETCDIR']}/#{ENV['PROGNAME']}\""],
|
||||
[ 'DDOC_LOCALIZATION_DIR', "\\1\"#{@installdir}/locale\"" ],
|
||||
[ 'DDOC_TEST_DIR', "\\1\"#{@installdir}/test\"" ],
|
||||
@@ -181,10 +183,10 @@ class Installer
|
||||
puts
|
||||
|
||||
puts "==> Installing default configuration file"
|
||||
- mkdir_p @ch_confdir, :verbose => @verbose
|
||||
- cp 'etc/dnsdoctor/dnsdoctor.conf', @ch_confdir, :verbose => @verbose
|
||||
- cp 'etc/dnsdoctor/rootservers', @ch_confdir, :verbose => @verbose
|
||||
- cp Dir['etc/dnsdoctor/*.profile'], @ch_confdir, :verbose => @verbose
|
||||
+ mkdir_p @ch_egdir, :verbose => @verbose
|
||||
+ cp 'etc/dnsdoctor/dnsdoctor.conf', @ch_egdir, :verbose => @verbose
|
||||
+ cp 'etc/dnsdoctor/rootservers', @ch_egdir, :verbose => @verbose
|
||||
+ cp Dir['etc/dnsdoctor/*.profile'], @ch_egdir, :verbose => @verbose
|
||||
puts
|
||||
end
|
||||
|
||||
@@ -217,6 +219,7 @@ class Installer
|
||||
puts "==> Installing HTML pages"
|
||||
mkdir_p @ch_wwwdir, :verbose => @verbose
|
||||
Dir["www/*"].each { |entry|
|
||||
+ next if entry =~ /dnsdoctor.conf.*/
|
||||
cp_r entry, @ch_wwwdir, :verbose => @verbose
|
||||
}
|
||||
puts
|
||||
@@ -323,7 +326,7 @@ info = false
|
||||
# Sanity check
|
||||
#
|
||||
rubyver = `#{ENV['RUBY']} --version`
|
||||
-m = /^ruby\s+(\d+)\.(\d+)\.(\d+)\s+/.match(rubyver)
|
||||
+m = /^ruby\s+(\d+)\.(\d+)\.([p0-9]+)\s+/.match(rubyver)
|
||||
if m.nil?
|
||||
$stderr.puts "ERROR: Invalid interpreter: #{ENV['RUBY']}"
|
||||
exit EXIT_ERROR
|
Loading…
Reference in a new issue