Initial import of telepathy-idle-0.1.2:
A full-featured IRC connection manager for Telepathy. XXX: I couldn't get this to work with empathy. Might need further fixes.
This commit is contained in:
parent
e308e522fa
commit
ba9de64eef
5 changed files with 66 additions and 0 deletions
1
chat/telepathy-idle/DESCR
Normal file
1
chat/telepathy-idle/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
A full-featured IRC connection manager for Telepathy.
|
27
chat/telepathy-idle/Makefile
Normal file
27
chat/telepathy-idle/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2008/11/14 23:00:12 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= telepathy-idle-0.1.2
|
||||
CATEGORIES= chat
|
||||
MASTER_SITES= http://telepathy.freedesktop.org/releases/telepathy-idle/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://telepathy.freedesktop.org/wiki/Components
|
||||
COMMENT= Full-featured IRC connection manager for Telepathy
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
|
||||
CONFIGURE_ARGS+= OPENSSL_CFLAGS=-I${BUILDLINK_PREFIX.openssl}/include
|
||||
CONFIGURE_ARGS+= OPENSSL_LIBS="-L${BUILDLINK_PREFIX.openssl}/lib ${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.openssl}/lib -lssl"
|
||||
|
||||
.include "../../chat/telepathy-glib/buildlink3.mk"
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../lang/python/application.mk"
|
||||
BUILDLINK_API_DEPENDS.openssl+= openssl>=0.9.7
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../sysutils/dbus-glib/buildlink3.mk"
|
||||
.include "../../sysutils/dbus/buildlink3.mk"
|
||||
.include "../../textproc/libxslt/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
7
chat/telepathy-idle/PLIST
Normal file
7
chat/telepathy-idle/PLIST
Normal file
|
@ -0,0 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2008/11/14 23:00:12 wiz Exp $
|
||||
bin/telepathy-idle
|
||||
share/dbus-1/services/org.freedesktop.Telepathy.ConnectionManager.idle.service
|
||||
share/telepathy/managers/idle.manager
|
||||
@unexec ${RMDIR} %D/share/telepathy/managers 2>/dev/null || ${TRUE}
|
||||
@unexec ${RMDIR} %D/share/telepathy 2>/dev/null || ${TRUE}
|
||||
@comment in dbus: @dirrm share/dbus-1/services
|
6
chat/telepathy-idle/distinfo
Normal file
6
chat/telepathy-idle/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2008/11/14 23:00:12 wiz Exp $
|
||||
|
||||
SHA1 (telepathy-idle-0.1.2.tar.gz) = c8ffa208b18db1a7b7f88237bbc5167c6a585f03
|
||||
RMD160 (telepathy-idle-0.1.2.tar.gz) = 124ca06ba8077016c0dea54f0635a8652049018b
|
||||
Size (telepathy-idle-0.1.2.tar.gz) = 405694 bytes
|
||||
SHA1 (patch-aa) = ae01882fdde77b13424974f6365fb3c531f0ccb6
|
25
chat/telepathy-idle/patches/patch-aa
Normal file
25
chat/telepathy-idle/patches/patch-aa
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2008/11/14 23:00:12 wiz Exp $
|
||||
|
||||
--- src/idle-parser.c.orig 2007-09-25 18:46:25.000000000 +0000
|
||||
+++ src/idle-parser.c
|
||||
@@ -184,6 +184,20 @@ static void _parse_message(IdleParser *p
|
||||
static void _parse_and_forward_one(IdleParser *parser, gchar **tokens, IdleParserMessageCode code, const gchar *format);
|
||||
static gboolean _parse_atom(IdleParser *parser, GValueArray *arr, char atom, const gchar *token, TpHandleSet *contact_reffed, TpHandleSet *room_reffed);
|
||||
|
||||
+#ifndef strnlen
|
||||
+size_t
|
||||
+strnlen(const char *msg, size_t maxlen)
|
||||
+{
|
||||
+ size_t i;
|
||||
+
|
||||
+ for (i=0; i<maxlen; i++)
|
||||
+ if (msg[i] == '\0')
|
||||
+ break;
|
||||
+
|
||||
+ return i;
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
void idle_parser_receive(IdleParser *parser, const gchar *msg) {
|
||||
IdleParserPrivate *priv = IDLE_PARSER_GET_PRIVATE(parser);
|
||||
int i;
|
Loading…
Reference in a new issue