Import OpenACS, a port of the Ars Digita Community System to

PostgreSQL.

OpenACS is a web development environment which includes a staggering
number of already-built modules.
This commit is contained in:
cjones 2001-07-19 04:35:59 +00:00
parent 927bfbea7a
commit bac143f579
10 changed files with 4125 additions and 0 deletions

51
www/openacs/Makefile Normal file
View file

@ -0,0 +1,51 @@
# $NetBSD: Makefile,v 1.1.1.1 2001/07/19 04:35:59 cjones Exp $
#
DISTNAME= openacs-3.2.5
CATEGORIES= www
MASTER_SITES= # none
EXTRACT_SUFX= .tgz
MAINTAINER= cjones@netbsd.org
HOMEPAGE= http://www.openacs.org/
COMMENT= TCL-based web programming environment
# Would also work with AOLServer, but there's no package for that.
DEPENDS+= ap-aolserver-1.1:../../www/ap-aolserver
DEPENDS+= postgresql-lib>=7:../../databases/postgresql-lib
DEPENDS+= ImageMagick:../../graphics/ImageMagick
DEPENDS+= unzip:../../archivers/unzip
BUILD_DEPENDS+= postgresql-client>=7:../../databases/postgresql-client
NO_CONFIGURE= # set
NO_BUILD= # set
MESSAGE_SUBST+= PREFIX=${PREFIX}
do-fetch:
@if [ ! -f ${DISTDIR}/${DISTFILES} ] ; then \
${ECHO} "Please fetch ${DISTFILES} into ${DISTDIR}" ; \
${ECHO} "from ${HOMEPAGE} ." ; \
exit 1 ; \
fi
SEDFILES=${WRKSRC}/parameters/ad.tcl \
${WRKSRC}/bin/aolserver-errors.pl \
${WRKSRC}/bin/queue-message.pl \
${WRKSRC}/www/doc/sql/postgres.sql \
${WRKDIR}/install-openacs
# This intentionally clobbers the .orig files:
post-patch:
${CP} ${FILESDIR}/install-openacs ${WRKDIR}
for F in ${SEDFILES} ; do \
${SED} "s,@PREFIX@,${PREFIX},g" < $$F > $$F.orig ; \
${MV} $$F.orig $$F ; \
done
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/install-openacs ${PREFIX}/bin
${INSTALL_DATA_DIR} ${PREFIX}/share/openacs
( cd ${WRKSRC} ; tar cf - . ) | \
( cd ${PREFIX}/share/openacs ; tar xf - )
.include "../../mk/bsd.pkg.mk"

8
www/openacs/distinfo Normal file
View file

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2001/07/19 04:35:59 cjones Exp $
SHA1 (openacs-3.2.5.tgz) = 6dce37b051f2d0b07eda24cc4a54f89ae3e140ff
Size (openacs-3.2.5.tgz) = 2662068 bytes
SHA1 (patch-aa) = e00628ec4aa5d651d6971373a8f127f44c63618b
SHA1 (patch-ab) = ce50389a7e397b0cefb6c32cd6faef545b5b59e6
SHA1 (patch-ac) = 2a433d099c14ba0f10eaf3b52b96b9333d0b4ace
SHA1 (patch-ad) = ec3652f8eca46e319ebd818e1c5a9498f07222e7

View file

@ -0,0 +1,78 @@
#!/bin/sh
# $NetBSD: install-openacs,v 1.1.1.1 2001/07/19 04:36:06 cjones Exp $
PATH=/bin:/usr/bin:@PREFIX@/bin
# Script to copy the openacs tree, create db, and populate db.
while [ `expr "$1" : -.*` -ne 0 ] ; do
case "$1" in
"-u")
ACSUSER=$2
shift;shift
;;
"-d")
ACSDB=$2
shift;shift
;;
*)
echo "Usage: $0 -u dbuser -d dbname destpath"
echo "dbuser is the postgres user, dbname is the database name."
echo "destpath is the path to install OpenACS in."
exit 1
;;
esac
done
DEST=$1
if [ -z "$DEST" ] ; then
echo "No destination given!"
exit 1
fi
if [ -z "$ACSUSER" ] ; then
echo "No dbuser given!"
exit 1
fi
if [ -z "$ACSDB" ] ; then
echo "No dbname given!"
exit 1
fi
echo -n "copying the openacs tree to $DEST..."
if [ ! -d $DEST ] ; then
mkdir -p $DEST
fi
( cd @PREFIX@/share/openacs ; tar cf - . ) | \
( cd $DEST ; tar xf - )
if [ $? -ne 0 ] ; then
exit 1
fi
echo "done."
NAME=`basename $DEST`
mv $DEST/parameters/ad.tcl $DEST/parameters/$NAME.tcl
rm $DEST/parameters/ad.ini
echo ""
echo "Creating $ACSDB owned by $ACSUSER:"
PGUSER=$ACSUSER
export PGUSER
psql -q -c "create database $ACSDB" template1 || exit 1
echo ""
echo "Loading geo tables:"
for I in $DEST/www/install/acs_geo_parents.sql $DEST/www/install/*.ctl ; do
psql -q -f $I $ACSDB || exit 1
done
echo ""
echo "Loading OpenACS schema:"
cd $DEST/www/doc/sql
psql -q -f load-data-model.sql $ACSDB || exit 1
echo "done."
echo ""
echo "Don't forget to take a look at $DEST/parameters/$NAME.tcl"
echo "and @PREFIX@/etc/httpd/tcl_modules/nsd.tcl."
echo "You'll at least want to check the database info in the latter file,"
echo "and the homedir variable in both files."

View file

@ -0,0 +1,149 @@
$NetBSD: patch-aa,v 1.1.1.1 2001/07/19 04:36:07 cjones Exp $
--- parameters/ad.tcl.orig Mon Apr 30 19:53:34 2001
+++ parameters/ad.tcl Wed Jul 18 21:49:47 2001
@@ -1,3 +1,7 @@
+# Your DocumentRoot should be ${homedir}/${server}/www, as in nsd.tcl.
+set homedir "/usr/local/share/htdocs"
+set server [ns_info server]
+
# AOLserver reads these files when the server starts up and stores
# parameters in an in-memory hash table. So you have to restart the
# server if you want to test a change made to this file.
@@ -187,7 +191,7 @@
ns_param UsersTableContainsConvertedUsersP 0
# Primarily for WimpyPoint, but may be useful to other modules
- ns_param PathToACS ${homedir}/servers/${server}
+ ns_param PathToACS ${homedir}/${server}
# Where is the global directory for such things as file-not-found
# error messages
@@ -235,7 +239,7 @@
# if you have ImageMagick configured, try to
# producte thumbnails?
- ns_param ProduceThumbnailsAutomaticallyP 0
+ ns_param ProduceThumbnailsAutomaticallyP 1
ns_param AcceptablePortraitMIMETypes "image/gif image/jpeg"
# stuff having to do with the physical computer on which
@@ -396,7 +400,7 @@
ns_param FileUploadingEnabledP 1
# this path does *not* contain a trailing "/"
- ns_param FilePath ${homedir}/servers/foobar/
+ ns_param FilePath ${homedir}/foobar/
# Urgent messages
ns_param UrgentMessageEnabledP 0
@@ -836,7 +840,7 @@
ns_section ns/server/${server}/acs/style
- # where to find templates, typically ${homedir}/servers/${server}/templates
+ # where to find templates, typically ${homedir}/${server}/templates
# (note lack of trailing slash, just like the pageroot)
# you can override it with this config param
# ns_param TemplateRoot ""
@@ -871,7 +875,7 @@
# note that this address must be set up through your mail transfer
# agent to run a email enqueueing script.
# See doc/ticket.html for more info on configuring the ticket system.
- # (from ${homedir}/servers/${server}/bin/queue-message.pl)
+ # (from ${homedir}/${server}/bin/queue-message.pl)
ns_param TicketReplyEmail support-ticket-robot@[ns_info hostname]
# The PicklistData specifies additional custom data fields you would like
@@ -1097,13 +1101,13 @@
ns_param LocalDomain [ns_info hostname]
# the directory that the ecommerce module is in
- ns_param EcommerceDirectory ${homedir}/servers/${server}/www/ecommerce/
+ ns_param EcommerceDirectory ${homedir}/${server}/www/ecommerce/
# web path to the directory that the ecommerce user files are in
ns_param EcommercePath /ecommerce/
# path to Product data directories (where product files like images are kept)
- ns_param EcommerceDataDirectory ${homedir}/servers/${server}/data/ecommerce/
+ ns_param EcommerceDataDirectory ${homedir}/${server}/data/ecommerce/
# This path goes on the end of the EcommerceDataDirectory
ns_param ProductDataDirectory product/
@@ -1224,7 +1228,7 @@
# ns_param PersontoNotify nerd1@[ns_info hostname]
# ns_param PersontoNotify nerd2@[ns_info hostname]
# location of the watchdog perl script
- ns_param WatchDogParser ${homedir}/servers/${server}/bin/aolserver-errors.pl
+ ns_param WatchDogParser ${homedir}/${server}/bin/aolserver-errors.pl
# watchdog frequency in minutes
ns_param WatchDogFrequency 15
@@ -1251,7 +1255,7 @@
ns_section ns/server/${server}/acs/download
# root directory of the downloadable files
- ns_param DownloadRoot ${homedir}/servers/${server}/download/
+ ns_param DownloadRoot ${homedir}/${server}/download/
ns_section ns/server/${server}/acs/wp
@@ -1265,7 +1269,7 @@
ns_param CommentApprovalPolicy open
# Path to the unzip program to use for bulk image uploading.
- ns_param PathToUnzip /usr/bin/unzip
+ ns_param PathToUnzip @PREFIX@/bin/unzip
# Is bulk image uploading enabled?
ns_param AllowBulkUploadP 1
@@ -1276,7 +1280,7 @@
# all user web content will be rooted under this directory. This
# directory will be the root of all the web content being published
# by the users of the system.
- ns_param ContentRoot ${homedir}/servers/${server}/users/
+ ns_param ContentRoot ${homedir}/${server}/users/
# Maximum quota for a 'normal user' (a lesser mortal who is not the
# site wide administrator) of the site in mega-bytes. For example, a
@@ -1344,7 +1348,7 @@
# Pairs of {email_addr_pattern pseudo-mime-type}
ns_param EmailTypes "{%@hotmail.com text/html} {%@aol.com text/aol-html}"
- ns_param DailySpamDirectory ${homedir}/servers/${server}/spam
+ ns_param DailySpamDirectory ${homedir}/${server}/spam
ns_param RemovalBlurb "{-----\\nSent through http://[ns_info hostname]\\n\\n}"
@@ -1393,7 +1397,7 @@
ns_section ns/server/${server}/acs/sdm
ns_param UrlStub /sdm
- ns_param SoftwareRoot ${homedir}/servers/${server}/sdm-software
+ ns_param SoftwareRoot ${homedir}/${server}/sdm-software
ns_param SdmVersion 0.4
ns_param NotificationSenderEmail robot@[ns_info hostname]
ns_param SystemName "Software Development Manager"
@@ -1420,7 +1424,7 @@
#to be able to restart the aolserver from the admin page,
#INIFile must have the path and name of the config file.
- #ie: ${homedir}/servers/aolserver/${server}.tcl
+ #ie: ${homedir}/aolserver/${server}.tcl
#To disable, leave INIFile blank
ns_section ns/server/${server}/acs/restart
@@ -1447,9 +1451,9 @@
ns_param PhotoSubDirectory "/photodb"
ns_param PhotoDatabaseServiceName "Photo Database"
ns_param ErrorPhotoPath "/graphics/photodb/error.jpg"
- ns_param PhotoDataRoot "${homedir}/servers/${server}/data/photodb"
- ns_param ImageMagickIdentifyLocation "/usr/bin/X11/identify"
- ns_param ImageMagickConvertLocation "/usr/bin/X11/convert"
+ ns_param PhotoDataRoot "${homedir}/${server}/data/photodb"
+ ns_param ImageMagickIdentifyLocation "@PREFIX@/bin/identify"
+ ns_param ImageMagickConvertLocation "@PREFIX@/bin/convert"
# Local Variables:
# eval: (auto-save-mode 0)

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2001/07/19 04:36:07 cjones Exp $
--- www/doc/sql/postgres.sql.orig Wed Jul 18 14:28:48 2001
+++ www/doc/sql/postgres.sql Wed Jul 18 14:28:50 2001
@@ -11,7 +11,7 @@
--as '/usr/lib/pgsql/plpgsql.so' language 'c';
--
create function plpgsql_call_handler() RETURNS opaque
-as '/usr/local/pgsql/lib/plpgsql.so' language 'c';
+as '@PREFIX@/lib/plpgsql.so' language 'c';
create trusted procedural language 'plpgsql'
HANDLER plpgsql_call_handler

View file

@ -0,0 +1,10 @@
$NetBSD: patch-ac,v 1.1.1.1 2001/07/19 04:36:07 cjones Exp $
--- bin/aolserver-errors.pl.orig Wed Jul 18 21:33:09 2001
+++ bin/aolserver-errors.pl Wed Jul 18 21:33:43 2001
@@ -1,4 +1,4 @@
-#! /usr/bin/perl
+#!@PREFIX@/bin/perl
# aolserver-errors.pl
#

View file

@ -0,0 +1,10 @@
$NetBSD: patch-ad,v 1.1.1.1 2001/07/19 04:36:07 cjones Exp $
--- bin/queue-message.pl.orig Wed Jul 18 21:33:09 2001
+++ bin/queue-message.pl Wed Jul 18 21:33:32 2001
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!@PREFIX@/bin/perl
#
# Respond to incoming mail message on STDIN
#

4
www/openacs/pkg/DESCR Normal file
View file

@ -0,0 +1,4 @@
OpenACS is the PostgreSQL port of Ars Digita, an open-source product
for "building scalable, community-oriented web applications."
OpenACS comes with a huge variety of modules already built.

10
www/openacs/pkg/MESSAGE Normal file
View file

@ -0,0 +1,10 @@
=============================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2001/07/19 04:36:06 cjones Exp $
To install an OpenACS server, run the ${PREFIX}/bin/install-openacs
script, giving it a database user (must already exist), database name
(must NOT already exist), and an installation directory. For example:
# psql -c "create user acsuser createdb" template1
# ${PREFIX}/bin/install-openacs -u acsuser -d acsdb /web/openacs
=============================================================================

3792
www/openacs/pkg/PLIST Normal file

File diff suppressed because it is too large Load diff