HP-UX is icky in that EAGAIN != EWOULDBLOCK and select(2) can return both
things. Fortunately libX11 has code to handle this already. Enable it for HP-UX.
This commit is contained in:
parent
053aef4689
commit
bafb37be43
2 changed files with 17 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.6 2007/08/05 22:39:38 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.7 2008/01/14 06:50:51 tnn Exp $
|
||||
|
||||
SHA1 (libX11-1.1.3.tar.bz2) = 235f69172b262f874d2a2d7bd17e8197aea5b767
|
||||
RMD160 (libX11-1.1.3.tar.bz2) = fcb8d5d31befa0ae227210dc7274c17b30c37fad
|
||||
|
@ -10,3 +10,4 @@ SHA1 (patch-ad) = 58645e734f48334ce5cbf62f5870d087d95194ee
|
|||
SHA1 (patch-ae) = 124c47038ac2c12dd37f3f63606396b9ed976822
|
||||
SHA1 (patch-af) = a97f3b31eecc783caecfeb315ac2cf6603ec32a5
|
||||
SHA1 (patch-ag) = 0d1cf4804049fd3640d627ddfbab7b717f20b445
|
||||
SHA1 (patch-ah) = 7c8e5a87c4cf3048e54448bef60e69193b39f24b
|
||||
|
|
15
x11/libX11/patches/patch-ah
Normal file
15
x11/libX11/patches/patch-ah
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ah,v 1.1 2008/01/14 06:50:52 tnn Exp $
|
||||
|
||||
--- src/XlibInt.c.orig 2007-07-21 10:45:39.000000000 +0200
|
||||
+++ src/XlibInt.c
|
||||
@@ -138,6 +138,10 @@ xthread_t (*_Xthread_self_fn)(void) = NU
|
||||
#ifdef ISC
|
||||
#define ECHECK(err) ((errno == err) || ETEST())
|
||||
#else
|
||||
+#ifdef __hpux
|
||||
+#define ECHECK(err) ((errno == err) || ETEST())
|
||||
+#define SUNSYSV 1
|
||||
+#else
|
||||
#define ECHECK(err) (errno == err)
|
||||
#endif
|
||||
#define ESET(val) errno = val
|
Loading…
Reference in a new issue