-disable the "pre-configure" step which turned out to be unnecessary
and could cause problems when building as non-root, from John Marino -put the build of demo programs (which was optionally, not switched on per default) into its own pkg, to avoid builds in the "install" phase and conditional PLIST entries -misc cleanup, fix a DESTDIR glitch
This commit is contained in:
parent
6126658502
commit
bb64ab9991
10 changed files with 194 additions and 93 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.786 2011/02/28 17:24:09 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.787 2011/03/02 10:14:31 drochner Exp $
|
||||
#
|
||||
|
||||
COMMENT= Packages related to the World Wide Web
|
||||
|
@ -76,6 +76,7 @@ SUBDIR+= apachetop
|
|||
SUBDIR+= asp2php
|
||||
SUBDIR+= august
|
||||
SUBDIR+= aws
|
||||
SUBDIR+= aws-demos
|
||||
SUBDIR+= awstats
|
||||
SUBDIR+= bannerfilter
|
||||
SUBDIR+= bins
|
||||
|
|
21
www/aws-demos/DESCR
Normal file
21
www/aws-demos/DESCR
Normal file
|
@ -0,0 +1,21 @@
|
|||
AWS stands for Ada Web Server, but it is more than just another webserver...
|
||||
|
||||
AWS is a complete framework to develop web based applications. The main
|
||||
part of the framework is the embedded web server. This small yet powerful
|
||||
web server can be embedded into your application so your application will be
|
||||
able to talk with a standard web browser such as Microsoft Internet Explorer
|
||||
or Netscape Communicator. Around this web server, a lot of services have
|
||||
been developed.
|
||||
|
||||
The framework includes:
|
||||
* seb parameters module * session server
|
||||
* SOAP support * WSDL generation from Ada
|
||||
* template parser * AJAX support
|
||||
* HTTPS/SSL support * large server support
|
||||
* virtual hosting support * server push
|
||||
* directory browser * status page
|
||||
* log module * hotplug module
|
||||
* light communications API * configuration API
|
||||
* client API * web page service
|
||||
* SMTP support * LDAP support
|
||||
* Jabber support
|
86
www/aws-demos/Makefile
Normal file
86
www/aws-demos/Makefile
Normal file
|
@ -0,0 +1,86 @@
|
|||
# $NetBSD: Makefile,v 1.1 2011/03/02 10:14:32 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= aws-${AWS_VERSION}
|
||||
PKGNAME= aws-demos-${AWS_VERSION}
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://downloads.dragonlace.net/src/ \
|
||||
http://dragonlace.mirrors.ada.cx/src/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= draco@marino.st
|
||||
HOMEPAGE= http://libre.adacore.com/libre/tools/aws/
|
||||
COMMENT= Adacore Ada Web Server and framework
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
AWS_VERSION= 2.10.0.1
|
||||
USE_TOOLS+= gmake makeinfo sed
|
||||
BUILD_DEPENDS+= gawk:../../lang/gawk
|
||||
PATCHDIR= ${.CURDIR}/../../www/aws/patches
|
||||
DISTINFO_FILE= ${.CURDIR}/../../www/aws/distinfo
|
||||
|
||||
MAKE_ENV+= ADA_PROJECT_PATH=${PREFIX}/lib/gnat
|
||||
|
||||
DEMO_DIRS+= agent
|
||||
DEMO_DIRS+= auth
|
||||
DEMO_DIRS+= com
|
||||
DEMO_DIRS+= dispatch
|
||||
DEMO_DIRS+= hello_world
|
||||
DEMO_DIRS+= hello_wsdl
|
||||
DEMO_DIRS+= hotplug
|
||||
DEMO_DIRS+= interoplab
|
||||
DEMO_DIRS+= jabber_demo
|
||||
DEMO_DIRS+= multiple_sessions
|
||||
DEMO_DIRS+= res_demo
|
||||
DEMO_DIRS+= runme
|
||||
DEMO_DIRS+= soap_demo
|
||||
DEMO_DIRS+= soap_disp
|
||||
DEMO_DIRS+= soap_vs
|
||||
DEMO_DIRS+= split
|
||||
DEMO_DIRS+= test_mail
|
||||
DEMO_DIRS+= text_input
|
||||
DEMO_DIRS+= vh_demo
|
||||
DEMO_DIRS+= web_block
|
||||
DEMO_DIRS+= web_block_ajax
|
||||
DEMO_DIRS+= web_block_ajax_templates
|
||||
DEMO_DIRS+= web_elements
|
||||
DEMO_DIRS+= web_mail
|
||||
DEMO_DIRS+= wps
|
||||
DEMO_DIRS+= ws
|
||||
DEMO_DIRS+= zdemo
|
||||
# untested
|
||||
#PLIST_VARS+= ldap
|
||||
#pkgbase := aws
|
||||
#.include "../../mk/pkg-build-options.mk"
|
||||
#.if !empty(PKG_BUILD_OPTIONS.aws:Mldap)
|
||||
#DEMO_DIRS+= test_ldap
|
||||
#PLIST.ldap= yes
|
||||
#.endif
|
||||
|
||||
post-wrapper:
|
||||
# We disable at least the wrapper binaries on all GNAT AUX to
|
||||
# avoid potential linkage problems
|
||||
${RM} ${WRKDIR}/.wrapper/bin/*
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC} && ${SETENV} CC=gnatgcc \
|
||||
${GMAKE} setup ${CONFIGURE_ARGS}
|
||||
|
||||
do-build:
|
||||
.for dd in ${DEMO_DIRS}
|
||||
cd ${WRKSRC}/demos/${dd} && ${GMAKE}
|
||||
.endfor
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${DESTDIR}${PREFIX}/share/examples/aws/demos
|
||||
.for dd in ${DEMO_DIRS}
|
||||
${FIND} ${WRKSRC}/demos/${dd} -type f -perm -0001 \
|
||||
-exec ${INSTALL} {} ${DESTDIR}${PREFIX}/share/examples/aws/demos/ \;
|
||||
.endfor
|
||||
|
||||
.include "../../www/aws/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../devel/gnatpython/buildlink3.mk"
|
||||
.include "../../devel/gprbuild-aux/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
31
www/aws-demos/PLIST
Normal file
31
www/aws-demos/PLIST
Normal file
|
@ -0,0 +1,31 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2011/03/02 10:14:32 drochner Exp $
|
||||
share/examples/aws/demos/auth
|
||||
share/examples/aws/demos/com_1
|
||||
share/examples/aws/demos/com_2
|
||||
share/examples/aws/demos/dispatch
|
||||
share/examples/aws/demos/hello_world
|
||||
share/examples/aws/demos/hotplug
|
||||
share/examples/aws/demos/interoplab_main
|
||||
share/examples/aws/demos/jabber_demo
|
||||
share/examples/aws/demos/main
|
||||
share/examples/aws/demos/multiple_sessions
|
||||
share/examples/aws/demos/res_demo
|
||||
share/examples/aws/demos/soap_client
|
||||
share/examples/aws/demos/soap_cvs
|
||||
share/examples/aws/demos/soap_server
|
||||
share/examples/aws/demos/soap_server_disp
|
||||
share/examples/aws/demos/soap_svs
|
||||
share/examples/aws/demos/split
|
||||
share/examples/aws/demos/test_mail
|
||||
share/examples/aws/demos/text_input
|
||||
share/examples/aws/demos/vh_demo
|
||||
share/examples/aws/demos/web_block
|
||||
share/examples/aws/demos/web_block_ajax
|
||||
share/examples/aws/demos/web_block_ajax_templates
|
||||
share/examples/aws/demos/web_elements
|
||||
share/examples/aws/demos/web_mail
|
||||
share/examples/aws/demos/wps
|
||||
share/examples/aws/demos/ws
|
||||
share/examples/aws/demos/wsdl_demo_client
|
||||
share/examples/aws/demos/wsdl_demo_server
|
||||
share/examples/aws/demos/zdemo
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/02/11 16:48:52 drochner Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2011/03/02 10:14:31 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= aws-${AWS_VERSION}
|
||||
|
@ -26,9 +26,6 @@ post-wrapper:
|
|||
# avoid potential linkage problems
|
||||
${RM} ${WRKDIR}/.wrapper/bin/*
|
||||
|
||||
pre-configure:
|
||||
gprconfig --batch --config=Ada --config=C --config="Project File"
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC} && ${SETENV} CC=gnatgcc \
|
||||
${GMAKE} setup ${CONFIGURE_ARGS}
|
||||
|
@ -42,24 +39,6 @@ do-test: install
|
|||
do-install:
|
||||
cd ${WRKSRC} && ${SETENV} ${INSTALL_ENV} ${GMAKE} install
|
||||
${TOUCH} ${DESTDIR}${PREFIX}/share/examples/aws/bin/IGNORE.ME
|
||||
.if !empty (BUILD_DEMOS)
|
||||
${MAKE} demos
|
||||
${MAKE} demos-install
|
||||
.endif
|
||||
|
||||
demos:
|
||||
.for dd in ${DEMO_DIRS}
|
||||
cd ${WRKSRC}/demos/${dd} && ${GMAKE}
|
||||
.endfor
|
||||
|
||||
demos-install:
|
||||
.if !empty (BUILD_DEMOS)
|
||||
${MKDIR} ${DESTDIR}${PREFIX}/share/examples/aws/demos
|
||||
.for dd in ${DEMO_DIRS}
|
||||
${FIND} ${WRKSRC}/demos/${dd} -type f -perm -0001 \
|
||||
-exec ${INSTALL} {} ${DESTDIR}${PREFIX}/share/examples/aws/demos/ \;
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../devel/gnatpython/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/02/11 16:48:53 drochner Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2011/03/02 10:14:31 drochner Exp $
|
||||
bin/aws_password
|
||||
bin/awsres
|
||||
bin/templates2ada
|
||||
|
@ -364,7 +364,8 @@ lib/aws/native/relocatable/aws-net-poll_events.ali
|
|||
lib/aws/native/relocatable/aws-net-sets.ali
|
||||
lib/aws/native/relocatable/aws-net-ssl-certificate__dummy.ali
|
||||
lib/aws/native/relocatable/aws-net-ssl__dummy.ali
|
||||
lib/aws/native/relocatable/aws-net-std__gnat.ali
|
||||
${PLIST.noipv6}lib/aws/native/relocatable/aws-net-std__gnat.ali
|
||||
${PLIST.ipv6}lib/aws/native/relocatable/aws-net-std__ipv6.ali
|
||||
lib/aws/native/relocatable/aws-net-stream_io.ali
|
||||
lib/aws/native/relocatable/aws-net-thin.ali
|
||||
lib/aws/native/relocatable/aws-net.ali
|
||||
|
@ -525,7 +526,8 @@ lib/aws/native/static/aws-net-poll_events.ali
|
|||
lib/aws/native/static/aws-net-sets.ali
|
||||
lib/aws/native/static/aws-net-ssl-certificate__dummy.ali
|
||||
lib/aws/native/static/aws-net-ssl__dummy.ali
|
||||
lib/aws/native/static/aws-net-std__gnat.ali
|
||||
${PLIST.noipv6}lib/aws/native/static/aws-net-std__gnat.ali
|
||||
${PLIST.ipv6}lib/aws/native/static/aws-net-std__ipv6.ali
|
||||
lib/aws/native/static/aws-net-stream_io.ali
|
||||
lib/aws/native/static/aws-net-thin.ali
|
||||
lib/aws/native/static/aws-net.ali
|
||||
|
|
16
www/aws/buildlink3.mk
Normal file
16
www/aws/buildlink3.mk
Normal file
|
@ -0,0 +1,16 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2011/03/02 10:14:31 drochner Exp $
|
||||
|
||||
BUILDLINK_TREE+= aws
|
||||
|
||||
.if !defined(AWS_BUILDLINK3_MK)
|
||||
AWS_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.aws+= aws>=2.10.0.1
|
||||
BUILDLINK_PKGSRCDIR.aws?= ../../www/aws
|
||||
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../devel/gnatpython/buildlink3.mk"
|
||||
.include "../../devel/gprbuild-aux/buildlink3.mk"
|
||||
.endif # AWS_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -aws
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/02/11 16:48:52 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.2 2011/03/02 10:14:31 drochner Exp $
|
||||
|
||||
SHA1 (aws-2.10.0.1.tar.bz2) = 3ea20d4328951089f93caa3693eb24d67cf76594
|
||||
RMD160 (aws-2.10.0.1.tar.bz2) = 8d6c2e9e681f18b16bbd79e76e6b65bb8f07a871
|
||||
|
@ -6,7 +6,7 @@ Size (aws-2.10.0.1.tar.bz2) = 1386481 bytes
|
|||
SHA1 (patch-ac) = 1985aca4185538590cea3d939f095b69495eb0fa
|
||||
SHA1 (patch-ad) = 6bfa89f2837cc0dca4f5c391b7e05e74a3d85181
|
||||
SHA1 (patch-ae) = 44f66219a999b90d626f8f581942ae4f406e6c18
|
||||
SHA1 (patch-ba) = 62e5a370d44eeeca7a9ee9e50445d20242808631
|
||||
SHA1 (patch-ba) = 334c40657793f0a6bcec295cc07329ca96bc8372
|
||||
SHA1 (patch-bb) = e2db43dd317b01b9d0e97c481b2851b19469667b
|
||||
SHA1 (patch-bc) = b4f9926351a0ab3c5e5c73601093266f0d8efaaa
|
||||
SHA1 (patch-bd) = b640a61fe75e9bfd06ea6a546ba827a71631517c
|
||||
|
|
|
@ -1,25 +1,25 @@
|
|||
# $NetBSD: options.mk,v 1.1.1.1 2011/02/11 16:48:52 drochner Exp $
|
||||
# $NetBSD: options.mk,v 1.2 2011/03/02 10:14:31 drochner Exp $
|
||||
|
||||
|
||||
# xmlada is built-in (not optional) due to gprbuild dependency
|
||||
# zlib is built-in because it's mandatory. It even comes with AWS.
|
||||
# ASIS is not supported right now (custom build, requires part of GNAT)
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.aws
|
||||
PKG_SUPPORTED_OPTIONS= ssl demos ldap ipv6 debug disable-shared-rt relocatable
|
||||
PKG_SUGGESTED_OPTIONS= ssl
|
||||
# The "ipv6" option effectively disabled IPv4 support, so it
|
||||
# should not be switched on per default even on systems which
|
||||
# support IPv6. For that reason, the option name is not "inet6".
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.aws
|
||||
PKG_SUPPORTED_OPTIONS= ssl ldap ipv6 debug disable-shared-rt relocatable
|
||||
PKG_SUGGESTED_OPTIONS= ssl
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
|
||||
CONFIGURE_ARGS+= GCC=gnatgcc
|
||||
CONFIGURE_ARGS+= PROCESSORS=1
|
||||
CONFIGURE_ARGS+= PYTHON=python2.6
|
||||
DOTBUILD= release
|
||||
DEMO_DIRS=
|
||||
|
||||
|
||||
# The system libgcc is from version 4.1 which doesn't include the symbol
|
||||
# _Unwind_GetIPInfo. If AWS uses the system zlib or if it's configured to use
|
||||
|
@ -35,7 +35,6 @@ DEMO_DIRS=
|
|||
CONFIGURE_ARGS+= ZLIB=false
|
||||
.endif
|
||||
|
||||
|
||||
###################
|
||||
## SSL Support ##
|
||||
###################
|
||||
|
@ -49,71 +48,27 @@ CONFIGURE_ARGS+= SOCKET=openssl
|
|||
.endif
|
||||
.endif
|
||||
|
||||
|
||||
|
||||
####################
|
||||
## LDAP Support ##
|
||||
####################
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mldap)
|
||||
CONFIGURE_ARGS+= LDAP=true
|
||||
DEPENDS+= openldap>=2.4:/../../databases/openldap
|
||||
DEPENDS+= openldap>=2.4:../../databases/openldap
|
||||
.endif
|
||||
|
||||
|
||||
|
||||
#####################
|
||||
## DEMOS Support ##
|
||||
#####################
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mdemos)
|
||||
BUILD_DEMOS= YES
|
||||
|
||||
DEMO_DIRS+= agent
|
||||
DEMO_DIRS+= auth
|
||||
DEMO_DIRS+= com
|
||||
DEMO_DIRS+= dispatch
|
||||
DEMO_DIRS+= hello_world
|
||||
DEMO_DIRS+= hello_wsdl
|
||||
DEMO_DIRS+= hotplug
|
||||
DEMO_DIRS+= interoplab
|
||||
DEMO_DIRS+= jabber_demo
|
||||
DEMO_DIRS+= multiple_sessions
|
||||
DEMO_DIRS+= res_demo
|
||||
DEMO_DIRS+= runme
|
||||
DEMO_DIRS+= soap_demo
|
||||
DEMO_DIRS+= soap_disp
|
||||
DEMO_DIRS+= soap_vs
|
||||
DEMO_DIRS+= split
|
||||
DEMO_DIRS+= test_mail
|
||||
DEMO_DIRS+= text_input
|
||||
DEMO_DIRS+= vh_demo
|
||||
DEMO_DIRS+= web_block
|
||||
DEMO_DIRS+= web_block_ajax
|
||||
DEMO_DIRS+= web_block_ajax_templates
|
||||
DEMO_DIRS+= web_elements
|
||||
DEMO_DIRS+= web_mail
|
||||
DEMO_DIRS+= wps
|
||||
DEMO_DIRS+= ws
|
||||
DEMO_DIRS+= zdemo
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mldap)
|
||||
DEMO_DIRS+= test_ldap
|
||||
.endif
|
||||
.endif
|
||||
|
||||
|
||||
|
||||
####################
|
||||
## IPv6 Support ##
|
||||
####################
|
||||
|
||||
PLIST_VARS+= ipv6 noipv6
|
||||
.if !empty(PKG_OPTIONS:Mipv6)
|
||||
CONFIGURE_ARGS+= IPv6=true
|
||||
PLIST.ipv6= yes
|
||||
.else
|
||||
PLIST.noipv6= yes
|
||||
.endif
|
||||
|
||||
|
||||
|
||||
#####################
|
||||
## Debug Support ##
|
||||
#####################
|
||||
|
@ -123,8 +78,6 @@ CONFIGURE_ARGS+= DEBUG=true
|
|||
DOTBUILD=debug
|
||||
.endif
|
||||
|
||||
|
||||
|
||||
##############################
|
||||
## Shared Runtime Library ##
|
||||
##############################
|
||||
|
@ -133,8 +86,6 @@ DOTBUILD=debug
|
|||
CONFIGURE_ARGS+= ENABLE_SHARED=false
|
||||
.endif
|
||||
|
||||
|
||||
|
||||
############################
|
||||
## Default Library Type ##
|
||||
############################
|
||||
|
|
|
@ -1,9 +1,23 @@
|
|||
$NetBSD: patch-ba,v 1.1.1.1 2011/02/11 16:48:53 drochner Exp $
|
||||
$NetBSD: patch-ba,v 1.2 2011/03/02 10:14:31 drochner Exp $
|
||||
|
||||
--- makefile.orig 2011-02-10 19:28:41.000000000 +0000
|
||||
--- makefile.orig 2011-01-25 20:53:19.000000000 +0000
|
||||
+++ makefile
|
||||
@@ -424,38 +424,38 @@ install_clean:
|
||||
$(RM) -f $(I_GPR)/aws.gpr
|
||||
@@ -416,46 +416,46 @@ setup_tp:
|
||||
$(MAKE) -C templates_parser setup $(GALL_OPTIONS)
|
||||
|
||||
install_clean:
|
||||
- $(RM) -fr $(I_INC)/$(PLATFORM)
|
||||
- $(RM) -fr $(I_LIB)
|
||||
- $(RM) -fr $(I_AGP)
|
||||
- $(RM) -fr $(prefix)/share/examples/aws
|
||||
- $(RM) -fr $(I_DOC)
|
||||
- $(RM) -f $(I_GPR)/aws.gpr
|
||||
+ $(RM) -fr $(DESTDIR)$(I_INC)/$(PLATFORM)
|
||||
+ $(RM) -fr $(DESTDIR)$(I_LIB)
|
||||
+ $(RM) -fr $(DESTDIR)$(I_AGP)
|
||||
+ $(RM) -fr $(DESTDIR)$(prefix)/share/examples/aws
|
||||
+ $(RM) -fr $(DESTDIR)$(I_DOC)
|
||||
+ $(RM) -f $(DESTDIR)$(I_GPR)/aws.gpr
|
||||
|
||||
install_dirs: install_clean
|
||||
- $(MKDIR) -p $(I_BIN)
|
||||
|
|
Loading…
Reference in a new issue