Fix build with gcc4. From Hans Rosenfeld in PR 35498.

This commit is contained in:
wiz 2007-01-27 11:08:57 +00:00
parent d59f7cb98a
commit bb6ad10e17
4 changed files with 65 additions and 1 deletions

View file

@ -1,7 +1,10 @@
$NetBSD: distinfo,v 1.5 2006/04/28 15:33:28 joerg Exp $ $NetBSD: distinfo,v 1.6 2007/01/27 11:08:57 wiz Exp $
SHA1 (gpsim-20050905.tar.gz) = 46e7d0d69695961aca4324d8d3267181bd641081 SHA1 (gpsim-20050905.tar.gz) = 46e7d0d69695961aca4324d8d3267181bd641081
RMD160 (gpsim-20050905.tar.gz) = 1b717f0e51440c4e2db72a4bdfb90d2e8d5e4a3d RMD160 (gpsim-20050905.tar.gz) = 1b717f0e51440c4e2db72a4bdfb90d2e8d5e4a3d
Size (gpsim-20050905.tar.gz) = 2027957 bytes Size (gpsim-20050905.tar.gz) = 2027957 bytes
SHA1 (patch-aa) = f7d1c04b216ecabaf3071f92c97c7436a54f1e87 SHA1 (patch-aa) = f7d1c04b216ecabaf3071f92c97c7436a54f1e87
SHA1 (patch-ab) = cd3ef9b6bef759e95ee18b1995d514546c2475ae SHA1 (patch-ab) = cd3ef9b6bef759e95ee18b1995d514546c2475ae
SHA1 (patch-ac) = 47ff4e3cd8a9255a85519a29a61f1d1f51997965
SHA1 (patch-ae) = 31c9ac582edf2e9e543905f0af6aed92da49f73c
SHA1 (patch-af) = 7cc61d6a1b6476a2a120ae15f25c500693f1897f

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.3 2007/01/27 11:08:57 wiz Exp $
--- cli/ui_gpsim.cc.orig 2005-08-30 19:12:00.000000000 +0000
+++ cli/ui_gpsim.cc
@@ -33,7 +33,7 @@ public:
CGpsimUserInterface(const char *paStrings[]);
virtual ~CGpsimUserInterface() {}
- void CGpsimUserInterface::SetStreams(FILE *in, FILE *out);
+ void SetStreams(FILE *in, FILE *out);
virtual ISimConsole &GetConsole();
virtual void DisplayMessage(unsigned int uStringID, ...);
virtual void DisplayMessage(FILE * pOut, unsigned int uStringID, ...);

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.3 2007/01/27 11:08:57 wiz Exp $
--- src/p12x.h.orig 2005-08-31 14:48:18.000000000 +0000
+++ src/p12x.h
@@ -108,7 +108,7 @@ class P12CE518 : public P12C508
virtual PROCESSOR_TYPE isa(void){return _P12CE518_;};
virtual void tris_instruction(unsigned int tris_register);
- virtual void P12CE518::set_eeprom(I2C_EE *e);
+ virtual void set_eeprom(I2C_EE *e);
P12CE518(void);
static Processor *construct(void);

View file

@ -0,0 +1,35 @@
$NetBSD: patch-af,v 1.3 2007/01/27 11:08:57 wiz Exp $
--- src/value.h.orig 2005-08-31 14:48:22.000000000 +0000
+++ src/value.h
@@ -290,7 +290,7 @@ public:
bool getVal() { return value; }
- static Boolean* Boolean::typeCheck(Value* val, string valDesc);
+ static Boolean* typeCheck(Value* val, string valDesc);
virtual bool compare(ComparisonOperator *compOp, Value *rvalue);
virtual Value *copy() { return new Boolean(value); }
@@ -353,9 +353,9 @@ public:
virtual char *toString(char *, int len);
virtual char *toBitStr(char *, int len);
- static Integer* Integer::typeCheck(Value* val, string valDesc);
- static Integer* Integer::assertValid(Value* val, string valDesc, gint64 valMin);
- static Integer* Integer::assertValid(Value* val, string valDesc, gint64 valMin, gint64 valMax);
+ static Integer* typeCheck(Value* val, string valDesc);
+ static Integer* assertValid(Value* val, string valDesc, gint64 valMin);
+ static Integer* assertValid(Value* val, string valDesc, gint64 valMin, gint64 valMax);
virtual bool compare(ComparisonOperator *compOp, Value *rvalue);
inline operator gint64() {
@@ -498,7 +498,7 @@ public:
/// copy the object value to a user char array
virtual char *toString(char *, int len);
- static AbstractRange* AbstractRange::typeCheck(Value* val, string valDesc);
+ static AbstractRange* typeCheck(Value* val, string valDesc);
virtual bool compare(ComparisonOperator *compOp, Value *rvalue);
private: