Update gworkspace to 0.6.3. Notable changes include:
* GWNet new subproject GWNet is a smb and ftp file viewer. * GWorkspace/GWSplitView.m -updateDiskSpaceInfo: rewritten. * Viewers/IconsViewer/PathIcon.m -mouseUp: implemented. * GWorkspace/Inspectors/Tools.m fixed a bug that crashed the app because a view created in Gorm was not retained before releasing its window. * applied patch by Matt Rice <ratmice@yahoo.com> that changes the usage of setStringValue: on many NSButtons to setTitle. * Viewers/IconsViewer/IconsPanel.m Viewers/IconsViewer/IconsPath.m Viewers/IconsViewer/IconsViewer.m Viewers/SmallIconsViewer/SmallIcon.m Viewers/SmallIconsViewer/SmallIconsPanel.m Viewers/SmallIconsViewer/SmallIconsViewer.m applied patch by S.J. Chun <chunsj@embian.com> to not access superviews before they are set. * added the "GWRemoteFilenamesPboardType" in all the classes that implements the DraggingDestination protocol * GWLib/FSWatcher.m added a NSNotificationQueue. * GWorkspace/Fiend/Fiend.m GWorkspace/FiendLeaf/FiendLeaf.m added DraggingDestination methods to the window. * GWorkspace/Recycler/Recycler.m the DraggingDestination is now the window. * ContentViewers/PdfViewer/PdfViewer.m applied a patch (by Charles Philip Chan <cpchan@sympatico.ca>) to make the pdf Inspector work with Ghostscript 8. * GWorkspace/main.m the key equivalent for "Quit" is now "Q". * Version 0.6.2 * GWorkspace/GWorkspace.m check the defaults for "NoWarnOnQuit" * ClipBook/ClipBookWindow.m added the DraggingDestination methods and removed them from the subviews. added support for the NSColorPboardType type. * ContentViewers/PasteboardViewer/PasteboardViewer.m added support for the NSColorPboardType pasteboard type. * Version 0.6.1 * ClipBook new subproject. * GWorkspace/Resources removed some duplicate files. * GWorkspace/TShelf/TShelfIconsView.m creates pasteboard icons also from dnd. * GWorkspace/TShelf/TShelfView.m reset the current selection when changing from a pasteboard tab to a normal one. * GWorkspace/FileOperations/FileOperation.m in -doDuplicate changed the suffix "_copy" appended to the file name to a prepended string, that is, "copy_of_". * All the DraggingSources now consider also the offset in -dragImage:at:offset:event:pasteboard:source:slideBack: (on GNUstep this does nothing but I need it for osx) * GWorkspace/Resources/Icons Added some icons for Mac OS X. * GWLib/externs.m added icons names. * GWorkspace/FileOperations/FileOperation.m Now works on Mac OS X, too. * GWorkspace/Resources/English.lproj Modified some .nib files. * A new Viewer opened on "/" now saves in the defaults its own shelf content and doesn't use anymore the shelf content of the main viewer. * Utilities/thumbnailer/thumbnailerInfo.plist moved "Make thumbnail(s)" and "Remove thumbnail(s)" in a submenu. they are now "Thumbnails/Make thumbnail(s)" and "Thumbnails/Remove thumbnail(s)". German translation by Martin Brecher <martin@mb-itconsulting.com>. * GWorkspace/Resources/German.lproj updated German Localized.strings (by Martin Brecher <martin@mb-itconsulting.com>) * ContentViewers/AppViewer/AppViewer.m shows also the extensions. * now the miniwindow icons reflect current directory icon instead of view type. * a new root viewer created has now the same shelf content of the first one. * Info->Preferences->Hidden files It is now possible to define directories as hidden. * ContentViewers/PasteboardViewer/PasteboardViewer.m Added a dummy implementation of GormNSBrowser, GormNSTableView, GormNSOutlineView, GormNSMenu, GormNSPopUpButtonCell and GormNSPopUpButton Now the viewer seems to works with all the Gorm objects. * ContentViewers/PasteboardViewer/PasteboardViewer.m Enabled. Actually it works with many Gorm objects. Problems with: NSBrowser, NSTableView, NSOutlineView and NSPopUpMenu. * ContentViewers/PasteboardViewer New contents viewer inspector. * Added support for cut, copy and paste operation to the Tabbed Shelf. * GWorkspace/TShelf/TShelfPBIcon.h GWorkspace/TShelf/TShelfPBIcon.m New files. * GWorkspace/Resources/Icons/ Added: Pboard.tiff, colorPboard.tiff, filecontsPboard.tiff Files, gormPboard.tiff, rtfPboard.tiff, rtfdPboard.tiff, stringPboard.tiff, tiffPboard.tiff. * GWorkspace/GWorkspace.m Added a "Do you really want to quit?" dialog in -applicationShouldTerminate:. Added some keyEquivalents to the tabbed shelf menues. * GWorkspace/TShelf/TShelfWin.m Reduced the height of the shelf by 6 pts. * GWorkspace/Desktop/DesktopView.m GWorkspace/Shelf/Shelf.m in -fileSystemDidChange: fixed a bug that leaved a renamed icon locked. * GWorkspace/FileOperations/FileOperation.m -calculateNumFiles doesn't block anymore. the stop button now works and the GWFileSystemDidChangeNotification is sent only with the processed files. * Viewers/SmallIconsViewer/SmallIconsPanel.m in -selectIconWithPath: now the view scroll to show the icon. * GWorkspace/Inspectors/Tools.m after setting the default application, the applications icons are now shown correctly. * Version 0.6 * GWLib/GWProtocol.h and GWorkspace/GWorkspace.m -sortedDirectoryContentsAtPath: -checkHiddenFiles:atPath: -setCachedMax: -addWatcherForPath: -removeWatcherForPath: -lockFiles:inDirectoryAtPath: -unLockFiles:inDirectoryAtPath: -isLockedPath: -existsAndIsDirectoryFileAtPath: -typeOfFileAt: -isPakageAtPath: -sortTypeForDirectoryAtPath: -setSortType:forDirectoryAtPath: -setDefSortType: -defSortType -setHideSysFiles: -hideSysFiles -iconForFile:ofType: -smallIconForFile: -smallIconForFiles: -smallHighlightIcon -setUseThumbnails: -imageExtensions all these methods have been moved in GWLib
This commit is contained in:
parent
427e9fa275
commit
bb712b5e4e
6 changed files with 301 additions and 454 deletions
|
@ -1,13 +1,12 @@
|
|||
# $NetBSD: Makefile,v 1.7 2004/03/26 02:27:55 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2004/04/11 03:20:34 rh Exp $
|
||||
#
|
||||
|
||||
.include "Makefile.common"
|
||||
PKGREVISION= 5
|
||||
|
||||
COMMENT= GNUstep Workspace manager
|
||||
|
||||
pre-install:
|
||||
${CP} ${FILESDIR}/GNUmakefile ${WRKSRC}/GWLib
|
||||
|
||||
.include "../../sysutils/GWLib/buildlink2.mk"
|
||||
.include "../../sysutils/GWLib/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile.common,v 1.8 2004/01/24 15:06:57 grant Exp $
|
||||
# $NetBSD: Makefile.common,v 1.9 2004/04/11 03:20:34 rh Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gworkspace-0.5.3
|
||||
DISTNAME= gworkspace-0.6.3
|
||||
CATEGORIES?= sysutils gnustep
|
||||
MASTER_SITES= http://www.gnustep.it/enrico/gworkspace/ \
|
||||
http://www.imago.ro/gworkspace/
|
||||
|
@ -10,13 +10,9 @@ MAINTAINER?= tech-pkg@NetBSD.org
|
|||
HOMEPAGE?= http://www.gnustep.it/enrico/gworkspace/
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/gw/GW/}
|
||||
USE_BUILDLINK2= YES
|
||||
USE_GNU_TOOLS+= make
|
||||
USE_X11= YES
|
||||
MAKEFILE= GNUmakefile
|
||||
GNU_CONFIGURE= YES
|
||||
GNU_CONFIGURE_PREFIX= ${PREFIX}/share/GNUstep
|
||||
USE_BUILDLINK3= yes
|
||||
USE_X11= yes
|
||||
|
||||
.include "../../x11/gnustep-back/buildlink2.mk"
|
||||
.include "../../mk/pthread.buildlink2.mk"
|
||||
.include "../../x11/gnustep-back/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/ghostscript.mk"
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,6 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2003/07/06 08:51:34 rh Exp $
|
||||
$NetBSD: distinfo,v 1.3 2004/04/11 03:20:34 rh Exp $
|
||||
|
||||
SHA1 (gworkspace-0.5.3.tar.gz) = 93d38f8ec63e6f391415ee8a97dc056457680c1e
|
||||
Size (gworkspace-0.5.3.tar.gz) = 1104593 bytes
|
||||
SHA1 (patch-aa) = 0fb9a1d949b4bbadc5d9492a03885f6da6a40aa6
|
||||
SHA1 (patch-ab) = c6e81a172c3fc769606cfad2110b0a6d0fc44bee
|
||||
SHA1 (gworkspace-0.6.3.tar.gz) = 2c0060e25852e9783b75bfa78bd63973a46f2c70
|
||||
Size (gworkspace-0.6.3.tar.gz) = 1337761 bytes
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2003/07/06 08:51:34 rh Exp $
|
||||
|
||||
--- Utilities/thumbnailer/main.m.orig 2003-06-30 23:40:26.000000000 +1000
|
||||
+++ Utilities/thumbnailer/main.m
|
||||
@@ -677,18 +677,26 @@ int main(int argc, char** argv, char **e
|
||||
exit(0);
|
||||
}
|
||||
|
||||
+#if GS_WITH_GC
|
||||
CREATE_AUTORELEASE_POOL (pool);
|
||||
+#endif
|
||||
thumbnailer = [Thumbnailer new];
|
||||
+#if GS_WITH_GC
|
||||
RELEASE (pool);
|
||||
+#endif
|
||||
|
||||
if (thumbnailer != nil) {
|
||||
+#if GS_WITH_GC
|
||||
CREATE_AUTORELEASE_POOL (pool);
|
||||
+#endif
|
||||
|
||||
[NSApplication sharedApplication];
|
||||
NSRegisterServicesProvider(thumbnailer, @"Thumbnailer");
|
||||
[[NSRunLoop currentRunLoop] run];
|
||||
|
||||
+#if GS_WITH_GC
|
||||
RELEASE (pool);
|
||||
+#endif
|
||||
}
|
||||
|
||||
exit(0);
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2003/07/06 08:51:35 rh Exp $
|
||||
|
||||
--- GWorkspace/GWorkspace.m.orig 2003-07-01 19:38:26.000000000 +1000
|
||||
+++ GWorkspace/GWorkspace.m
|
||||
@@ -92,6 +92,7 @@ static GWorkspace *gworkspace = nil;
|
||||
BOOL confirm = !([defaults boolForKey: confirmString]);
|
||||
NSRect scr = [[NSScreen mainScreen] visibleFrame];
|
||||
NSRect wrect = NSZeroRect;
|
||||
+ NSRect wr;
|
||||
FileOperation *op;
|
||||
int i;
|
||||
|
||||
@@ -105,7 +106,7 @@ static GWorkspace *gworkspace = nil;
|
||||
|
||||
for (i = 0; i < [operations count]; i++) {
|
||||
op = [operations objectAtIndex: i];
|
||||
- NSRect wr = [op winRect];
|
||||
+ wr = [op winRect];
|
||||
|
||||
if (NSEqualRects(wr, NSZeroRect) == NO) {
|
||||
wrect = NSMakeRect(wr.origin.x + WSHIFT,
|
Loading…
Reference in a new issue