lua-cyrussasl: Ensure objects used in shared libraries are built with -fPIC.

Do not invoke git during builds.
This commit is contained in:
nia 2023-08-06 10:14:50 +00:00
parent c219351ed3
commit bb71b7ebc7
3 changed files with 15 additions and 5 deletions

View File

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.2 2022/05/09 00:41:57 khorben Exp $
# $NetBSD: Makefile,v 1.3 2023/08/06 10:14:50 nia Exp $
DISTNAME= ${GITHUB_PROJECT}-${PKGVERSION_NOREV}
PKGNAME= ${LUA_PKGPREFIX}-${GITHUB_PROJECT:S/lua-//}-1.1.0
PKGREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GITHUB:=JorjBauer/}
GITHUB_PROJECT= lua-cyrussasl
@ -16,8 +17,9 @@ USE_LANGUAGES= c
.include "../../mk/bsd.prefs.mk"
CFLAGS+= -fPIC
MAKE_FLAGS+= CPATH="${DESTDIR}${PREFIX}/${LUA_CDIR}"
MAKE_FLAGS+= LDFLAGS="-shared -lsasl2 -L${PREFIX}/lib -Wl,-rpath,${PREFIX}/lib -L${PREFIX}/${LUA_LDIR}"
MAKE_FLAGS+= LDFLAGS="-shared -lsasl2 -L${PREFIX}/lib -Wl,-rpath,${PREFIX}/lib -L${PREFIX}/${LUA_LDIR} ${LDFLAGS}"
.include "../../security/cyrus-sasl/buildlink3.mk"
.include "../../lang/lua/module.mk"

View File

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.1 2022/05/09 00:37:58 khorben Exp $
$NetBSD: distinfo,v 1.2 2023/08/06 10:14:50 nia Exp $
BLAKE2s (lua-cyrussasl-1.1.0.tar.gz) = a2ced3c0ea7bef8afd61592ea7b8ab1b91c3460811cf094d256d46b99ef3030b
SHA512 (lua-cyrussasl-1.1.0.tar.gz) = 2262dd1e403bd0825b714253dc03844aad20525b206d8fb16196b2647b642a45d137b18bdd89920d95c168b99c5e6b36d73b7cdaa6ec91d3ad2673360307e0ee
Size (lua-cyrussasl-1.1.0.tar.gz) = 14325 bytes
SHA1 (patch-Makefile) = 8dc1f2bbe6b507dd4c792a14925692e5d008404d
SHA1 (patch-Makefile) = b35c5a19d0c66afa25eeb4a1e5b069e402f02e87

View File

@ -1,7 +1,9 @@
$NetBSD: patch-Makefile,v 1.1 2022/05/09 00:37:59 khorben Exp $
$NetBSD: patch-Makefile,v 1.2 2023/08/06 10:14:50 nia Exp $
Allow using the right compilation flags and installation path
Do not invoke git.
--- Makefile.orig 2015-08-21 22:24:54.000000000 +0000
+++ Makefile
@@ -17,11 +17,11 @@
@ -29,3 +31,9 @@ Allow using the right compilation flags and installation path
cp $(TARGET) $(CPATH)
clean:
@@ -67,5 +68,4 @@ context.c: context.h
version:
@if ! test -f $(BUILD_VERSION); then echo 0 > $(BUILD_VERSION); fi
@echo $$(($$(cat $(BUILD_VERSION)) + 1)) > $(BUILD_VERSION)
- @if ! test -f $(BRANCH_VERSION); then git log --pretty=oneline -1|cut -c1-8 > $(BRANCH_VERSION); fi