Remove zope211, Zope 2.11.8.
Zope 2.11.8 is EOL and the package itself isn't maintained for long time. Since newer Plone and Zope introduce their own install framework, it is difficult to support it in pkgsrc unless someone create some framework.
This commit is contained in:
parent
7a795e496b
commit
bb95830197
16 changed files with 0 additions and 9317 deletions
|
@ -1,17 +0,0 @@
|
|||
Zope is an exciting new object-based, open source web application
|
||||
platform. It allows you to build powerful and dynamic web applications
|
||||
easily. Zope comes with source code and is friendly to developers as
|
||||
well as users.
|
||||
Zope is distinguished by its integrated object database which, when
|
||||
combined with a revolutionary object model, provides a completely unique
|
||||
facility for servicing content managers and web application developers.
|
||||
|
||||
Here are some of the "headlines" mentioned in the features list.
|
||||
|
||||
Database Integration Content Management
|
||||
SQL and HTML in Harmony Builtin Objects
|
||||
Multiple Data Sources Document Templates
|
||||
Publish Databases Web to Objects
|
||||
Application Development Integrated Object Database
|
||||
DTML Scripting Managed Through the Web
|
||||
External Methods Direct URL Access to Objects
|
|
@ -1,47 +0,0 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.2 2008/07/20 02:14:23 taca Exp $
|
||||
|
||||
Zope Successfull installed.
|
||||
|
||||
To create an instance of Zope please run
|
||||
${ZOPE_DIR}/bin/mkzopeinstance.py -d <INSTANCEDIR>
|
||||
|
||||
<INSTANCEDIR> is the directory where the instance files should
|
||||
be installed. This can be ${ZOPE_DIR}
|
||||
but not recommended.
|
||||
|
||||
Command-line options to 'mkzopeinstance' are available, and can be
|
||||
investigated by running 'mkzopeinstance.py --help'.
|
||||
|
||||
The Instancefiles created by mkzopeinstance.py will not be remove
|
||||
when the package is deinstalled. You`ll have to delete them yourself.
|
||||
|
||||
If Zope should get started automatically when the system starts,
|
||||
please add the following lines to /etc/rc.conf
|
||||
|
||||
zope${ZOPE_VERSION}${RCVAR_SUFFIX}="YES"
|
||||
zope${ZOPE_VERSION}_instances="<INSTANCEDIR>"
|
||||
zope${ZOPE_VERSION}_encoding="<ENCODING>"
|
||||
|
||||
You can optionally specify default character encoding for python
|
||||
as <ENCODING> (default is utf-8).
|
||||
|
||||
Additional zope Instances have to be added to zope${ZOPE_VERSION}_instances
|
||||
seperated by a space.
|
||||
|
||||
** ZEO Instances ** (Optional)
|
||||
** Please refere to http://zope.org/Products/ZEO/ZEOFactSheet
|
||||
|
||||
If you want to run a ZEO server please create a ZEO instancen by
|
||||
calling ${ZOPE_DIR}/bin/mkzopeinstance.py --dir <ZEODIR>
|
||||
|
||||
To start the ZEO Server at System startup add the following lines to
|
||||
/etc/rc.conf
|
||||
|
||||
zeo${ZOPE_VERSION}${RCVAR_SUFFIX}="YES"
|
||||
zeo${ZOPE_VERSION}_instances="<ZEODIR>"
|
||||
zeo${ZOPE_VERSION}_encoding="<ENCODING>"
|
||||
|
||||
Additional zeo Instances have to be added to zeo${ZOPE_VERSION}_instances
|
||||
seperated by a space.
|
||||
===========================================================================
|
|
@ -1,99 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.8 2012/02/02 09:56:53 hans Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Zope-${ZOPE211_VERSION}-final
|
||||
PKGNAME= ${ZOPE_PKG_PREFIX}-${ZOPE211_VERSION}
|
||||
CATEGORIES= www python
|
||||
MASTER_SITES= http://www.zope.org/Products/Zope/${ZOPE211_VERSION}/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.zope.org/
|
||||
COMMENT= Zope, the Z Object Publishing Environment
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
DEPENDS+= ${PYPKGPREFIX}-expat>=0:../../textproc/py-expat
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 24
|
||||
ZOPE_VERSION= 211
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --prefix=${ZOPE_DIR} --with-python=${PYTHONBIN} --quiet
|
||||
BUILD_TARGET= build version_txt
|
||||
MAKE_FILE= makefile
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${_USE_DESTDIR} != "no"
|
||||
INSTALL_MAKE_FLAGS= INSTALL_FLAGS=--root=${DESTDIR:Q}
|
||||
.endif
|
||||
|
||||
INSTALLATION_DIRS= ${ZOPE_DOC_DIR}/zeo ${ZOPE_DOC_DIR}/zope
|
||||
OWN_DIRS+= ${ZOPE_PRODUCTS_DIR}
|
||||
RCD_SCRIPTS= zope${ZOPE_VERSION} zeo${ZOPE_VERSION}
|
||||
RCD_SCRIPT_SRC.zope${ZOPE_VERSION}= ../zope/files/zope.sh
|
||||
RCD_SCRIPT_SRC.zeo${ZOPE_VERSION}= ../zope/files/zeo.sh
|
||||
|
||||
OWN_DIRS+= ${ZOPE_BASE}/skel/etc/package-includes ${ZOPE_PRODUCTS_BASE}
|
||||
|
||||
SUBST_CLASSES+= param
|
||||
SUBST_STAGE.param= pre-configure
|
||||
SUBST_FILES.param+= skel/etc/zope.conf.in utilities/mkzopeinstance.py
|
||||
SUBST_SED.param+= -e "s|@ZOPE_PRODUCTS_DIR@|${ZOPE_PRODUCTS_DIR}|g"
|
||||
SUBST_SED.param+= -e "s|@ZOPE_USER@|${ZOPE_USER}|g"
|
||||
SUBST_SED.param+= -e "s|@ZOPE_GROUP@|${ZOPE_GROUP}|g"
|
||||
SUBST_MESSAGE.param= Fixing some parameters in files.
|
||||
|
||||
REPLACE_PYTHON= \
|
||||
lib/python/AccessControl/securitySuite/regressionSecurity.py \
|
||||
lib/python/Interface/pyskel.py lib/python/OFS/ndiff.py \
|
||||
lib/python/Products/PageTemplates/tests/run.py \
|
||||
lib/python/Products/PluginIndexes/TextIndex/Splitter/setup.py \
|
||||
lib/python/StructuredText/ClassicStructuredText.py \
|
||||
lib/python/ZEO/zeoctl.py lib/python/ZTUtils/tests/run.py \
|
||||
lib/python/Zope2/Startup/misc/zpasswd.py \
|
||||
lib/python/Zope2/Startup/zopectl.py \
|
||||
lib/python/docutils/readers/python/pynodes.py \
|
||||
lib/python/pytz/tzfile.py lib/python/zdaemon/zdctl.py \
|
||||
lib/python/zdaemon/zdrun.py lib/python/zdaemon/tests/nokill.py \
|
||||
lib/python/zope/security/setup.py test.py
|
||||
REPLACE_PYTHON_DIRS+= lib/python/Products/ZCTextIndex/tests \
|
||||
lib/python/Products/ZCatalog/regressiontests lib/python/TAL \
|
||||
lib/python/ZEO/scripts lib/python/ZODB/scripts \
|
||||
lib/python/ZServer/medusa lib/python/zope/app/locales \
|
||||
lib/python/zope/index/text lib/python/zope/rdb/gadfly \
|
||||
lib/python/zope/tal utilities
|
||||
USE_TOOLS+= pax
|
||||
|
||||
pre-patch:
|
||||
${CP} ../zope/files/sitecustomize.py ${WRKSRC}/lib/python
|
||||
${RM} -f ${WRKSRC}/skel/bin/runzope.bat.in
|
||||
|
||||
post-extract:
|
||||
cd ${WRKSRC}; ${FIND} doc lib skel/import -type f -print | \
|
||||
${XARGS} ${CHMOD} -x
|
||||
cd ${WRKSRC}/lib/python/RestrictedPython/tests && \
|
||||
${RM} -f before_and_after25.py before_and_after26.py \
|
||||
security_in_syntax26.py
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC}; ${PY_COMPILE_ALL} .
|
||||
|
||||
pre-install:
|
||||
${FIND} ${WRKSRC} \( -name '*.orig' -o -name svn-commit.tmp \) \
|
||||
-print | ${XARGS} -- ${RM} -f
|
||||
|
||||
post-install:
|
||||
cd ${WRKSRC}/doc/ZEO; pax -rw *.txt ${DESTDIR}${ZOPE_DOC_DIR}/zeo
|
||||
cd ${WRKSRC}/doc; pax -rw *.txt ${DESTDIR}${ZOPE_DOC_DIR}/zope
|
||||
${FIND} ${DESTDIR}${ZOPE_DIR} ${DESTDIR}${ZOPE_DOC_DIR} -type f -print \
|
||||
| ${XARGS} -- ${CHMOD} a-w+r
|
||||
${FIND} ${DESTDIR}${ZOPE_DIR} -type f -name '*.pyc' -print | \
|
||||
${XARGS} -- ${CHMOD} a-x
|
||||
|
||||
.include "../../www/zope/Makefile.common"
|
||||
.include "../../www/zope/replace.mk"
|
||||
.include "../../www/zope/zopeversion.mk"
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
8906
www/zope211/PLIST
8906
www/zope211/PLIST
File diff suppressed because it is too large
Load diff
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.6 2011/11/11 18:48:24 joerg Exp $
|
||||
|
||||
SHA1 (Zope-2.11.8-final.tgz) = 0d06b6c4842f00db7c4b900f9f3860e911276a46
|
||||
RMD160 (Zope-2.11.8-final.tgz) = 64cedf8576296fa1722af9bd17df5e074a8b2fce
|
||||
Size (Zope-2.11.8-final.tgz) = 7335479 bytes
|
||||
SHA1 (patch-aa) = 85124be8493036eb8b835c5050cac98d8e808aff
|
||||
SHA1 (patch-ab) = fb9da4fcf47fa1ec0119ff94f9e3124135016d2d
|
||||
SHA1 (patch-ac) = 62f2bcbaeb6bd064cbcbea2e2fa0d36a2c8bbf48
|
||||
SHA1 (patch-ad) = 7bc7ef78c2367324deaedd326015f9fd2f0b027a
|
||||
SHA1 (patch-ae) = 427deb06bbed0f0b23efa14ce1ad5f820d2f3d0f
|
||||
SHA1 (patch-af) = 3b352c8bd6cc8f7360025d3d27267a0319cd6b17
|
||||
SHA1 (patch-ag) = dffc88b9d087e01bf853441c4a9064a9184a310f
|
||||
SHA1 (patch-ah) = 360c8f69e1f23a9f0dec666d509e03e4ef55d93b
|
||||
SHA1 (patch-ai) = 1b08b88cbd9e8950c1c24a85ddceff273a175892
|
||||
SHA1 (patch-inst-Makefile.in) = f0ab14a78fe2f19317eedc3e046f063c5df1ef8e
|
||||
SHA1 (patch-lib_python_mechanize___firefox3cookiejar.py) = 21e5350bf364b6df919251c08dfc66a72c356ac6
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2008/06/21 10:39:31 taca Exp $
|
||||
|
||||
--- lib/python/Products/SiteAccess/tests/testVirtualHostMonster.py.orig 2007-03-25 18:46:14.000000000 +0900
|
||||
+++ lib/python/Products/SiteAccess/tests/testVirtualHostMonster.py
|
||||
@@ -12,6 +12,7 @@
|
||||
|
||||
from Testing.makerequest import makerequest
|
||||
|
||||
+from __future__ import generators
|
||||
import Zope2
|
||||
Zope2.startup()
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2008/06/21 10:39:31 taca Exp $
|
||||
|
||||
--- lib/python/RestrictedPython/tests/verify.py.orig 2007-03-25 18:46:21.000000000 +0900
|
||||
+++ lib/python/RestrictedPython/tests/verify.py
|
||||
@@ -21,6 +21,7 @@ all attribute access is performed via th
|
||||
function.
|
||||
"""
|
||||
|
||||
+from __future__ import generators
|
||||
import dis
|
||||
import types
|
||||
|
|
@ -1,73 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2008/06/21 10:39:31 taca Exp $
|
||||
|
||||
--- lib/python/zope/structuredtext/document.py.orig 2007-03-25 18:51:59.000000000 +0900
|
||||
+++ lib/python/zope/structuredtext/document.py
|
||||
@@ -556,7 +556,7 @@ class Document:
|
||||
|
||||
def doc_literal(
|
||||
self, s,
|
||||
- expr = re.compile(r"(\W+|^)'([%s%s%s\s]+)'([%s]+|$)" % (letters, digits, literal_punc, phrase_delimiters)).search,):
|
||||
+ expr = re.compile(r"(\W+|^)'((?:\w|[%s%s\s])+)'([%s]+|$)" % (digits, literal_punc, phrase_delimiters), re.U).search,):
|
||||
r = expr(s)
|
||||
if r:
|
||||
start, end = r.span(2)
|
||||
@@ -564,7 +564,8 @@ class Document:
|
||||
|
||||
def doc_emphasize(
|
||||
self, s,
|
||||
- expr = re.compile(r'\*([%s%s%s\s]+?)\*' % (letters, digits, strongem_punc)).search
|
||||
+ # i18nal variant
|
||||
+ expr = re.compile(r'\*((?:\w|[%s\s])+?)\*' % (strongem_punc), re.U).search
|
||||
):
|
||||
|
||||
r=expr(s)
|
||||
@@ -605,7 +606,7 @@ class Document:
|
||||
|
||||
def doc_underline(self,
|
||||
s,
|
||||
- expr=re.compile(r'_([%s%s%s\s]+)_([\s%s]|$)' % (letters, digits, under_punc,phrase_delimiters)).search):
|
||||
+ expr=re.compile(r'_((?:\w|[%s\s])+)_([\s%s]|$)' % (under_punc,phrase_delimiters), re.U).search):
|
||||
|
||||
result = expr(s)
|
||||
if result:
|
||||
@@ -617,7 +618,7 @@ class Document:
|
||||
|
||||
def doc_strong(self,
|
||||
s,
|
||||
- expr = re.compile(r'\*\*([%s%s%s\s]+?)\*\*' % (letters, digits, strongem_punc)).search
|
||||
+ expr = re.compile(r'\*\*((?:\w|[%s%s\s])+?)\*\*' % (digits, strongem_punc), re.U).search
|
||||
#expr = re.compile(r'\s*\*\*([ \n\r%s0-9.:/;,\'\"\?\-\_\/\=\-\>\<\(\)]+)\*\*(?!\*|-)' % letters).search, # old expr, inconsistent punc, failed to cross newlines.
|
||||
):
|
||||
|
||||
@@ -627,19 +628,19 @@ class Document:
|
||||
return (stng.StructuredTextStrong(s[start:end]), start-2, end+2)
|
||||
|
||||
## Some constants to make the doc_href() regex easier to read.
|
||||
- _DQUOTEDTEXT = r'("[ %s0-9\n\r%s]+")' % (letters,dbl_quoted_punc) ## double quoted text
|
||||
+ _DQUOTEDTEXT = r'("[^"]+")' ## double quoted text
|
||||
_ABSOLUTE_URL=r'((http|https|ftp|mailto|file|about)[:/]+?[%s0-9_\@\.\,\?\!\/\:\;\-\#\~\=\&\%%\+]+)' % letters
|
||||
_ABS_AND_RELATIVE_URL=r'([%s0-9_\@\.\,\?\!\/\:\;\-\#\~\=\&\%%\+]+)' % letters
|
||||
|
||||
_SPACES = r'(\s*)'
|
||||
|
||||
def doc_href1(self, s,
|
||||
- expr=re.compile(_DQUOTEDTEXT + "(:)" + _ABS_AND_RELATIVE_URL + _SPACES).search
|
||||
+ expr=re.compile(_DQUOTEDTEXT + "(:)" + _ABS_AND_RELATIVE_URL + _SPACES, re.U).search
|
||||
):
|
||||
return self.doc_href(s, expr)
|
||||
|
||||
def doc_href2(self, s,
|
||||
- expr=re.compile(_DQUOTEDTEXT + r'(\,\s+)' + _ABSOLUTE_URL + _SPACES).search
|
||||
+ expr=re.compile(_DQUOTEDTEXT + r'(\,\s+)' + _ABSOLUTE_URL + _SPACES, re.U).search
|
||||
):
|
||||
return self.doc_href(s, expr)
|
||||
|
||||
@@ -693,7 +694,7 @@ class DocumentWithImages(Document):
|
||||
|
||||
def doc_img(
|
||||
self, s,
|
||||
- expr1=re.compile('\"([ _a-zA-Z0-9*.:/;,\[\]\'\-\n\~]+)\":img:([a-zA-Z0-9%\_\-.:/\?=;,\n\~]+)').search,
|
||||
+ expr1=re.compile('\"((?:\w|[ *.:/;,\-\n\~])+)\":img:([a-zA-Z0-9\_\-.:/;,\n\~]+)', re.U).search,
|
||||
):
|
||||
|
||||
r=expr1(s)
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2008/06/21 10:39:31 taca Exp $
|
||||
|
||||
--- lib/python/zope/structuredtext/stletters.py.orig 2007-03-25 18:51:59.000000000 +0900
|
||||
+++ lib/python/zope/structuredtext/stletters.py
|
||||
@@ -24,7 +24,7 @@ def punc_func(exclude):
|
||||
return punc
|
||||
|
||||
digits = string.digits
|
||||
-letters = string.letters
|
||||
+letters = string.letters + '\200-\377\?\!'
|
||||
literal_punc = punc_func("'")
|
||||
dbl_quoted_punc = punc_func("\"")
|
||||
strongem_punc = punc_func('*')
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2008/06/21 10:39:31 taca Exp $
|
||||
|
||||
--- lib/python/zope/structuredtext/stng.py.orig 2007-03-25 18:51:59.000000000 +0900
|
||||
+++ lib/python/zope/structuredtext/stng.py
|
||||
@@ -105,6 +105,9 @@ def structurize(paragraphs, delimiter=re
|
||||
[paragraph,[sub-paragraphs]]
|
||||
"""
|
||||
|
||||
+ if type(paragraphs) == type(''):
|
||||
+ paragraphs = unicode(paragraphs, 'utf-8')
|
||||
+
|
||||
currentlevel = 0
|
||||
currentindent = 0
|
||||
levels = {0:0}
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 2008/06/21 10:39:31 taca Exp $
|
||||
|
||||
--- setup.py.orig 2007-03-25 18:46:27.000000000 +0900
|
||||
+++ setup.py
|
||||
@@ -493,7 +493,6 @@ def skel_visit(skel, dirname, names):
|
||||
skel.append(("../../" + dirname, L))
|
||||
|
||||
installed_data_files = [
|
||||
- ["../../doc", ['doc/*.txt']],
|
||||
["../../bin", ['utilities/README.txt']],
|
||||
]
|
||||
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-ag,v 1.1.1.1 2008/06/21 10:39:31 taca Exp $
|
||||
|
||||
--- skel/etc/zope.conf.in.orig 2007-03-25 18:46:27.000000000 +0900
|
||||
+++ skel/etc/zope.conf.in
|
||||
@@ -90,6 +90,8 @@ instancehome $INSTANCE
|
||||
# Example:
|
||||
#
|
||||
# products /home/chrism/projects/myproducts
|
||||
+products @ZOPE_PRODUCTS_DIR@
|
||||
+products $INSTANCE/Products
|
||||
|
||||
|
||||
# Directive: environment
|
||||
@@ -147,6 +149,7 @@ instancehome $INSTANCE
|
||||
# Example:
|
||||
#
|
||||
# effective-user chrism
|
||||
+effective-user zope
|
||||
|
||||
|
||||
# Directive: enable-product-installation
|
|
@ -1,38 +0,0 @@
|
|||
$NetBSD: patch-ah,v 1.1.1.1 2008/06/21 10:39:31 taca Exp $
|
||||
|
||||
# set owner/group for Zone instance's some directories.
|
||||
|
||||
--- utilities/mkzopeinstance.py.orig 2007-10-29 22:09:41.000000000 +0900
|
||||
+++ utilities/mkzopeinstance.py
|
||||
@@ -32,8 +32,14 @@ import os
|
||||
import shutil
|
||||
import sys
|
||||
import copyzopeskel
|
||||
+import pwd
|
||||
+import grp
|
||||
|
||||
def main():
|
||||
+ dirs = ['log', 'var']
|
||||
+ user = '@ZOPE_USER@'
|
||||
+ group = '@ZOPE_GROUP@'
|
||||
+
|
||||
try:
|
||||
opts, args = getopt.getopt(sys.argv[1:],
|
||||
"hu:d:s:",
|
||||
@@ -124,6 +130,16 @@ def main():
|
||||
copyzopeskel.copyskel(skelsrc, skeltarget, None, None, **kw)
|
||||
if user and password:
|
||||
write_inituser(inituser, user, password)
|
||||
+ try:
|
||||
+ u = pwd.getpwnam(user)
|
||||
+ g = grp.getgrnam(group)
|
||||
+
|
||||
+ for d in dirs:
|
||||
+ p = os.path.join(instancehome, d)
|
||||
+ os.chown(p, u.pw_uid, g.gr_gid)
|
||||
+ except:
|
||||
+ sys.exit(1)
|
||||
+
|
||||
|
||||
def usage(stream, msg=None):
|
||||
if msg:
|
|
@ -1,9 +0,0 @@
|
|||
$NetBSD: patch-ai,v 1.2 2011/05/14 02:58:09 taca Exp $
|
||||
|
||||
--- utilities/reindex_catalog.py.orig 2011-02-04 21:44:27.000000000 +0000
|
||||
+++ utilities/reindex_catalog.py
|
||||
@@ -1,3 +1,4 @@
|
||||
+#!/usr/bin/env python2.4
|
||||
##############################################################################
|
||||
#
|
||||
# Copyright (c) 2002 Zope Foundation and Contributors.
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-inst-Makefile.in,v 1.1 2011/11/11 18:48:24 joerg Exp $
|
||||
|
||||
--- inst/Makefile.in.orig 2011-11-11 17:14:02.000000000 +0000
|
||||
+++ inst/Makefile.in
|
||||
@@ -55,7 +54,7 @@ unbuild:
|
||||
install: build version_txt
|
||||
${PYTHON} "${BASE_DIR}/setup.py" ${DISTUTILS_OPTS} install \
|
||||
--home="${PREFIX}" ${BUILD_FLAGS} ${INSTALL_FLAGS}
|
||||
- [ -f ${PREFIX}/bin/python ] || ${LN} ${PYTHON} ${PREFIX}/bin/python
|
||||
+ [ -f ${DESTDIR}${PREFIX}/bin/python ] || ${LN} ${PYTHON} ${DESTDIR}${PREFIX}/bin/python
|
||||
@echo
|
||||
@echo Zope binaries installed successfully.
|
||||
@echo Now run \'${PREFIX}/bin/mkzopeinstance.py\'
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-lib_python_mechanize___firefox3cookiejar.py,v 1.1 2011/05/14 02:58:09 taca Exp $
|
||||
|
||||
--- lib/python/mechanize/_firefox3cookiejar.py.orig 2011-02-04 21:45:35.000000000 +0000
|
||||
+++ lib/python/mechanize/_firefox3cookiejar.py
|
||||
@@ -89,8 +89,9 @@ class Firefox3CookieJar(CookieJar):
|
||||
cur.execute(query, params)
|
||||
for row in cur.fetchall():
|
||||
yield row
|
||||
- finally:
|
||||
+ except:
|
||||
cur.close()
|
||||
+ raise
|
||||
|
||||
def _create_table_if_necessary(self):
|
||||
self._execute("""\
|
Loading…
Reference in a new issue