Update to 3.3. Patches for tests on NetBSD have been integrated.

3.3:

This is a regularly scheduled feature release with over 800 changes.

1.1. commands

    add: add back forgotten files even when not matching exactly (BC)
    addremove: add back forgotten files (BC)
    addremove: add support for the -S flag
    addremove: print relative paths when called with -I/-X (BC)
    addremove: support addremove with explicit paths in subrepos
    backout: add --commit option
    commit: abort if --addremove is specified, but fails
    commit: remove reverse search for copy source when not in parent (issue4476)
    commit: propagate --addremove to subrepos if -S is specified (issue3759)
    graft: show more useful status information while grafting

1.2. core

    bundles: do not overwrite existing backup bundles (BC)
    osx: patch .pax.gz files in pkg bundles so they extract as root (issue4081)
    revset: handle hidden linkrev for file missing for head (issue4490)
    revset: allow rev(-1) to indicate null revision (BC)
    revset: fix ancestors(null) to include null revision (issue4512)
    subrepo: don't abort in add when non-hg subrepos are present (issue4513)
    cmdserver: use given streams as pipe channels like other commands
    extensions: only check compatibility against major and minor versions (BC)
    https: support tls sni (server name indication) for https urls (issue3090)
    ignore: resolve ignore files relative to repo root (issue4473) (BC)
    linkrev: handle filtered linkrev with no visible children (issue4307)
    linkrev: also adjust linkrev when bootstrapping annotate (issue4305)
    linkrev: use the right manifest content when adjusting linrev (issue4499)
    memctx: calculate manifest correctly with newly-removed files (issue4470)
    memctx: fix manifest for removed files (issue4470)
    obsstore: disable garbage collection during initialization (issue4456)
    subrepo: support remove with explicit paths in subrepos
    subrepo: add full revert support for git subrepos
    subrepo: add partial diff support for git subrepos
    subrepo: add status support for ignored files in git subrepos
    win32: remove Mercurial.ini file from Inno Setup installer (issue4435)

1.3. hgweb

    hgweb: allow viewing diffs against p1 or p2 for merge commits (issue3904)

1.4. extensions

    color: add support for colorizing git subrepo diffs
    color: add missing 'dim' in _effects
    convert: on svn failure, note libsvn version (issue4043)
    convert: replace revision references in messages if they are >= short hashes
    convert: handle LookupError in mercurial_source.lookuprev()
    extdiff: reintroduce backward compatibility with manual quoting of parameters
    histedit: add a test to show that issue4251 is fixed (issue4251)
    largefiles: fix commit of a directory with no largefile changes (issue4330)
    largefiles: use 'default' path for pulling largefiles, not 'default-push'
    largefiles: enable subrepo support for add, forget, remove
    largefiles: show progress when checking standin hashes in outgoing changesets
    mq: smarter handling of plain headers
    patchbomb: don't honor whitespace and format-changing diffopts (BC)
    rebase: show more useful status information while rebasing
    rebase: ensure rebase revision remains visible (issue4504)
    extdiff: avoid unexpected quoting arguments for external tools (issue4463)
    highlight: ignore Unicode's extra linebreaks (issue4291)
    record: don't honor format-changing diffopts (issue4459)
    share: add option to share bookmarks
    transplant: properly skip empty changeset (issue4423)
This commit is contained in:
wiz 2015-02-03 11:09:55 +00:00
parent 4cc6e289ec
commit bb9b287573
9 changed files with 11 additions and 128 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile.version,v 1.13 2015/01/03 09:26:40 wiz Exp $
# $NetBSD: Makefile.version,v 1.14 2015/02/03 11:09:55 wiz Exp $
VERSION= 3.2.4
VERSION= 3.3
PYTHON_VERSIONS_INCOMPATIBLE= 33 34 # not yet ported as of 2.9
# see also http://mercurial.selenic.com/wiki/SupportedPythonVersions

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2014/11/02 17:38:25 wiz Exp $
@comment $NetBSD: PLIST,v 1.5 2015/02/03 11:09:55 wiz Exp $
bin/hg
${PYSITELIB}/hgext/__init__.py
${PYSITELIB}/hgext/__init__.pyc
@ -249,6 +249,7 @@ ${PYSITELIB}/mercurial/dagparser.pyo
${PYSITELIB}/mercurial/dagutil.py
${PYSITELIB}/mercurial/dagutil.pyc
${PYSITELIB}/mercurial/dagutil.pyo
${PYSITELIB}/mercurial/default.d/mergetools.rc
${PYSITELIB}/mercurial/demandimport.py
${PYSITELIB}/mercurial/demandimport.pyc
${PYSITELIB}/mercurial/demandimport.pyo
@ -424,6 +425,9 @@ ${PYSITELIB}/mercurial/minirst.py
${PYSITELIB}/mercurial/minirst.pyc
${PYSITELIB}/mercurial/minirst.pyo
${PYSITELIB}/mercurial/mpatch.so
${PYSITELIB}/mercurial/namespaces.py
${PYSITELIB}/mercurial/namespaces.pyc
${PYSITELIB}/mercurial/namespaces.pyo
${PYSITELIB}/mercurial/node.py
${PYSITELIB}/mercurial/node.pyc
${PYSITELIB}/mercurial/node.pyo

View file

@ -1,11 +1,5 @@
$NetBSD: distinfo,v 1.14 2015/01/03 09:26:40 wiz Exp $
$NetBSD: distinfo,v 1.15 2015/02/03 11:09:55 wiz Exp $
SHA1 (mercurial-3.2.4.tar.gz) = 6adc45a99f036a3fe3433a4d24e5641c91acb693
RMD160 (mercurial-3.2.4.tar.gz) = 96ca807bcccd0e00d1171c0541bc9ef351aa3f3f
Size (mercurial-3.2.4.tar.gz) = 4078698 bytes
SHA1 (patch-tests_test-convert-cvs-branch.t) = 2d801e2e11ab64aa2788b4a31269d72d419f8991
SHA1 (patch-tests_test-convert-cvs-detectmerge.t) = cc1a846e6fa090149a1ee5d5a91640d7ce39c19a
SHA1 (patch-tests_test-convert-cvs-synthetic.t) = 6978a6a513f04ef1a24b1026642aa03e2d9869e6
SHA1 (patch-tests_test-convert-cvs.t) = 69f9210d59066a2bfb8f2f6fce7642a7c9009dc1
SHA1 (patch-tests_test-convert-cvsnt-mergepoints.t) = 4bfdeb98ece867ea1bb16c0b1dd0db65fc9412a1
SHA1 (patch-tests_test-run-tests.t) = dbf53354652831bf67a22b60e9000356269c0ef6
SHA1 (mercurial-3.3.tar.gz) = 9bc03b6e82ce7bccb9d2608c7a5c4023adf2290c
RMD160 (mercurial-3.3.tar.gz) = 949f621e6581329b8732c5b3d9888b55960e6d45
Size (mercurial-3.3.tar.gz) = 4162147 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-tests_test-convert-cvs-branch.t,v 1.1 2014/12/28 17:16:54 wiz Exp $
Fix cvs-specific tests with cvs-1.12.
http://bz.selenic.com/show_bug.cgi?id=4482
--- tests/test-convert-cvs-branch.t.orig 2014-12-18 20:59:22.000000000 +0000
+++ tests/test-convert-cvs-branch.t
@@ -21,6 +21,7 @@ create cvs repository
$ CVS_OPTIONS=-f
$ export CVS_OPTIONS
$ cd ..
+ $ rmdir cvsrepo
$ cvscall -q -d "$CVSROOT" init
Create a new project

View file

@ -1,15 +0,0 @@
$NetBSD: patch-tests_test-convert-cvs-detectmerge.t,v 1.1 2014/12/28 17:16:54 wiz Exp $
Fix cvs-specific tests with cvs-1.12.
http://bz.selenic.com/show_bug.cgi?id=4482
--- tests/test-convert-cvs-detectmerge.t.orig 2014-12-18 20:59:22.000000000 +0000
+++ tests/test-convert-cvs-detectmerge.t
@@ -31,7 +31,6 @@ XXX copied from test-convert-cvs-synthet
create cvs repository with one project
- $ mkdir cvsrepo
$ cvscall -q -d "$CVSROOT" init
$ mkdir cvsrepo/proj

View file

@ -1,15 +0,0 @@
$NetBSD: patch-tests_test-convert-cvs-synthetic.t,v 1.1 2014/12/28 17:16:54 wiz Exp $
Fix cvs-specific tests with cvs-1.12.
http://bz.selenic.com/show_bug.cgi?id=4482
--- tests/test-convert-cvs-synthetic.t.orig 2014-12-18 20:59:22.000000000 +0000
+++ tests/test-convert-cvs-synthetic.t
@@ -14,6 +14,7 @@ create cvs repository with one project
$ CVS_OPTIONS=-f
$ export CVS_OPTIONS
$ cd ..
+ $ rmdir cvsrepo
$ cvscall()
> {
> cvs -f "$@"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-tests_test-convert-cvs.t,v 1.1 2014/12/28 17:16:54 wiz Exp $
Fix cvs-specific tests with cvs-1.12.
http://bz.selenic.com/show_bug.cgi?id=4482
--- tests/test-convert-cvs.t.orig 2014-12-18 20:59:22.000000000 +0000
+++ tests/test-convert-cvs.t
@@ -31,6 +31,7 @@ create cvs repository
$ CVS_OPTIONS=-f
$ export CVS_OPTIONS
$ cd ..
+ $ rmdir cvsrepo
$ cvscall -q -d "$CVSROOT" init
create source directory

View file

@ -1,15 +0,0 @@
$NetBSD: patch-tests_test-convert-cvsnt-mergepoints.t,v 1.1 2014/12/28 17:16:54 wiz Exp $
Fix cvs-specific tests with cvs-1.12.
http://bz.selenic.com/show_bug.cgi?id=4482
--- tests/test-convert-cvsnt-mergepoints.t.orig 2014-12-18 20:59:22.000000000 +0000
+++ tests/test-convert-cvsnt-mergepoints.t
@@ -32,6 +32,7 @@ create cvs repository
$ CVS_OPTIONS=-f
$ export CVS_OPTIONS
$ cd ..
+ $ rmdir cvsmaster
$ filterpath cvscall -Q -d "$CVSROOT" init
checkout #1: add foo.txt

View file

@ -1,40 +0,0 @@
$NetBSD: patch-tests_test-run-tests.t,v 1.1 2014/12/28 22:47:59 wiz Exp $
Adapt glob so this works with NetBSD's /bin/sh.
http://bz.selenic.com/show_bug.cgi?id=4484
--- tests/test-run-tests.t.orig 2014-12-18 20:59:22.000000000 +0000
+++ tests/test-run-tests.t
@@ -181,22 +181,22 @@ Running In Debug Mode
======================
$ $TESTDIR/run-tests.py --with-hg=`which hg` --debug 2>&1 | grep -v pwd
- + echo SALT* 0 0 (glob)
- SALT* 0 0 (glob)
+ + echo *SALT* 0 0 (glob)
+ *SALT* 0 0 (glob)
+ echo babar
babar
- + echo SALT* 4 0 (glob)
- SALT* 4 0 (glob)
- .+ echo SALT* 0 0 (glob)
- SALT* 0 0 (glob)
+ + echo *SALT* 4 0 (glob)
+ *SALT* 4 0 (glob)
+ .+ echo *SALT* 0 0 (glob)
+ *SALT* 0 0 (glob)
+ echo babar
babar
- + echo SALT* 2 0 (glob)
- SALT* 2 0 (glob)
+ + echo *SALT* 2 0 (glob)
+ *SALT* 2 0 (glob)
+ echo xyzzy
xyzzy
- + echo SALT* 4 0 (glob)
- SALT* 4 0 (glob)
+ + echo *SALT* 4 0 (glob)
+ *SALT* 4 0 (glob)
.
# Ran 2 tests, 0 skipped, 0 warned, 0 failed.