pcmanfm-qt: fix location of default desktop settings config

Place the desktop settings configuration file where the rest of LXQt
(as configured in pkgsrc presently) expects it to be, so fallbacks
work if a user doesn't already have a custom configuration defined.
This does not affect standalone use of this application, only its
functionality that provides the desktop background for LXQt. (Ride
previous commits of LXQt earlier today; this doesn't merit a recursive
dependency bump.)
This commit is contained in:
gutteridge 2020-04-26 02:19:56 +00:00
parent a16dbca970
commit bbf1769839
4 changed files with 20 additions and 6 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.5 2020/04/22 08:33:48 pin Exp $
# $NetBSD: Makefile,v 1.6 2020/04/26 02:19:56 gutteridge Exp $
DISTNAME= pcmanfm-qt-0.14.1
PKGREVISION= 3
PKGREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= https://downloads.lxqt.org/downloads/pcmanfm-qt/0.14.1/
EXTRACT_SUFX= .tar.xz

View file

@ -1,10 +1,10 @@
@comment $NetBSD: PLIST,v 1.1 2020/02/20 06:15:34 gutteridge Exp $
@comment $NetBSD: PLIST,v 1.2 2020/04/26 02:19:56 gutteridge Exp $
bin/pcmanfm-qt
man/man1/pcmanfm-qt.1
share/applications/pcmanfm-qt-desktop-pref.desktop
share/applications/pcmanfm-qt.desktop
share/examples/lxqt/xdg/autostart/lxqt-desktop.desktop
share/pcmanfm-qt/lxqt/settings.conf
share/examples/lxqt/xdg/pcmanfm-qt/lxqt/settings.conf
share/pcmanfm-qt/translations/pcmanfm-qt_ar.qm
share/pcmanfm-qt/translations/pcmanfm-qt_ca.qm
share/pcmanfm-qt/translations/pcmanfm-qt_cs.qm
@ -32,4 +32,3 @@ share/pcmanfm-qt/translations/pcmanfm-qt_tr.qm
share/pcmanfm-qt/translations/pcmanfm-qt_uk.qm
share/pcmanfm-qt/translations/pcmanfm-qt_zh_CN.qm
share/pcmanfm-qt/translations/pcmanfm-qt_zh_TW.qm
@pkgdir lib

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1 2020/02/20 06:15:34 gutteridge Exp $
$NetBSD: distinfo,v 1.2 2020/04/26 02:19:56 gutteridge Exp $
SHA1 (pcmanfm-qt-0.14.1.tar.xz) = 4672228bd0cace0f7c91ce1330cb618576a6e48d
RMD160 (pcmanfm-qt-0.14.1.tar.xz) = a09e756db9ce641bbdbbcf10b33d36069e87f9db
SHA512 (pcmanfm-qt-0.14.1.tar.xz) = f3d170ab8344332f740a3245cc549ea0c3bddc97a45472dcd46208d59413dd42d3571821f309184417a34a627d2cb093fcaa335f782cf6e526eef3fcad212b3e
Size (pcmanfm-qt-0.14.1.tar.xz) = 227360 bytes
SHA1 (patch-config_CMakeLists.txt) = 84ace10083579bf3c09e16b472c92e6146665b85

View file

@ -0,0 +1,14 @@
$NetBSD: patch-config_CMakeLists.txt,v 1.1 2020/04/26 02:19:56 gutteridge Exp $
Install fallback .conf files to a consistent location.
--- config/CMakeLists.txt.orig 2019-02-24 00:16:13.000000000 +0000
+++ config/CMakeLists.txt
@@ -3,6 +3,6 @@
configure_file(pcmanfm-qt/lxqt/settings.conf.in pcmanfm-qt/lxqt/settings.conf @ONLY)
install(FILES
"${CMAKE_CURRENT_BINARY_DIR}/pcmanfm-qt/lxqt/settings.conf"
- DESTINATION "${CMAKE_INSTALL_DATADIR}/pcmanfm-qt/lxqt"
+ DESTINATION "${LXQT_ETC_XDG_DIR}/pcmanfm-qt/lxqt"
COMPONENT Runtime
)