Update to 4.8:

SIP v4.8 has been released. The highlights of this release include
support for Python v3, the ability to supply alternate super-types
and meta-types for wrapped objects, and documentation built using
Sphinx.

The major new features are:

  * support for Python v3
  * the %BIGetBufferCode and %BIReleaseBufferCode to
    support the buffer interface of Python v3
  * the %DefaultMetatype directive and the
    /Metatype/ class annotation to allow the
    meta-type of a wrapped type to be changed
  * the %DefaultSupertype directive and the
    /Supertype/ class annotation to allow the
    super-type of a wrapped type to be changed
  * the sip.simplewrapper type to be used as a
    super-type for wrapped types that don't take
    part in parent/child relationships
  * the %InitialisationCode directive
  * the /KeepReference/ argument annotation
  * the /Encoding/ argument, function, typedef and
    variable annotation
  * super() now works as expected with wrapped types
  * support for __floordiv__, __ifloordiv__,
    __truediv__, __itruediv__ and __index__
  * __bool__ is a synonym for __nonzero__
  * Sphinx is now used for the documentation
  * many additions and deprecations in the API to
    eliminate the differences between classes and
    mapped types. (See the documentation for the
    details.)
This commit is contained in:
wiz 2009-06-09 13:51:57 +00:00
parent 148bf67c0a
commit bbf22e6027
3 changed files with 18 additions and 18 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.3 2008/12/10 00:54:55 wiz Exp $
# $NetBSD: Makefile,v 1.4 2009/06/09 13:51:57 wiz Exp $
#
DISTNAME= sip-4.7.9
DISTNAME= sip-4.8
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= x11 devel python
MASTER_SITES= http://www.riverbankcomputing.com/static/Downloads/sip4/
@ -14,7 +14,7 @@ PKG_DESTDIR_SUPPORT= user-destdir
CONFLICTS+= ${PYPKGPREFIX}-qt2-sip-* ${PYPKGPREFIX}-qt3-sip-*
PYTHON_VERSIONS_ACCEPTED= 25 24 23
PYTHON_VERSIONS_ACCEPTED= 26 25 24 23
USE_LIBTOOL= yes
USE_TOOLS+= gmake

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.2 2008/12/10 00:54:56 wiz Exp $
$NetBSD: distinfo,v 1.3 2009/06/09 13:51:57 wiz Exp $
SHA1 (sip-4.7.9.tar.gz) = a8eabe3890a1fc42ec77ac82fa41344ad23abe09
RMD160 (sip-4.7.9.tar.gz) = 719f7c7ae211ceb2bb7609c5e70d864054ccd23d
Size (sip-4.7.9.tar.gz) = 471372 bytes
SHA1 (patch-aa) = 97bf03e1bfd687773d137a88f6eb527e481c400d
SHA1 (sip-4.8.tar.gz) = ec2273eceb1a8cbcbc70983529ac440000aa22c7
RMD160 (sip-4.8.tar.gz) = 90494e067e873911bcb6962357369ac8ccc93b2b
Size (sip-4.8.tar.gz) = 613197 bytes
SHA1 (patch-aa) = 67da3bbb531ee50ba47b0ce4ee7a6edf5d0ad139
SHA1 (patch-ab) = f5ba9704fc3867a1273dca534b145cdb14b070e7

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.1.1.1 2008/10/08 14:10:45 wiz Exp $
$NetBSD: patch-aa,v 1.2 2009/06/09 13:51:57 wiz Exp $
--- configure.py.orig 2008-08-08 16:07:36.000000000 +0200
--- configure.py.orig 2009-06-05 08:59:07.000000000 +0000
+++ configure.py
@@ -230,7 +230,7 @@ def set_platform_directories():
@@ -198,7 +198,7 @@ def set_platform_directories():
plat_py_lib_dir = lib_dir + "/config"
plat_bin_dir = sys.exec_prefix + "/bin"
@ -11,16 +11,16 @@ $NetBSD: patch-aa,v 1.1.1.1 2008/10/08 14:10:45 wiz Exp $
def create_config(module, template, macros):
@@ -248,7 +248,7 @@ def create_config(module, template, macr
@@ -216,7 +216,7 @@ def create_config(module, template, macr
"sip_version": sip_version,
"sip_version_str": sip_version_str,
"platform": opt_platform,
- "sip_bin": os.path.join(opt_sipbindir, "sip"),
+ "sip_bin": os.path.join(opt_sipbindir, "sip%s" % sys.version[0:3]),
"sip_inc_dir": opt_sipincdir,
"sip_mod_dir": opt_sipmoddir,
"platform": opts.platform,
- "sip_bin": os.path.join(opts.sipbindir, "sip"),
+ "sip_bin": os.path.join(opts.sipbindir, "sip%s" % sys.version[0:3]),
"sip_inc_dir": opts.sipincdir,
"sip_mod_dir": opts.sipmoddir,
"default_bin_dir": plat_bin_dir,
@@ -282,7 +282,7 @@ def create_makefiles(macros):
@@ -249,7 +249,7 @@ def create_makefiles(macros):
sipconfig.ParentMakefile(
configuration=cfg,
subdirs=["sipgen", "siplib"],