Update net/nagstamon to 0.9.8
pkgsrc changes: - Add a patch to install manpage in the proper place. - To preserve compatibility with the previous versions of the package, link installed script nagstamon.py to nagstamon. Upstream changes: 2011-10-25: Version 0.9.8 added customizable acknowledge/downtime/submit-result defaults added regexp filter for status information column added option to connect to hosts via its monitor hostname without HTTP overhead added ability to keep status detail popup open despite hovering away added option to change offset between popup window and systray icon to avoid partly hidden popup fixed some popup artefacts fixed various bugs with acknowledgement flags (persistent/sticky/notification), now they are actually working fixed some issues when running on MacOS X 2011-05-30: Version 0.9.7.1 fixed sf.net bug 3309166 which broke Centreon support 2011-05-30: Version 0.9.7 on some servers now context menu allows submitting check results for hosts and services added filter for services on acknowledged hosts added icons for "passiveonly" and "flapping" hosts and services fix for uneditable text entry fields in settings dialog - sf.net bug 3300873 fix for not working filter "services on hosts in maintenance" - sf.net bug 3299790 fix for soft state detection in Centreon - sf.net bug 3303861 fix for not filtered services which should have been filtered - sf.net bug 3308008 2011-05-06: Version 0.9.6.1 fixed sf.net bug 3298321 which raised an error if everything was OK on monitor 2011-05-06: Version 0.9.6 improved, full Ninja support rewritten filtering mechanism allows new features displaying icons in status overview popup indicating states "acknowledged" and "scheduled downtime" added option to play notification sounds more than once small UI improvements uses BeautifulSoup instead of lxml uses GTK UI Builder instead of glade as always: bugfixes 2011-04-08: Version 0.9.5 added op5 Ninja support added Check_MK Multisite support improved Icinga support (compatibility with Icinga 1.3) improved Centreon support (compatible with Centreon 2.1) added sortable columns in status overview added customizable colors better debugging and error messages password has not necessarily to be stored in config file major memory leak closed various bugs fixed 2010-06-15: Version 0.9.4 added initial support for Centreon servers (beta) added Nagios 1.x support fixed serious pango crash bug (Debian bug 582977) fixed not-playing-sound bug (sf.net bug 2998035) 2010-04-26: Version 0.9.3 added ability to connect to Opsview monitoring servers added "Recheck all" button to recheck all failing hosts and services by one click added ability to toggle notifications by state added HTTP Digest authentication added recognition of customized host IP information (see bug 2967416) increased GUI responsiveness fixed bugs in update interval mechanism fixed minor bugs
This commit is contained in:
parent
afb4032328
commit
bbfa13a91f
5 changed files with 95 additions and 74 deletions
|
@ -1,10 +1,9 @@
|
||||||
# $NetBSD: Makefile,v 1.11 2012/02/06 12:41:16 wiz Exp $
|
# $NetBSD: Makefile,v 1.12 2012/02/18 17:05:27 gls Exp $
|
||||||
#
|
#
|
||||||
|
|
||||||
VERSION= 0.9.2
|
VERSION= 0.9.8
|
||||||
DISTNAME= nagstamon_${VERSION}
|
DISTNAME= nagstamon_${VERSION}
|
||||||
PKGNAME= ${DISTNAME:S/_/-/}
|
PKGNAME= ${DISTNAME:S/_/-/}
|
||||||
PKGREVISION= 9
|
|
||||||
CATEGORIES= net python
|
CATEGORIES= net python
|
||||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=nagstamon/}
|
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=nagstamon/}
|
||||||
|
|
||||||
|
@ -17,24 +16,26 @@ PKG_DESTDIR_SUPPORT= user-destdir
|
||||||
USE_LANGUAGES= # none
|
USE_LANGUAGES= # none
|
||||||
PYDISTUTILSPKG= yes
|
PYDISTUTILSPKG= yes
|
||||||
|
|
||||||
# Upstream's aware of this
|
WRKSRC= ${WRKDIR}/Nagstamon
|
||||||
SUBST_CLASSES+= typo
|
|
||||||
SUBST_STAGE.typo= post-extract
|
|
||||||
SUBST_FILES.typo= ${WRKSRC}/Nagstamon/nagstamonGUI.py
|
|
||||||
SUBST_SED.typo= -e 's|\#!/usr/bin/py\ .*|\#!/usr/bin/python|'
|
|
||||||
SUBST_MESSAGE.typo= Fixing interpreter typo.
|
|
||||||
|
|
||||||
INSTALLATION_DIRS+= ${PKGMANDIR}/man1
|
INSTALLATION_DIRS+= ${PKGMANDIR}/man1
|
||||||
REPLACE_PYTHON= ${WRKSRC}/Nagstamon/*.py
|
REPLACE_PYTHON= ${WRKSRC}/*.py
|
||||||
REPLACE_PYTHON+= ${WRKSRC}/Nagstamon/nagstamon
|
REPLACE_PYTHON+= ${WRKSRC}/Nagstamon/Server/Multisite.py
|
||||||
|
|
||||||
DEPENDS+= ${PYPKGPREFIX}-lxml>=2.2.4:../../textproc/py-lxml
|
DEPENDS+= ${PYPKGPREFIX}-lxml>=2.2.4:../../textproc/py-lxml
|
||||||
DEPENDS+= ${PYPKGPREFIX}-libxslt>=1.1.24:../../textproc/py-libxslt
|
DEPENDS+= ${PYPKGPREFIX}-libxslt>=1.1.24:../../textproc/py-libxslt
|
||||||
DEPENDS+= sox>=14.0.1:../../audio/sox
|
DEPENDS+= sox>=14.0.1:../../audio/sox
|
||||||
|
|
||||||
|
SUBST_CLASSES+= mandir
|
||||||
|
SUBST_STAGE.mandir= pre-configure
|
||||||
|
SUBST_SED.mandir= -e s,@PKGMANDIR@,${PKGMANDIR},g
|
||||||
|
SUBST_FILES.mandir= setup.py
|
||||||
|
|
||||||
|
# Upstream renamed script from nagstamon to nagstamon.py
|
||||||
|
# Preserve compatibility with previous version of the package
|
||||||
post-install:
|
post-install:
|
||||||
${INSTALL_MAN} files/nagstamon.1 \
|
${LN} -s ${DESTDIR}${PREFIX}/bin/nagstamon.py \
|
||||||
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/
|
${DESTDIR}${PREFIX}/bin/nagstamon
|
||||||
|
|
||||||
.include "../../graphics/librsvg/buildlink3.mk"
|
.include "../../graphics/librsvg/buildlink3.mk"
|
||||||
.include "../../textproc/py-libxml2/buildlink3.mk"
|
.include "../../textproc/py-libxml2/buildlink3.mk"
|
||||||
|
|
|
@ -1,59 +1,104 @@
|
||||||
@comment $NetBSD: PLIST,v 1.1.1.1 2010/04/11 09:24:20 imil Exp $
|
@comment $NetBSD: PLIST,v 1.2 2012/02/18 17:05:27 gls Exp $
|
||||||
bin/nagstamon
|
bin/nagstamon
|
||||||
|
bin/nagstamon.py
|
||||||
|
${PYSITELIB}/Nagstamon/Actions.py
|
||||||
|
${PYSITELIB}/Nagstamon/Actions.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/Actions.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/BeautifulSoup.py
|
||||||
|
${PYSITELIB}/Nagstamon/BeautifulSoup.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/BeautifulSoup.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/Config.py
|
||||||
|
${PYSITELIB}/Nagstamon/Config.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/Config.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/Custom.py
|
||||||
|
${PYSITELIB}/Nagstamon/Custom.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/Custom.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/GUI.py
|
||||||
|
${PYSITELIB}/Nagstamon/GUI.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/GUI.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/Objects.py
|
||||||
|
${PYSITELIB}/Nagstamon/Objects.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/Objects.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Centreon.py
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Centreon.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Centreon.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Generic.py
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Generic.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Generic.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Icinga.py
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Icinga.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Icinga.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Multisite.py
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Multisite.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Multisite.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Nagios.py
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Nagios.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Nagios.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Ninja.py
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Ninja.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Ninja.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Opsview.py
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Opsview.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/Server/Opsview.pyo
|
||||||
|
${PYSITELIB}/Nagstamon/Server/__init__.py
|
||||||
|
${PYSITELIB}/Nagstamon/Server/__init__.pyc
|
||||||
|
${PYSITELIB}/Nagstamon/Server/__init__.pyo
|
||||||
${PYSITELIB}/Nagstamon/__init__.py
|
${PYSITELIB}/Nagstamon/__init__.py
|
||||||
${PYSITELIB}/Nagstamon/__init__.pyc
|
${PYSITELIB}/Nagstamon/__init__.pyc
|
||||||
${PYSITELIB}/Nagstamon/__init__.pyo
|
${PYSITELIB}/Nagstamon/__init__.pyo
|
||||||
${PYSITELIB}/Nagstamon/nagstamonActions.py
|
|
||||||
${PYSITELIB}/Nagstamon/nagstamonActions.pyc
|
|
||||||
${PYSITELIB}/Nagstamon/nagstamonActions.pyo
|
|
||||||
${PYSITELIB}/Nagstamon/nagstamonConfig.py
|
|
||||||
${PYSITELIB}/Nagstamon/nagstamonConfig.pyc
|
|
||||||
${PYSITELIB}/Nagstamon/nagstamonConfig.pyo
|
|
||||||
${PYSITELIB}/Nagstamon/nagstamonGUI.py
|
|
||||||
${PYSITELIB}/Nagstamon/nagstamonGUI.pyc
|
|
||||||
${PYSITELIB}/Nagstamon/nagstamonGUI.pyo
|
|
||||||
${PYSITELIB}/Nagstamon/nagstamonObjects.py
|
|
||||||
${PYSITELIB}/Nagstamon/nagstamonObjects.pyc
|
|
||||||
${PYSITELIB}/Nagstamon/nagstamonObjects.pyo
|
|
||||||
${PYSITELIB}/Nagstamon/resources/LICENSE
|
${PYSITELIB}/Nagstamon/resources/LICENSE
|
||||||
${PYSITELIB}/Nagstamon/resources/acknowledge_dialog.glade
|
${PYSITELIB}/Nagstamon/resources/acknowledge_dialog.ui
|
||||||
${PYSITELIB}/Nagstamon/resources/close.png
|
${PYSITELIB}/Nagstamon/resources/close.png
|
||||||
${PYSITELIB}/Nagstamon/resources/close.svg
|
${PYSITELIB}/Nagstamon/resources/close.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/critical.wav
|
${PYSITELIB}/Nagstamon/resources/critical.wav
|
||||||
${PYSITELIB}/Nagstamon/resources/downtime_dialog.glade
|
${PYSITELIB}/Nagstamon/resources/downtime_dialog.ui
|
||||||
${PYSITELIB}/Nagstamon/resources/hostdown.wav
|
${PYSITELIB}/Nagstamon/resources/hostdown.wav
|
||||||
${PYSITELIB}/Nagstamon/resources/hosts.png
|
${PYSITELIB}/Nagstamon/resources/hosts.png
|
||||||
${PYSITELIB}/Nagstamon/resources/hosts.svg
|
${PYSITELIB}/Nagstamon/resources/hosts.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/nagios.png
|
${PYSITELIB}/Nagstamon/resources/nagios.png
|
||||||
${PYSITELIB}/Nagstamon/resources/nagios.svg
|
${PYSITELIB}/Nagstamon/resources/nagios.svg
|
||||||
|
${PYSITELIB}/Nagstamon/resources/nagstamon.1
|
||||||
|
${PYSITELIB}/Nagstamon/resources/nagstamon.desktop
|
||||||
|
${PYSITELIB}/Nagstamon/resources/nagstamon.icns
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon.ico
|
${PYSITELIB}/Nagstamon/resources/nagstamon.ico
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon.png
|
${PYSITELIB}/Nagstamon/resources/nagstamon.png
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon.svg
|
${PYSITELIB}/Nagstamon/resources/nagstamon.svg
|
||||||
|
${PYSITELIB}/Nagstamon/resources/nagstamon_acknowledged.png
|
||||||
|
${PYSITELIB}/Nagstamon/resources/nagstamon_acknowledged.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_black.png
|
${PYSITELIB}/Nagstamon/resources/nagstamon_black.png
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_black.svg
|
${PYSITELIB}/Nagstamon/resources/nagstamon_black.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_darkred.png
|
${PYSITELIB}/Nagstamon/resources/nagstamon_darkred.png
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_darkred.svg
|
${PYSITELIB}/Nagstamon/resources/nagstamon_darkred.svg
|
||||||
|
${PYSITELIB}/Nagstamon/resources/nagstamon_downtime.png
|
||||||
|
${PYSITELIB}/Nagstamon/resources/nagstamon_downtime.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_error.png
|
${PYSITELIB}/Nagstamon/resources/nagstamon_error.png
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_error.svg
|
${PYSITELIB}/Nagstamon/resources/nagstamon_error.svg
|
||||||
|
${PYSITELIB}/Nagstamon/resources/nagstamon_flapping.png
|
||||||
|
${PYSITELIB}/Nagstamon/resources/nagstamon_flapping.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_green.png
|
${PYSITELIB}/Nagstamon/resources/nagstamon_green.png
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_green.svg
|
${PYSITELIB}/Nagstamon/resources/nagstamon_green.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_label.png
|
${PYSITELIB}/Nagstamon/resources/nagstamon_label.png
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_label.svg
|
${PYSITELIB}/Nagstamon/resources/nagstamon_label.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_orange.png
|
${PYSITELIB}/Nagstamon/resources/nagstamon_orange.png
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_orange.svg
|
${PYSITELIB}/Nagstamon/resources/nagstamon_orange.svg
|
||||||
|
${PYSITELIB}/Nagstamon/resources/nagstamon_passive.png
|
||||||
|
${PYSITELIB}/Nagstamon/resources/nagstamon_passive.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_red.png
|
${PYSITELIB}/Nagstamon/resources/nagstamon_red.png
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_red.svg
|
${PYSITELIB}/Nagstamon/resources/nagstamon_red.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_small.png
|
${PYSITELIB}/Nagstamon/resources/nagstamon_small.png
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_small.svg
|
${PYSITELIB}/Nagstamon/resources/nagstamon_small.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_yellow.png
|
${PYSITELIB}/Nagstamon/resources/nagstamon_yellow.png
|
||||||
${PYSITELIB}/Nagstamon/resources/nagstamon_yellow.svg
|
${PYSITELIB}/Nagstamon/resources/nagstamon_yellow.svg
|
||||||
|
${PYSITELIB}/Nagstamon/resources/recheckall.png
|
||||||
|
${PYSITELIB}/Nagstamon/resources/recheckall.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/refresh.png
|
${PYSITELIB}/Nagstamon/resources/refresh.png
|
||||||
${PYSITELIB}/Nagstamon/resources/refresh.svg
|
${PYSITELIB}/Nagstamon/resources/refresh.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/services.png
|
${PYSITELIB}/Nagstamon/resources/services.png
|
||||||
${PYSITELIB}/Nagstamon/resources/services.svg
|
${PYSITELIB}/Nagstamon/resources/services.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/settings.png
|
${PYSITELIB}/Nagstamon/resources/settings.png
|
||||||
${PYSITELIB}/Nagstamon/resources/settings.svg
|
${PYSITELIB}/Nagstamon/resources/settings.svg
|
||||||
${PYSITELIB}/Nagstamon/resources/settings_dialog.glade
|
${PYSITELIB}/Nagstamon/resources/settings_dialog.ui
|
||||||
${PYSITELIB}/Nagstamon/resources/settings_server_dialog.glade
|
${PYSITELIB}/Nagstamon/resources/settings_server_dialog.ui
|
||||||
|
${PYSITELIB}/Nagstamon/resources/submit_check_result_dialog.ui
|
||||||
${PYSITELIB}/Nagstamon/resources/warning.wav
|
${PYSITELIB}/Nagstamon/resources/warning.wav
|
||||||
man/man1/nagstamon.1
|
man/man1/nagstamon.1
|
||||||
|
|
|
@ -1,5 +1,6 @@
|
||||||
$NetBSD: distinfo,v 1.1.1.1 2010/04/11 09:24:20 imil Exp $
|
$NetBSD: distinfo,v 1.2 2012/02/18 17:05:27 gls Exp $
|
||||||
|
|
||||||
SHA1 (nagstamon_0.9.2.tar.gz) = 2c49d9b54cacbc9a813308f337d6d73bb9590ea7
|
SHA1 (nagstamon_0.9.8.tar.gz) = 6721f6b41dc26327e7fe89087e32580703b565dd
|
||||||
RMD160 (nagstamon_0.9.2.tar.gz) = fbadb44702eba2ef72d46ac0fc1d41601cca23c7
|
RMD160 (nagstamon_0.9.8.tar.gz) = 069715f02ade45e0c9efe37045b8bf9d4483845d
|
||||||
Size (nagstamon_0.9.2.tar.gz) = 145601 bytes
|
Size (nagstamon_0.9.8.tar.gz) = 382861 bytes
|
||||||
|
SHA1 (patch-setup.py) = be194ed10d9284921abda1c71ba9486d001dcfd0
|
||||||
|
|
|
@ -1,40 +0,0 @@
|
||||||
'\" t
|
|
||||||
.\" Title: nagstamon
|
|
||||||
.\" Author: [see the "AUTHOR" section]
|
|
||||||
.\" Generator: DocBook XSL Stylesheets v1.75.1 <http://docbook.sf.net/>
|
|
||||||
.\" Date: 03/20/2010
|
|
||||||
.\" Language: English
|
|
||||||
.\"
|
|
||||||
.TH "NAGSTAMON" "1" "03/20/2010"
|
|
||||||
.\" -----------------------------------------------------------------
|
|
||||||
.\" * set default formatting
|
|
||||||
.\" -----------------------------------------------------------------
|
|
||||||
.\" disable hyphenation
|
|
||||||
.nh
|
|
||||||
.\" disable justification (adjust text to left margin only)
|
|
||||||
.ad l
|
|
||||||
.\" -----------------------------------------------------------------
|
|
||||||
.\" * MAIN CONTENT STARTS HERE *
|
|
||||||
.\" -----------------------------------------------------------------
|
|
||||||
.SH "NAME"
|
|
||||||
nagstamon \- Nagios status monitor which takes place in systray or on desktop
|
|
||||||
.SH "SYNOPSIS"
|
|
||||||
.sp
|
|
||||||
nagstamon [alternate\-config]
|
|
||||||
.SH "DESCRIPTION"
|
|
||||||
.sp
|
|
||||||
Nagstamon is a Nagios status monitor which takes place in systray or on desktop (GNOME, KDE) as floating statusbar to inform you in realtime about the status of your Nagios monitored network\&. It allows to connect to multiple Nagios servers\&.
|
|
||||||
.sp
|
|
||||||
The command can optionally take one argument giving the path to an alternate configuration file\&.
|
|
||||||
.SH "OPTIONS"
|
|
||||||
.sp
|
|
||||||
No options\&.
|
|
||||||
.SH "AUTHOR"
|
|
||||||
.sp
|
|
||||||
This manual page has been written by Carl Chenet <chaica@ohmytux\&.com>\&.
|
|
||||||
.SH "RESSOURCES"
|
|
||||||
.sp
|
|
||||||
http://sourceforge\&.net/projects/nagstamon/
|
|
||||||
.SH "LICENSE"
|
|
||||||
.sp
|
|
||||||
This manual page is licensed under the GPL\-2 license\&.
|
|
14
net/nagstamon/patches/patch-setup.py
Normal file
14
net/nagstamon/patches/patch-setup.py
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
$NetBSD: patch-setup.py,v 1.1 2012/02/18 17:05:27 gls Exp $
|
||||||
|
|
||||||
|
Install manpage in the proper location.
|
||||||
|
|
||||||
|
--- setup.py.orig 2011-10-24 13:03:20.000000000 +0000
|
||||||
|
+++ setup.py
|
||||||
|
@@ -50,6 +50,6 @@ setup(name = 'nagstamon',
|
||||||
|
packages = ['Nagstamon', 'Nagstamon.Server'],
|
||||||
|
package_dir = {'Nagstamon':'Nagstamon'},
|
||||||
|
package_data = {'Nagstamon':['resources/*']},
|
||||||
|
- data_files = [('%s/share/man/man1' % sys.prefix, ['Nagstamon/resources/nagstamon.1'])]
|
||||||
|
+ data_files = [('%s/@PKGMANDIR@/man1' % sys.prefix, ['Nagstamon/resources/nagstamon.1'])]
|
||||||
|
)
|
||||||
|
|
Loading…
Reference in a new issue