Remove the netqmail package in favor of the newly bsd.options.mk'ified
qmail package. Building qmail with PKG_OPTIONS.qmail set to "netqmail bigdns" will apply the same patches that were applied by this package.
This commit is contained in:
parent
63bf0e3cd6
commit
bc45235635
4 changed files with 0 additions and 112 deletions
|
@ -1,12 +0,0 @@
|
|||
Charles Cazabon, Dave Sill, Henning Brauer, Peter Samuel, and
|
||||
Russell Nelson have put together a netqmail-1.05 distribution of
|
||||
qmail. It is comprised of qmail-1.03 plus a patch file, some
|
||||
documentation, and a shell script which prepares the files for
|
||||
compilation.
|
||||
|
||||
We have done this because in our opinion, too many new users are
|
||||
confused by the out-of-date INSTALL file, and too much time is
|
||||
spent arguing on the mailing list over bugs. We have tried to stick
|
||||
to the barest minimum number of changes. We have fixed only those
|
||||
things which are out-and-out wrong, or which have been approved by
|
||||
djb (specifically QMAILQUEUE).
|
|
@ -1,28 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.2 2004/08/02 03:57:17 schmonz Exp $
|
||||
#
|
||||
|
||||
PKGNAME= ${DISTNAME}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= mail
|
||||
|
||||
MAINTAINER= schmonz@NetBSD.org
|
||||
HOMEPAGE= http://qmail.org/netqmail/
|
||||
COMMENT= Unofficial distribution of qmail that includes basic patches
|
||||
|
||||
CONFLICTS+= qmail-[0-9]*
|
||||
|
||||
USE_BUILDLINK3= yes
|
||||
|
||||
# netqmail is a modification of the qmail source.
|
||||
RESTRICTED= "modified source and binaries may not be distributed"
|
||||
NO_BIN_ON_CDROM=${RESTRICTED}
|
||||
NO_BIN_ON_FTP= ${RESTRICTED}
|
||||
NO_PACKAGE= "needs work to function properly as a binary package"
|
||||
|
||||
APPLY_NETQMAIL= \
|
||||
${PATCH} ${PATCH_DIST_ARGS} < ../${DISTNAME}.patch; \
|
||||
cd ..; ${MV} ${QMAIL_VERS} ${DISTNAME}
|
||||
|
||||
.include "../../mail/qmail/Makefile.common"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,7 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.2 2004/08/02 03:57:17 schmonz Exp $
|
||||
|
||||
SHA1 (netqmail-1.05.tar.gz) = fe4cbe97bd2f18a5ca1b36e4fbbd6c524256a829
|
||||
Size (netqmail-1.05.tar.gz) = 252264 bytes
|
||||
SHA1 (panther.patch) = 952b919786d808a605343d078696e1af7cbd2577
|
||||
Size (panther.patch) = 2392 bytes
|
||||
SHA1 (patch-aa) = c9928d0879dee77010bb469d4afa8c4ca35668f8
|
|
@ -1,65 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/07/21 22:42:04 schmonz Exp $
|
||||
|
||||
--- dns.c.orig 2004-07-20 20:02:28.000000000 -0400
|
||||
+++ dns.c
|
||||
@@ -19,10 +19,12 @@ extern int res_search();
|
||||
static unsigned short getshort(c) unsigned char *c;
|
||||
{ unsigned short u; u = c[0]; return (u << 8) + c[1]; }
|
||||
|
||||
-static union { HEADER hdr; unsigned char buf[PACKETSZ]; } response;
|
||||
+static struct { unsigned char *buf; } response;
|
||||
+static int responsebuflen = 0;
|
||||
static int responselen;
|
||||
static unsigned char *responseend;
|
||||
static unsigned char *responsepos;
|
||||
+static u_long saveresoptions;
|
||||
|
||||
static int numanswers;
|
||||
static char name[MAXDNAME];
|
||||
@@ -43,18 +45,33 @@ int type;
|
||||
errno = 0;
|
||||
if (!stralloc_copy(&glue,domain)) return DNS_MEM;
|
||||
if (!stralloc_0(&glue)) return DNS_MEM;
|
||||
- responselen = lookup(glue.s,C_IN,type,response.buf,sizeof(response));
|
||||
+ if (!responsebuflen)
|
||||
+ if (response.buf = (unsigned char *)alloc(PACKETSZ+1))
|
||||
+ responsebuflen = PACKETSZ+1;
|
||||
+ else return DNS_MEM;
|
||||
+
|
||||
+ responselen = lookup(glue.s,C_IN,type,response.buf,responsebuflen);
|
||||
+ if ((responselen >= responsebuflen) ||
|
||||
+ (responselen > 0 && (((HEADER *)response.buf)->tc)))
|
||||
+ {
|
||||
+ if (responsebuflen < 65536)
|
||||
+ if (alloc_re(&response.buf, responsebuflen, 65536))
|
||||
+ responsebuflen = 65536;
|
||||
+ else return DNS_MEM;
|
||||
+ saveresoptions = _res.options;
|
||||
+ _res.options |= RES_USEVC;
|
||||
+ responselen = lookup(glue.s,C_IN,type,response.buf,responsebuflen);
|
||||
+ _res.options = saveresoptions;
|
||||
+ }
|
||||
if (responselen <= 0)
|
||||
{
|
||||
if (errno == ECONNREFUSED) return DNS_SOFT;
|
||||
if (h_errno == TRY_AGAIN) return DNS_SOFT;
|
||||
return DNS_HARD;
|
||||
}
|
||||
- if (responselen >= sizeof(response))
|
||||
- responselen = sizeof(response);
|
||||
responseend = response.buf + responselen;
|
||||
responsepos = response.buf + sizeof(HEADER);
|
||||
- n = ntohs(response.hdr.qdcount);
|
||||
+ n = ntohs(((HEADER *)response.buf)->qdcount);
|
||||
while (n-- > 0)
|
||||
{
|
||||
i = dn_expand(response.buf,responseend,responsepos,name,MAXDNAME);
|
||||
@@ -64,7 +81,7 @@ int type;
|
||||
if (i < QFIXEDSZ) return DNS_SOFT;
|
||||
responsepos += QFIXEDSZ;
|
||||
}
|
||||
- numanswers = ntohs(response.hdr.ancount);
|
||||
+ numanswers = ntohs(((HEADER *)response.buf)->ancount);
|
||||
return 0;
|
||||
}
|
||||
|
Loading…
Reference in a new issue