Update to version 9.2.

This  version  is  focused  on  improved performance and stability,
  rather  than introducing new functionality, hence it is called R9C.

Build Process NEW

   The  build  process  has been improved so that it is possible to build
   Erlang/OTP  from  source  even  on  Windows platforms. There is also a
   completely new installation program for Windows.

Observer

  crashdump_viewer NEW

   A  HTML based tool for browsing Erlang crashdumps. The tool can handle
   crashdumps  from  OTP R7B, R8B and R9B as well but there is additional
   information in the crashdumps for R9C.

OTP_MIBs NEW

   The  OTP  mibs  that  where included in the SASL application have been
   moved  to  this  new application otp_mibs. This is a step too create a
   pure   core   for   Erlang/OTP  that  does  not  depend  on  specific,
   non-mainstream applications such as SNMP.
This commit is contained in:
jtb 2003-08-31 01:01:55 +00:00
parent e14180496b
commit bc49b5d314
5 changed files with 2500 additions and 2391 deletions

View file

@ -1,13 +1,12 @@
# $NetBSD: Makefile,v 1.5 2003/07/21 16:54:01 martti Exp $
# $NetBSD: Makefile,v 1.6 2003/08/31 01:01:55 jtb Exp $
DISTNAME= otp_src_R9B-1
PKGNAME= erlang-9.1
PKGREVISION= 1
DISTNAME= otp_src_R9C-0
PKGNAME= erlang-9.2
CATEGORIES= lang
MASTER_SITES= http://www.erlang.org/download/
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://www.erlang.org
HOMEPAGE= http://www.erlang.org/
COMMENT= Concurrent functional programming language
DIST_SUBDIR= erlang
@ -18,6 +17,8 @@ USE_PERL5= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
.include "../../mk/pthread.buildlink2.mk"
.include "../../security/openssl/buildlink2.mk"
.include "../../devel/ncurses/buildlink2.mk"
.include "../../mk/java-vm.mk"
.include "../../mk/pthread.buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

File diff suppressed because it is too large Load diff

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2003/04/29 23:47:45 jtb Exp $
$NetBSD: distinfo,v 1.2 2003/08/31 01:01:56 jtb Exp $
SHA1 (erlang/otp_src_R9B-1.tar.gz) = 6e3f1de911e44b177453b5a2d5c4142f42ef7f54
Size (erlang/otp_src_R9B-1.tar.gz) = 8455643 bytes
SHA1 (patch-aa) = 4b1973638e590866e5f44f5ba9cef3b584638b8b
SHA1 (erlang/otp_src_R9C-0.tar.gz) = 5fb3a143863307b2df73691814340a2d004ce043
Size (erlang/otp_src_R9C-0.tar.gz) = 8229056 bytes
SHA1 (patch-aa) = 43eb492a22462442e3f717ee32056df11d1a0e43
SHA1 (patch-ab) = ced331e223b3b1de88426de5f18fe066ca8be028

View file

@ -1,38 +1,30 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/04/29 23:47:45 jtb Exp $
$NetBSD: patch-aa,v 1.2 2003/08/31 01:01:56 jtb Exp $
--- erts/autoconf/config.guess.orig
+++ erts/autoconf/config.guess
@@ -136,15 +136,15 @@
# object file format.
# Determine the machine/vendor (is the vendor relevant).
case "${UNAME_MACHINE}" in
- amiga) machine=m68k-unknown ;;
- arm32) machine=arm-unknown ;;
- atari*) machine=m68k-atari ;;
- sun3*) machine=m68k-sun ;;
- mac68k) machine=m68k-apple ;;
- macppc) machine=powerpc-apple ;;
- hp3[0-9][05]) machine=m68k-hp ;;
- ibmrt|romp-ibm) machine=romp-ibm ;;
- *) machine=${UNAME_MACHINE}-unknown ;;
+ amiga) machine=m68k- ;;
+ arm32) machine=arm- ;;
+ atari*) machine=m68k- ;;
+ sun3*) machine=m68k- ;;
+ mac68k) machine=m68k- ;;
+ macppc) machine=powerpc- ;;
+ hp3[0-9][05]) machine=m68k- ;;
+ ibmrt|romp-ibm) machine=romp- ;;
+ *) machine=${UNAME_MACHINE}- ;;
--- erts/autoconf/config.guess.orig 2003-08-29 08:35:08.000000000 +0100
+++ erts/autoconf/config.guess 2003-08-29 08:37:07.000000000 +0100
@@ -153,11 +153,11 @@
UNAME_MACHINE_ARCH=`(/sbin/$sysctl 2>/dev/null || \
/usr/sbin/$sysctl 2>/dev/null || echo unknown)`
case "${UNAME_MACHINE_ARCH}" in
- armeb) machine=armeb-unknown ;;
- arm*) machine=arm-unknown ;;
- sh3el) machine=shl-unknown ;;
- sh3eb) machine=sh-unknown ;;
- *) machine=${UNAME_MACHINE_ARCH}-unknown ;;
+ armeb) machine=armeb- ;;
+ arm*) machine=arm- ;;
+ sh3el) machine=shl- ;;
+ sh3eb) machine=sh- ;;
+ *) machine=${UNAME_MACHINE_ARCH}- ;;
esac
# The Operating System including object format, if it has switched
# to ELF recently, or will in the future.
@@ -165,7 +165,7 @@
@@ -188,7 +188,7 @@
release='-gnu'
;;
*)
- release=`echo ${UNAME_RELEASE}|sed -e 's/[-_].*/\./'`
+ release=
;;
esac
# The OS release
- release=`echo ${UNAME_RELEASE}|sed -e 's/[-_].*/\./'`
+ release=
# Since CPU_TYPE-MANUFACTURER-KERNEL-OPERATING_SYSTEM:
# contains redundant information, the shorter form:
# CPU_TYPE-MANUFACTURER-OPERATING_SYSTEM is used.

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2003/08/31 01:01:56 jtb Exp $
--- make/otp.mk.in.orig 2003-08-29 11:34:39.000000000 +0100
+++ make/otp.mk.in 2003-08-29 11:34:56.000000000 +0100
@@ -155,7 +155,7 @@
$(JAVA_DEST_ROOT)$(JAVA_CLASS_SUBDIR)%.class: %.java
- CLASSPATH=$(CLASSPATH) $(JAVA) $(JAVA_OPTIONS) -d $(JAVA_DEST_ROOT) $<
+ CLASSPATH=$(CLASSPATH) $(JAVA) $(JAVA_OPTIONS) -d $(JAVA_DEST_ROOT) *.java
# ----------------------------------------------------
# Emacs byte code compiling