Fix inline usage.
This commit is contained in:
parent
85a4d9bfe4
commit
bc61b56c59
2 changed files with 60 additions and 1 deletions
|
@ -1,8 +1,9 @@
|
||||||
$NetBSD: distinfo,v 1.4 2007/08/08 17:55:59 joerg Exp $
|
$NetBSD: distinfo,v 1.5 2012/11/23 12:33:44 joerg Exp $
|
||||||
|
|
||||||
SHA1 (d2x-0.2.5.tar.gz) = b68c74fdc1f31a5ae32f6b27d7d3658e7e0dbdca
|
SHA1 (d2x-0.2.5.tar.gz) = b68c74fdc1f31a5ae32f6b27d7d3658e7e0dbdca
|
||||||
RMD160 (d2x-0.2.5.tar.gz) = c27f16f52eaa7a3742cd7b50307bd747ab79c96f
|
RMD160 (d2x-0.2.5.tar.gz) = c27f16f52eaa7a3742cd7b50307bd747ab79c96f
|
||||||
Size (d2x-0.2.5.tar.gz) = 2015249 bytes
|
Size (d2x-0.2.5.tar.gz) = 2015249 bytes
|
||||||
|
SHA1 (patch-2d_bitblt.c) = bac6c0a818517ad7a838f8775da15ae1048bf712
|
||||||
SHA1 (patch-aa) = c7b5790409851bea1637d0f2fc1a8d86924c4528
|
SHA1 (patch-aa) = c7b5790409851bea1637d0f2fc1a8d86924c4528
|
||||||
SHA1 (patch-ab) = b59b2de4d60d98bec20117f085be06016ee03047
|
SHA1 (patch-ab) = b59b2de4d60d98bec20117f085be06016ee03047
|
||||||
SHA1 (patch-ac) = 93d3f8afb1d865c5c4ba4218f19d5e5b67df3eed
|
SHA1 (patch-ac) = 93d3f8afb1d865c5c4ba4218f19d5e5b67df3eed
|
||||||
|
|
58
games/d2x/patches/patch-2d_bitblt.c
Normal file
58
games/d2x/patches/patch-2d_bitblt.c
Normal file
|
@ -0,0 +1,58 @@
|
||||||
|
$NetBSD: patch-2d_bitblt.c,v 1.1 2012/11/23 12:33:45 joerg Exp $
|
||||||
|
|
||||||
|
--- 2d/bitblt.c.orig 2012-11-21 16:32:42.000000000 +0000
|
||||||
|
+++ 2d/bitblt.c
|
||||||
|
@@ -159,7 +159,7 @@ void gr_linear_movsd( ubyte * source, ub
|
||||||
|
|
||||||
|
#elif !defined(NO_ASM) && defined(__GNUC__)
|
||||||
|
|
||||||
|
-inline void gr_linear_movsd(ubyte *src, ubyte *dest, unsigned int num_pixels) {
|
||||||
|
+static inline void gr_linear_movsd(ubyte *src, ubyte *dest, unsigned int num_pixels) {
|
||||||
|
int dummy[3];
|
||||||
|
__asm__ __volatile__ (
|
||||||
|
" cld;"
|
||||||
|
@@ -185,7 +185,7 @@ inline void gr_linear_movsd(ubyte *src,
|
||||||
|
|
||||||
|
#elif !defined(NO_ASM) && defined(_MSC_VER)
|
||||||
|
|
||||||
|
-__inline void gr_linear_movsd(ubyte *src, ubyte *dest, unsigned int num_pixels)
|
||||||
|
+static __inline void gr_linear_movsd(ubyte *src, ubyte *dest, unsigned int num_pixels)
|
||||||
|
{
|
||||||
|
__asm {
|
||||||
|
mov esi, [src]
|
||||||
|
@@ -297,7 +297,7 @@ static inline void gr_linear_rep_movsdm(
|
||||||
|
|
||||||
|
#elif !defined(NO_ASM) && defined(_MSC_VER)
|
||||||
|
|
||||||
|
-__inline void gr_linear_rep_movsdm(ubyte * src, ubyte * dest, unsigned int num_pixels )
|
||||||
|
+static __inline void gr_linear_rep_movsdm(ubyte * src, ubyte * dest, unsigned int num_pixels )
|
||||||
|
{
|
||||||
|
__asm {
|
||||||
|
nextpixel:
|
||||||
|
@@ -380,7 +380,7 @@ static inline void gr_linear_rep_movsdm_
|
||||||
|
|
||||||
|
#elif !defined(NO_ASM) && defined(_MSC_VER)
|
||||||
|
|
||||||
|
-__inline void gr_linear_rep_movsdm_faded(void * src, void * dest, unsigned int num_pixels, ubyte fade_value )
|
||||||
|
+static __inline void gr_linear_rep_movsdm_faded(void * src, void * dest, unsigned int num_pixels, ubyte fade_value )
|
||||||
|
{
|
||||||
|
__asm {
|
||||||
|
mov esi, [src]
|
||||||
|
@@ -481,7 +481,7 @@ static inline void gr_linear_rep_movsd_2
|
||||||
|
|
||||||
|
#elif !defined(NO_ASM) && defined(_MSC_VER)
|
||||||
|
|
||||||
|
-__inline void gr_linear_rep_movsd_2x(ubyte * src, ubyte * dest, unsigned int num_dest_pixels )
|
||||||
|
+static __inline void gr_linear_rep_movsd_2x(ubyte * src, ubyte * dest, unsigned int num_dest_pixels )
|
||||||
|
{
|
||||||
|
__asm {
|
||||||
|
mov esi, [src]
|
||||||
|
@@ -2113,7 +2113,7 @@ void gr_bm_ubitbltm(int w, int h, int dx
|
||||||
|
|
||||||
|
// rescalling bitmaps, 10/14/99 Jan Bobrowski jb@wizard.ae.krakow.pl
|
||||||
|
|
||||||
|
-inline void scale_line(byte *in, byte *out, int ilen, int olen)
|
||||||
|
+static inline void scale_line(byte *in, byte *out, int ilen, int olen)
|
||||||
|
{
|
||||||
|
int a = olen/ilen, b = olen%ilen;
|
||||||
|
int c = 0, i;
|
Loading…
Reference in a new issue