* Avoid to use "ftools" which has deprecated in ruby19.
This commit is contained in:
parent
908b815e8f
commit
bc71b80623
2 changed files with 29 additions and 1 deletions
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.3 2006/01/03 14:25:51 taca Exp $
|
||||
$NetBSD: distinfo,v 1.4 2010/09/10 08:49:55 taca Exp $
|
||||
|
||||
SHA1 (xmlscan-0.2.3.tar.gz) = 70c989d3782c916179170238a40b1d7defa9dc47
|
||||
RMD160 (xmlscan-0.2.3.tar.gz) = d83fb70ed24764e1a036f7af79c2b1f3f4e4fa18
|
||||
Size (xmlscan-0.2.3.tar.gz) = 88414 bytes
|
||||
SHA1 (patch-aa) = 664fe81b0bef9f8f06e360f55e69b1b1e31cce57
|
||||
|
|
27
textproc/ruby-xmlscan/patches/patch-aa
Normal file
27
textproc/ruby-xmlscan/patches/patch-aa
Normal file
|
@ -0,0 +1,27 @@
|
|||
$NetBSD: patch-aa,v 1.1 2010/09/10 08:49:55 taca Exp $
|
||||
|
||||
Avoid to use "ftools" which has deprecated in ruby19.
|
||||
|
||||
--- install.rb.orig 2002-12-26 21:09:38.000000000 +0000
|
||||
+++ install.rb
|
||||
@@ -6,9 +6,9 @@
|
||||
|
||||
require 'rbconfig'
|
||||
-require 'ftools'
|
||||
+require 'fileutils'
|
||||
require 'find'
|
||||
require 'getoptlong'
|
||||
|
||||
-DEFAULT_DESTDIR = Config::CONFIG['sitelibdir'] || Config::CONFIG['sitedir']
|
||||
+DEFAULT_DESTDIR = Config::CONFIG['vendorlibdir'] || Config::CONFIG['vendordir']
|
||||
SRCDIR = File.dirname(__FILE__)
|
||||
|
||||
@@ -20,6 +20,6 @@ def install_rb(from, to)
|
||||
next unless /\.rb\z/ =~ src
|
||||
dst = src.sub(/\A#{Regexp.escape(from)}/, to)
|
||||
- File.makedirs File.dirname(dst), true
|
||||
- File.install src, dst, 0644, true
|
||||
+ FileUtils.mkdir_p File.dirname(dst)
|
||||
+ FileUtils.install src, dst, :mode => 0644
|
||||
}
|
||||
end
|
Loading…
Reference in a new issue