Add patch to conditionally include <stdint.h> based on the symbol

HAVE_STDINT_H generated by configure. This is required for
compilation on Solaris 9.
This commit is contained in:
shannonjr 2008-04-30 11:39:24 +00:00
parent 29b9319b25
commit bc762658a7
2 changed files with 17 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.19 2008/04/29 11:45:55 wiz Exp $
$NetBSD: distinfo,v 1.20 2008/04/30 11:39:24 shannonjr Exp $
SHA1 (libtasn1-1.4.tar.gz) = 684c9dc343b0155a074c2127ac8050f983528bc8
RMD160 (libtasn1-1.4.tar.gz) = 8553984f8992151b1086f6b3d7196a3916e61edd
Size (libtasn1-1.4.tar.gz) = 1552101 bytes
SHA1 (patch-aa) = 64d8599d79c4f9975b0a1ccae79d91865c9afa33

View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.1 2008/04/30 11:39:24 shannonjr Exp $
--- ./lib/int.h.orig 2008-04-30 05:06:07.085583902 -0600
+++ ./lib/int.h
@@ -31,7 +31,10 @@
#include <stdlib.h>
#include <stdio.h>
#include <ctype.h>
+
+#ifdef HAVE_STDINT_H
#include <stdint.h>
+#endif
#ifdef HAVE_SYS_TYPES_H
# include <sys/types.h>