Use stdlib.h instead of private decls of malloc; remove union wait. Should

fix build with newer gcc and maybe also clang.
This commit is contained in:
dholland 2011-11-15 00:11:06 +00:00
parent e928fd705a
commit bcadc84a74
4 changed files with 72 additions and 8 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.10 2011/11/10 09:42:22 is Exp $
$NetBSD: distinfo,v 1.11 2011/11/15 00:11:06 dholland Exp $
SHA1 (icsi-finger-1.0.27.tar.Z) = 41f03c42269a402169000a6b08ba8c6330256861
RMD160 (icsi-finger-1.0.27.tar.Z) = 92839362b6d4b1893958ca0909654f070e734aa4
@ -12,7 +12,8 @@ SHA1 (patch-af) = 96d691992eecbf08118a924218570325a52603b1
SHA1 (patch-ah) = d61e893ce11a3957bbe138abc9a247b0d4b51a0e
SHA1 (patch-ai) = 01b48ecef2c1fe191780c9a8dee61f2951ee9c10
SHA1 (patch-aj) = 53adee387e703fcff2b8f5dba4ae593712acb2ad
SHA1 (patch-ak) = 8e9bd7da344e082deb0e51301e124a2b7f8025fe
SHA1 (patch-al) = 28e8762269e94dec2e1b306527c2613b8a86d76d
SHA1 (patch-ak) = e34c9b4e4e24295c4d60e7628ef90d2be7fa4c13
SHA1 (patch-al) = 1abcd4a364d66b19e30e38422f3fda5a9cc233b3
SHA1 (patch-am) = 50b7cc7eaa30eaab2a26a849a875322c5344a74a
SHA1 (patch-an) = c5e4a49e7abd2b14513be38d3d06280117730e09
SHA1 (patch-lib_util_c) = 160eb90114aaa9dce5d66de1392673f15aed9cd9

View file

@ -1,8 +1,22 @@
$NetBSD: patch-ak,v 1.1 2011/01/18 12:28:25 is Exp $
$NetBSD: patch-ak,v 1.2 2011/11/15 00:11:07 dholland Exp $
- use standard includes
- 64-bit time_t fixes
- remove union wait
--- src/in.fingerd.c.orig 1996-01-10 19:26:24.000000000 +0000
+++ src/in.fingerd.c
@@ -805,12 +805,12 @@ finger_users (user, options, stream)
@@ -33,9 +33,7 @@ static char *rcsid = "$Id: in.fingerd.c,
#include <sys/types.h>
#include <fcntl.h>
#include <sys/file.h>
-#ifndef X_OK
#include <unistd.h>
-#endif
#include <sys/stat.h>
#include <netinet/in.h>
#include <arpa/inet.h>
@@ -805,12 +803,12 @@ finger_users (user, options, stream)
fprintf (stream, "%s (%s) seen at %s on %s",
upackets[i]->real_name, upackets[i]->name,
strip_hostname (upackets[i]->host),
@ -17,7 +31,7 @@ $NetBSD: patch-ak,v 1.1 2011/01/18 12:28:25 is Exp $
}
else
{
@@ -1262,7 +1262,7 @@ show_unlogged_packet (packet, stream)
@@ -1262,7 +1260,7 @@ show_unlogged_packet (packet, stream)
/* In SunOS4 getpwnam() seems to call ctime(), so we move this call down
* here to be sure the intended result doesn't get overwritten. */
@ -26,3 +40,18 @@ $NetBSD: patch-ak,v 1.1 2011/01/18 12:28:25 is Exp $
the_time[strlen(the_time) - 1] = '\0'; /* delete newline */
if (*(packet->real_name))
@@ -1406,14 +1404,7 @@ run_target_script(script, target, cd, in
char *arg;
{
int pid;
-#ifdef SYSV
int status;
-#else
-#ifndef WEXITSTATUS
-# define WEXITSTATUS(w) ((w).w_retcode)
-#endif
- union wait status;
-#endif
if (access (script, X_OK) >= 0)
{

View file

@ -1,8 +1,19 @@
$NetBSD: patch-al,v 1.1 2011/01/18 12:28:25 is Exp $
$NetBSD: patch-al,v 1.2 2011/11/15 00:11:07 dholland Exp $
- 64-bit time_t fixes
- use standard includes
--- lib/os.c.orig 1996-07-18 23:31:32.000000000 +0000
+++ lib/os.c
@@ -1137,3 +1137,15 @@ same_hostip (host1, host2)
@@ -28,6 +28,7 @@ static char *rcsid = "$Id: os.c,v 1.63 1
#include "../config.h"
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include <sys/types.h>
#include <sys/param.h>
@@ -1137,3 +1138,15 @@ same_hostip (host1, host2)
return (addr1 == addr2);
}

View file

@ -0,0 +1,23 @@
$NetBSD: patch-lib_util_c,v 1.1 2011/11/15 00:11:07 dholland Exp $
- use standard headers
--- lib/util.c~ 1997-10-19 00:06:56.000000000 +0000
+++ lib/util.c
@@ -26,6 +26,7 @@ static char *rcsid = "$Id: util.c,v 1.27
#endif
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include <ctype.h>
#include <sys/types.h>
@@ -239,8 +240,6 @@ memory_error_and_abort (nbytes)
handle_error(FATAL, "(re)alloc error. Cannot allocate %d bytes.", nbytes);
}
-extern char *malloc(), *realloc();
-
void *
xmalloc (nbytes)
int nbytes;