Changes 2.82:

==== All Platforms ====
* Fix webseed crash
* Fix crash when adding UDP trackers whose host's canonical name couldn't be found
* Fix crash when sending handshakes to some peers immediately after adding a magnet link
* Fix crash when parsing incoming encrypted handshakes when the user is removing the related torrent
* Add safeguard to prevent zombie processes after running a script when a torrent finishes downloading
* Fix "bad file descriptor" error
* Queued torrents no longer show up as paused after exiting & restarting
* Fix 2.81 compilation error on OpenBSD
* Don't misidentify Tixati as BitTornado
==== Mac Client ====
* Fix bug that had slow download speeds until editing preferences
==== GTK+ Client ====
* Fix crash that occurred in some cases after using Torrent > Set Location
* Fix crash where on_app_exit() got called twice in a row
* Fix 2.81 compilation error on older versions of glib
* Can now open folders that have a '#' in their names
* Silence gobject warning when updating a blocklist from URL
==== Qt Client ====
* Qt 5 support
==== Web Client ====
* Fix syntax error in index.html's meta name="viewport"
* Fix file uploading issue in Internet Explorer 11
This commit is contained in:
adam 2014-04-01 09:48:04 +00:00
parent bf4ed23bd4
commit bcaeb93ef9
10 changed files with 120 additions and 50 deletions

View file

@ -1,12 +1,14 @@
# $NetBSD: Makefile,v 1.9 2014/02/12 23:18:26 tron Exp $
# $NetBSD: Makefile,v 1.10 2014/04/01 09:48:04 adam Exp $
PKGNAME= ${DISTNAME:C:-:-gtk-:}
PKGREVISION= 8
USE_LANGUAGES+= c c++
USE_LANGUAGES= c c++
INSTALL_ENV+= INSTALL_ROOT=${DESTDIR}${PREFIX}
CONFIGURE_ARGS+= --disable-cli --disable-daemon --with-gtk
CONFIGURE_ARGS+= --disable-cli
CONFIGURE_ARGS+= --disable-daemon
CONFIGURE_ARGS+= --disable-mac
CONFIGURE_ARGS+= --with-gtk
CONFLICTS+= Transmission-gui-[0-9]*

View file

@ -1,13 +1,15 @@
# $NetBSD: Makefile,v 1.5 2014/02/12 23:18:26 tron Exp $
# $NetBSD: Makefile,v 1.6 2014/04/01 09:48:05 adam Exp $
PKGNAME= ${DISTNAME:C:-:-qt-:}
PKGREVISION= 4
USE_LANGUAGES+= c c++
USE_LANGUAGES= c c++
MAKE_ENV+= QTDIR=${QTDIR}
INSTALL_ENV+= INSTALL_ROOT=${DESTDIR}${PREFIX}
CONFIGURE_ARGS+= --disable-cli --disable-daemon --without-gtk
CONFIGURE_ARGS+= --disable-cli
CONFIGURE_ARGS+= --disable-daemon
CONFIGURE_ARGS+= --disable-mac
CONFIGURE_ARGS+= --without-gtk
CONFLICTS+= Transmission-gui-[0-9]*
@ -20,6 +22,6 @@ post-build:
do-install:
cd ${WRKSRC}/qt && ${SETENV} ${INSTALL_ENV} make install
.include "../../x11/qt4-qdbus/buildlink3.mk"
.include "../../x11/qt4-tools/buildlink3.mk"
.include "../../x11/qt5-dbus/buildlink3.mk"
.include "../../x11/qt5-qtbase/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,11 +1,11 @@
# $NetBSD: Makefile,v 1.4 2014/02/12 23:18:26 tron Exp $
# $NetBSD: Makefile,v 1.5 2014/04/01 09:48:04 adam Exp $
PKGREVISION= 1
CONFLICTS+= Transmission-[0-9]*
pre-configure:
touch ${WRKSRC}/po/Makefile
CONFIGURE_ARGS+= --disable-mac
CONFIGURE_ARGS+= --without-gtk
.include "../../net/transmission/Makefile.common"

View file

@ -1,16 +1,16 @@
# $NetBSD: Makefile.common,v 1.2 2013/03/17 15:29:24 wiz Exp $
# $NetBSD: Makefile.common,v 1.3 2014/04/01 09:48:04 adam Exp $
# used by net/transmission/Makefile
# used by net/transmission-gtk/Makefile
# used by net/transmission-qt/Makefile
DISTNAME= transmission-2.77
CATEGORIES= net
MASTER_SITES= http://download.m0k.org/transmission/files/
EXTRACT_SUFX= .tar.bz2
DISTNAME= transmission-2.82
CATEGORIES= net
MASTER_SITES= http://download.m0k.org/transmission/files/
EXTRACT_SUFX= .tar.xz
MAINTAINER= wiz@NetBSD.org
HOMEPAGE= http://www.transmissionbt.com/
COMMENT= Free, lightweight BitTorrent client
MAINTAINER= wiz@NetBSD.org
HOMEPAGE= http://www.transmissionbt.com/
COMMENT= Free, lightweight BitTorrent client
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
@ -29,11 +29,14 @@ LDFLAGS+= ${BUILDLINK_LDADD.getopt} ${BUILDLINK_LDADD.gettext}
.if !empty(OPSYS:M*BSD) || !empty(OPSYS:MDragonFly)
CPPFLAGS+= -DBSD
.endif
.if !empty(OPSYS:MDarwin)
LDFLAGS+= -framework CoreFoundation
.endif
BUILDLINK_API_DEPENDS.libevent+= libevent>=2.0.10
.include "../../devel/libevent/buildlink3.mk"
ALL_ENV+= "OPENSSL_CFLAGS=-I${SSLBASE}/include"
ALL_ENV+= "OPENSSL_LIBS=-L${SSLBASE}/lib -lcrypto -lssl"
ALL_ENV+= "OPENSSL_CFLAGS=-I${SSLBASE}/include"
ALL_ENV+= "OPENSSL_LIBS=-L${SSLBASE}/lib -lcrypto -lssl"
.include "../../devel/libgetopt/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2013/03/02 19:33:29 wiz Exp $
@comment $NetBSD: PLIST,v 1.2 2014/04/01 09:48:04 adam Exp $
bin/transmission-cli
bin/transmission-create
bin/transmission-daemon
@ -22,8 +22,6 @@ share/transmission/web/javascript/file-row.js
share/transmission/web/javascript/formatter.js
share/transmission/web/javascript/inspector.js
share/transmission/web/javascript/jquery/jquery.contextmenu.min.js
share/transmission/web/javascript/jquery/jquery.form.js
share/transmission/web/javascript/jquery/jquery.form.min.js
share/transmission/web/javascript/jquery/jquery.min.js
share/transmission/web/javascript/jquery/jquery.transmenu.min.js
share/transmission/web/javascript/jquery/jqueryui-1.8.16.min.js

View file

@ -1,11 +1,12 @@
$NetBSD: distinfo,v 1.2 2013/03/17 15:29:24 wiz Exp $
$NetBSD: distinfo,v 1.3 2014/04/01 09:48:04 adam Exp $
SHA1 (transmission-2.77.tar.bz2) = a26298dc814b3995a7e4a7f6566fc16b1463bbbb
RMD160 (transmission-2.77.tar.bz2) = 742b4cc296a11972899e88bb7d173c544917792d
Size (transmission-2.77.tar.bz2) = 4305751 bytes
SHA1 (transmission-2.82.tar.xz) = 1081542e2692147e45dde7c310b793abc4f33f2d
RMD160 (transmission-2.82.tar.xz) = 468ac753cd7143f2789a4b2515b9b6eb1745717f
Size (transmission-2.82.tar.xz) = 3172024 bytes
SHA1 (patch-aa) = 75d6df8cf8105dbb55ec3a4ed967036c28cfae3c
SHA1 (patch-ab) = 96174f474e3301f9062eaa17fafe3cd5c26a5243
SHA1 (patch-ac) = 75e0d1fbfc5bb895b17fa22d8d09d6257e798847
SHA1 (patch-ae) = e4a5cc16b9fc211fcd12bc38251e1d7df5b7f846
SHA1 (patch-qt_qtr.pro) = 9dcf0a36110357d71138fc1325484e2b5ea7c8d4
SHA1 (patch-libtransmission_platform-quota.c) = d87c6cfba6ef91585afac1063a8f47e39777a9a8
SHA1 (patch-qt_qtr.pro) = 9a272f1e60f1b59d513b62451b4e0fc085dbae18
SHA1 (patch-qt_torrent-filter.cc) = 490babef551fd43cfed18c0efdfd9624c8c3527e
SHA1 (patch-third-party_miniupnp_miniupnp.c) = df4957ccf5b08af14d2df98e953dd2d1b584c294

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ae,v 1.1 2013/03/02 19:33:29 wiz Exp $
--- qt/qtr.pro.orig 2012-07-06 01:24:43.000000000 +0000
+++ qt/qtr.pro
@@ -13,7 +13,9 @@ man.files = transmission-qt.1
CONFIG += qt qdbus thread debug link_pkgconfig
QT += network
-PKGCONFIG = fontconfig libcurl openssl libevent
+PKGCONFIG = fontconfig libcurl libevent
+INCLUDEPATH += $${OPENSSL_CFLAGS}
+LIBS += $${OPENSSL_LIBS}
TRANSMISSION_TOP = ..

View file

@ -0,0 +1,57 @@
$NetBSD$
Add NetBSD support.
--- libtransmission/platform-quota.c.orig 2014-03-31 18:47:50.000000000 +0000
+++ libtransmission/platform-quota.c
@@ -20,6 +20,8 @@
#include <sys/types.h> /* types needed by quota.h */
#if defined(__FreeBSD__) || defined(__OpenBSD__)
#include <ufs/ufs/quota.h> /* quotactl() */
+ #elif defined(__NetBSD__)
+ #include <ufs/ufs/quota1.h>
#elif defined (__sun)
#include <sys/fs/ufs_quota.h> /* quotactl */
#else
@@ -104,7 +106,11 @@ getdev (const char * path)
int i;
int n;
+#if defined(__NetBSD__)
+ struct statvfs * mnt;
+#else
struct statfs * mnt;
+#endif
n = getmntinfo(&mnt, MNT_WAIT);
if (!n)
@@ -154,7 +160,11 @@ getfstype (const char * device)
int i;
int n;
+#if defined(__NetBSD__)
+ struct statvfs *mnt;
+#else
struct statfs *mnt;
+#endif
n = getmntinfo(&mnt, MNT_WAIT);
if (!n)
@@ -203,7 +213,7 @@ getquota (const char * device)
int64_t freespace;
int64_t spaceused;
-#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(SYS_DARWIN)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(SYS_DARWIN)
if (quotactl(device, QCMD(Q_GETQUOTA, USRQUOTA), getuid(), (caddr_t) &dq) == 0)
{
#elif defined(__sun)
@@ -235,7 +245,7 @@ getquota (const char * device)
/* No quota enabled for this user */
return -1;
}
-#if defined(__FreeBSD__) || defined(__OpenBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
spaceused = (int64_t) dq.dqb_curblocks >> 1;
#elif defined(SYS_DARWIN)
spaceused = (int64_t) dq.dqb_curbytes;

View file

@ -1,8 +1,8 @@
$NetBSD: patch-qt_qtr.pro,v 1.1 2013/03/02 19:33:29 wiz Exp $
$NetBSD: patch-qt_qtr.pro,v 1.2 2014/04/01 09:48:04 adam Exp $
--- qt/qtr.pro.orig 2012-07-06 01:24:43.000000000 +0000
--- qt/qtr.pro.orig 2014-03-21 11:16:35.000000000 +0000
+++ qt/qtr.pro
@@ -8,7 +8,7 @@ target.path = /bin
@@ -8,12 +8,14 @@ target.path = /bin
INSTALLS += target
unix: INSTALLS += man
@ -10,4 +10,11 @@ $NetBSD: patch-qt_qtr.pro,v 1.1 2013/03/02 19:33:29 wiz Exp $
+man.path = /man/man1/
man.files = transmission-qt.1
CONFIG += qt qdbus thread debug link_pkgconfig
CONFIG += qt thread debug link_pkgconfig
QT += network dbus widgets
PKGCONFIG = fontconfig libcurl openssl libevent
+INCLUDEPATH += $${OPENSSL_CFLAGS}
+LIBS += $${OPENSSL_LIBS}
TRANSMISSION_TOP = ..

View file

@ -0,0 +1,15 @@
$NetBSD: patch-qt_torrent-filter.cc,v 1.1 2014/04/01 09:48:04 adam Exp $
Fix building error.
--- qt/torrent-filter.cc.orig 2014-04-01 07:01:04.000000000 +0000
+++ qt/torrent-filter.cc
@@ -211,7 +211,7 @@ TorrentFilter :: hiddenRowCount( ) const
void
TorrentFilter :: countTorrentsPerMode (int * setmeCounts) const
{
- std::fill_n (setmeCounts, FilterMode::NUM_MODES, 0);
+ std::fill_n (setmeCounts, (int)FilterMode::NUM_MODES, 0);
for (int row(0); ; ++row)
{