Update to 1.5.1, the latest stable. Remove patch that was applied upstream.
Now depends on qt5-qt{tools,base}. From changes.txt: Solarus 1.5.1 (2016-11-29) __________________________ Engine changes -------------- * Add Spanish translation of the launcher GUI (thanks Diarandor!). * Fix registering quest to the launcher at quest install time (#948). * Fix crash when a carried bomb explodes (#953). * Fix crash when a scrolling teletransporter is incorrectly placed (#977). * Fix crash when an entity has a wrong savegame variable type (#1008). * Fix memory leak when creating lots of surfaces (#962). * Fix cleanup of the quest files at exit. * Fix error in sol.main.load_settings() when the file does not exist. * Fix ground ignored after hero:unfreeze() or back to solid ground (#827). * Fix entity:get_name() returning nil after the entity is removed (#954). * Improve error messages of surface creations and conversions. * Chests: set an initial value "entities/chest" to the sprite field. Solarus launcher GUI changes ---------------------------- * Start the selected quest by pressing Return or double-clicking (#949). Sample quest changes -------------------- * The sample quest is now in a separate repository (#996). __________________________ Solarus 1.5.0 (2016-07-27) __________________________ Engine changes -------------- * Add a launcher GUI to ease chosing a quest and setting options (#693). * Rename the solarus_run executable to solarus-run. * Add version number and symbolic links when building the library. * Add a -lua-console option to run Lua code from the standard input. * Remove the -win-console option, the preferred way is now to use a GUI. * Add a -turbo option to run at full speed. * Add a -lag option to simulate slower systems for debugging. * Print when the main loop starts and stops. * Print the Lua version at startup (#692). * Outputs are now prefixed by [Solarus] and the current simulated time. * Musics: Add support of custom OGG looping (#643). * Maps: allow more than 3 layers (#445). * Improve the performance of loading big maps (#854). * Improve the performance of custom entity collisions. * Improve the performance of collisions by using a quadtree. * Entities far from the camera are no longer suspended. * The hero no longer automatically jumps when arriving on water (#530). * Destinations can now set to update or not the starting location (#819). * Teletransporters on the side of the map now work on all layers (#850). * Streams can now have a speed of zero (#496). * Fix crash when main.lua has a syntax error. * Fix crash with missing directions in sprites controlled by the engine (#864). * Fix sprite:on_animation_finished() and others not working sometimes (#799). * Fix error in sprite:set_animation() when the direction is missing (#937). * Fix straight movement precision. * Fix freeze when loading a map with tiles outside the limits (#875). * Fix crash when trying to use a non-saved item (#889). * Fix sword tapping sound still played when the game is suspended (#797). * Fix hero:set_invincible() not working without duration (#805). * Fix lifted item walking animation only accepting 3 frames (#645). * Fix enemy:set_attack_consequence_sprite() with thrown items (#834). * Fix custom_entity:set_can_traverse() for doors (#716). * Fix custom_entity:set_can_traverse_ground() for some grounds (#794). * Fix custom entity collisions missed for entities that do not move (#671, #883). * Fix custom_entity:get_modified_ground() returning nothing. * Fix custom_entity:on_ground_below_changed() not called (#738). * Fix missing notifications in custom_entity:set_origin() (#880). * Fix creating an entity with the same name as another one just removed (#795). * Fix parallax scrolling for dynamic tiles (#816). * Fix crash when a diagonal tile is not square (#837). * Fix crash when the teletransporter after stairs is missing. * Fix non-blocking stream turns after going south (#648). * Fix text_surface:set_rendering_mode() not working (#833). * Fix possible freeze when changing the position of a path finding entity. * Fix circle_movement:set_initial_angle() not working (#721). * Fix straight movement setting speed to zero when reaching obstacles (#633). * Fix support of joypads with multiple axes. * Fix sol.input.get_mouse_coordinates() ignoring the zoom factor (#734). Lua API changes --------------- Changes that introduce incompatibilities: * Fix missing collision detections and entity notifications. * chest:on_empty() is replaced by chest:on_opened(treasure) (#483). * Enemy ranks no longer exist, set_hurt_style() needs to be called (#449). * Items with amount now have a default max amount of 1000 (#688). * New ability "jump_over_water" in game:get/set_ability(), off by default (#530). * Fix hero state name "freezed", renamed it to "frozen" (#813). * Fix map:get_entities() not returning the hero (#670). * Fix map:create_custom_entity() not erroring when width/height are missing. * map:get_camera_position() is now deprecated, use camera:get_bounding_box(). * map:move_camera() is now deprecated, use a camera movement instead. * map:draw_sprite() is now deprecated, use map:draw_visual() instead (#661). * Fix entity:set_enabled(true) delayed while it blocks the hero (#817). * Fix brandished treasure sprite and shop treasure sprite not animated (#790). * circle_movement:get/set_initial_angle() now use degrees (#721). * Add ability to hide mouse cursor (#891). Changes that do not introduce incompatibilities: * Add a function sol.main.get_solarus_version() (#767). * Add a function sol.main.get_quest_format(). * Add a function sol.main.get_type() (#744). * Add a method game:set_suspended() (#845). * Add methods map:get_min_layer() and map:get_max_layer() (#445). * Add a method map:get_entities_by_type() (#796). * Add a method map:get_entities_in_rectangle() (#142). * Add a method map:draw_visual() to draw any drawable object (#661). * Add a method map:get_camera() (the camera is now a map entity). * Add methods map:set_world() and map:set_floor() (#656). * map:get_entities() can now be called without parameter to get all entities. * map:get_entities*() functions now give entities sorted in Z order (#779). * Add an event entity:on_movement_started(). * Add a method entity:get_max_bounding_box() considering sprite boxes (#754). * entity:get_center_position() now also returns the layer. * Add a method entity:get_facing_position(). * Add a method entity:get_facing_entity() (#877). * Add a method entity:get_ground_position() (#830). * Add a method entity:get_ground_below() (#830). * entity:set_optimization_distance() is now only a hint for the engine. * entity:test_obstacles() now also works without parameters. * entity:overlaps() now has an optional collision mode parameter (#748). * Add entity:get_sprite() to all entities, with an optional name value (#669). * Add a method entity:get_sprites() (#851). * Add methods entity:bring_sprite_to_front/back() (#809). * enemy/custom_entity:create_sprite() now take an optional name value. * hero:save_solid_ground() can now take a function parameter (#667). * Add a method hero:start_attack() (#821). * Add methods npc:is/set_traversable() (#712). * Add methods chest:get/set_treasure() (#664). * Add an event chest:on_opened() with treasure info parameters (#483). * Add methods dynamic_tile:get_pattern_id() and get_modified_ground() (#755). * Add methods destination:get/set_starting_location_mode() (#819). * Add a method switch:is_walkable() (#729). * Add a method switch:is_locked(). * Add a method sprite:get_num_frames() (#818). * Add methods sprite:get_size() and sprite:get_origin() (#823). * sprite:set_animation() now takes an optional callback parameter (#861). * Add a method surface:get_opacity() (#722). * Add methods surface/text_surface/sprite:get/set_blending_mode (#930). Data files format changes ------------------------- * New directory logos to put the logo and icons of your quest, used in the GUI. * Quest properties: New properties describing the quest, used in the GUI (#838). * Quest properties: the title_bar property no longer exists, use title instead. * Maps: New properties min_layer and max_layer (#445). * Maps: Enemies no longer have a rank property (#449). * Maps: New property starting_location_mode on destinations (#819). * Maps: width and height of custom entities are now mandatory as documented. * Dialogs: Allow empty texts. Sample quest changes -------------------- * Lots of new sprites and sounds from Diarandor. __________________________ Solarus 1.4.5 (2015-11-22) __________________________ Bug fixes for the 1.4 release. * Fix file name not shown when there is an error in dialogs file (#718). * Fix saving special characters in data files (#719). * Fix sol.main.load_file() returning a string instead of nil on error (#730). * Fix performance issue when sprites have huge frame delays (#723). * Fix collisions triggered for removed entities (#710). * Fix hero disappearing if lifting animation has less than 5 frames (#682). * Fix collisions with diagonal dynamic tiles larger than 8x8 (#486). * Fix path finding movement not working with NPCs (#708). * Fix stuck on non-traversable dynamic tiles covered by traversables (#769). * Fix collision detection of custom entities that do not move. * Fix pickables with special movement falling in holes too early. * Fix blocking streams not working when the hero's speed is greater (#488). __________________________ Solarus 1.4.4 (2015-08-19) __________________________ Bug fixes for the 1.4 release. * Fix pickables falling in holes even when hooked (#740). __________________________ Solarus 1.4.3 (2015-08-12) __________________________ Bug fixes for the 1.4 release. * Fix a compilation error with Mac OS X. * Fix crash at exit when a surface has a movement with callback (#699). * Fix crash when removing a custom entity (#690). * Fix crash when a sprite file is missing or has no animation (#700). * Fix crash when trying to remove a sprite already removed (#705). * Fix crash when a custom entity collision or traversable test errors. * Fix crash when changing hero sprites sometimes. * Fix crash when sound buffers are full. * Fix crash in map:get_ground() with out of bounds coordinates. * Fix Lua error message saying "number expected" instead of "string expected". * Fix game:set_command_keyboard/joypad_binding refusing parameters. * Fix map scrolling not working if quest size is not a multiple of 5 (#701). * Fix camera:move() ignoring separators. * Fix entities already destroyed when map:on_finished() is called (#691). * Fix entity:bring_to_front()/back() ignoring the order of obstacles. * Fix hero stuck on blocks. * Fix hero going backwards on ice sometimes. * Fix custom_entity:set_can_traverse_ground() giving opposite result (#668). * Fix enemy:immobilize() having no effect when already immobilized. * Fix dying animation of flying and swimming enemies. * Fix the position of the shadow of pickables when they move. * Fix pickables not reacting to their ground (#655).
This commit is contained in:
parent
328332d442
commit
bcc3476b57
4 changed files with 56 additions and 43 deletions
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.20 2016/07/16 00:03:36 markd Exp $
|
||||
# $NetBSD: Makefile,v 1.21 2017/01/11 23:42:56 rodent Exp $
|
||||
|
||||
VERSION= 1.4.2
|
||||
VERSION= 1.5.1
|
||||
DISTNAME= solarus-${VERSION}-src
|
||||
PKGNAME= ${DISTNAME:S/-src//1}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://www.solarus-games.org/downloads/solarus/
|
||||
|
||||
|
@ -21,9 +20,8 @@ USE_LANGUAGES= c c++
|
|||
GCC_REQD+= 4.8
|
||||
LDFLAGS.SunOS+= -lsocket -lnsl
|
||||
|
||||
pre-install:
|
||||
rm ${WRKSRC}/include/solarus/EntityData.h.orig
|
||||
|
||||
.include "../../x11/qt5-qttools/buildlink3.mk"
|
||||
.include "../../x11/qt5-qtbase/buildlink3.mk"
|
||||
.include "../../devel/physfs/buildlink3.mk"
|
||||
.include "../../lang/LuaJIT2/buildlink3.mk"
|
||||
LUA_VERSIONS_ACCEPTED= 51
|
||||
|
|
|
@ -1,27 +1,29 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2015/07/01 23:06:59 rodent Exp $
|
||||
bin/solarus_run
|
||||
@comment $NetBSD: PLIST,v 1.3 2017/01/11 23:42:56 rodent Exp $
|
||||
bin/solarus
|
||||
bin/solarus-run
|
||||
include/solarus/Ability.h
|
||||
include/solarus/AbilityInfo.h
|
||||
include/solarus/Arguments.h
|
||||
include/solarus/Camera.h
|
||||
include/solarus/CommandsEffects.h
|
||||
include/solarus/Common.h
|
||||
include/solarus/CurrentQuest.h
|
||||
include/solarus/Dialog.h
|
||||
include/solarus/DialogBoxSystem.h
|
||||
include/solarus/DialogResources.h
|
||||
include/solarus/Drawable.h
|
||||
include/solarus/DrawablePtr.h
|
||||
include/solarus/EntityData.h
|
||||
include/solarus/EnumInfo.h
|
||||
include/solarus/EnumInfo.inl
|
||||
include/solarus/Equipment.h
|
||||
include/solarus/EquipmentItem.h
|
||||
include/solarus/EquipmentItemUsage.h
|
||||
include/solarus/Game.h
|
||||
include/solarus/GameCommand.h
|
||||
include/solarus/GameCommands.h
|
||||
include/solarus/KeysEffect.h
|
||||
include/solarus/MainLoop.h
|
||||
include/solarus/Map.h
|
||||
include/solarus/MapData.h
|
||||
include/solarus/MapLoader.h
|
||||
include/solarus/QuestProperties.h
|
||||
include/solarus/QuestResources.h
|
||||
include/solarus/ResourceType.h
|
||||
|
@ -46,12 +48,16 @@ include/solarus/Treasure.h
|
|||
include/solarus/config.h
|
||||
include/solarus/config.h.in
|
||||
include/solarus/containers/Grid.h
|
||||
include/solarus/containers/Quadtree.h
|
||||
include/solarus/containers/Quadtree.inl
|
||||
include/solarus/entities/AnimatedTilePattern.h
|
||||
include/solarus/entities/Arrow.h
|
||||
include/solarus/entities/Block.h
|
||||
include/solarus/entities/Bomb.h
|
||||
include/solarus/entities/Boomerang.h
|
||||
include/solarus/entities/CarriedItem.h
|
||||
include/solarus/entities/Camera.h
|
||||
include/solarus/entities/CameraPtr.h
|
||||
include/solarus/entities/CarriedObject.h
|
||||
include/solarus/entities/Chest.h
|
||||
include/solarus/entities/CollisionMode.h
|
||||
include/solarus/entities/Crystal.h
|
||||
|
@ -59,12 +65,15 @@ include/solarus/entities/CrystalBlock.h
|
|||
include/solarus/entities/CustomEntity.h
|
||||
include/solarus/entities/Destination.h
|
||||
include/solarus/entities/Destructible.h
|
||||
include/solarus/entities/Detector.h
|
||||
include/solarus/entities/Door.h
|
||||
include/solarus/entities/DynamicTile.h
|
||||
include/solarus/entities/Enemy.h
|
||||
include/solarus/entities/EnemyAttack.h
|
||||
include/solarus/entities/EnemyReaction.h
|
||||
include/solarus/entities/Entities.h
|
||||
include/solarus/entities/Entity.h
|
||||
include/solarus/entities/EntityPtr.h
|
||||
include/solarus/entities/EntityState.h
|
||||
include/solarus/entities/EntityType.h
|
||||
include/solarus/entities/EntityTypeInfo.h
|
||||
include/solarus/entities/Explosion.h
|
||||
|
@ -72,12 +81,9 @@ include/solarus/entities/Fire.h
|
|||
include/solarus/entities/Ground.h
|
||||
include/solarus/entities/GroundInfo.h
|
||||
include/solarus/entities/Hero.h
|
||||
include/solarus/entities/HeroPtr.h
|
||||
include/solarus/entities/Hookshot.h
|
||||
include/solarus/entities/Jumper.h
|
||||
include/solarus/entities/Layer.h
|
||||
include/solarus/entities/MapEntities.h
|
||||
include/solarus/entities/MapEntity.h
|
||||
include/solarus/entities/MapEntityPtr.h
|
||||
include/solarus/entities/NonAnimatedRegions.h
|
||||
include/solarus/entities/Npc.h
|
||||
include/solarus/entities/ParallaxScrollingTilePattern.h
|
||||
|
@ -85,20 +91,37 @@ include/solarus/entities/Pickable.h
|
|||
include/solarus/entities/SelfScrollingTilePattern.h
|
||||
include/solarus/entities/Sensor.h
|
||||
include/solarus/entities/Separator.h
|
||||
include/solarus/entities/SeparatorPtr.h
|
||||
include/solarus/entities/ShopTreasure.h
|
||||
include/solarus/entities/SimpleTilePattern.h
|
||||
include/solarus/entities/Stairs.h
|
||||
include/solarus/entities/StartingLocationMode.h
|
||||
include/solarus/entities/Stream.h
|
||||
include/solarus/entities/StreamAction.h
|
||||
include/solarus/entities/Switch.h
|
||||
include/solarus/entities/Teletransporter.h
|
||||
include/solarus/entities/Tile.h
|
||||
include/solarus/entities/TileInfo.h
|
||||
include/solarus/entities/TilePattern.h
|
||||
include/solarus/entities/TilePtr.h
|
||||
include/solarus/entities/Tileset.h
|
||||
include/solarus/entities/TilesetData.h
|
||||
include/solarus/entities/TimeScrollingTilePattern.h
|
||||
include/solarus/entities/Wall.h
|
||||
include/solarus/gui/about_dialog.h
|
||||
include/solarus/gui/console.h
|
||||
include/solarus/gui/console_line_edit.h
|
||||
include/solarus/gui/gui_common.h
|
||||
include/solarus/gui/gui_tools.h
|
||||
include/solarus/gui/main_window.h
|
||||
include/solarus/gui/quest_runner.h
|
||||
include/solarus/gui/quests_item_delegate.h
|
||||
include/solarus/gui/quests_model.h
|
||||
include/solarus/gui/quests_view.h
|
||||
include/solarus/gui/settings.h
|
||||
include/solarus/gui/ui_about_dialog.h
|
||||
include/solarus/gui/ui_console.h
|
||||
include/solarus/gui/ui_main_window.h
|
||||
include/solarus/hero/BackToSolidGroundState.h
|
||||
include/solarus/hero/BoomerangState.h
|
||||
include/solarus/hero/BowState.h
|
||||
|
@ -106,9 +129,10 @@ include/solarus/hero/CarryingState.h
|
|||
include/solarus/hero/FallingState.h
|
||||
include/solarus/hero/ForcedWalkingState.h
|
||||
include/solarus/hero/FreeState.h
|
||||
include/solarus/hero/FreezedState.h
|
||||
include/solarus/hero/FrozenState.h
|
||||
include/solarus/hero/GrabbingState.h
|
||||
include/solarus/hero/HeroSprites.h
|
||||
include/solarus/hero/HeroState.h
|
||||
include/solarus/hero/HookshotState.h
|
||||
include/solarus/hero/HurtState.h
|
||||
include/solarus/hero/JumpingState.h
|
||||
|
@ -120,7 +144,6 @@ include/solarus/hero/PushingState.h
|
|||
include/solarus/hero/RunningState.h
|
||||
include/solarus/hero/SpinAttackState.h
|
||||
include/solarus/hero/StairsState.h
|
||||
include/solarus/hero/State.h
|
||||
include/solarus/hero/SwimmingState.h
|
||||
include/solarus/hero/SwordLoadingState.h
|
||||
include/solarus/hero/SwordSwingingState.h
|
||||
|
@ -128,7 +151,10 @@ include/solarus/hero/SwordTappingState.h
|
|||
include/solarus/hero/TreasureState.h
|
||||
include/solarus/hero/UsingItemState.h
|
||||
include/solarus/hero/VictoryState.h
|
||||
include/solarus/lowlevel/BlendMode.h
|
||||
include/solarus/lowlevel/BlendModeInfo.h
|
||||
include/solarus/lowlevel/Color.h
|
||||
include/solarus/lowlevel/Color.inl
|
||||
include/solarus/lowlevel/Debug.h
|
||||
include/solarus/lowlevel/FontResource.h
|
||||
include/solarus/lowlevel/Geometry.h
|
||||
|
@ -137,8 +163,9 @@ include/solarus/lowlevel/Hq3xFilter.h
|
|||
include/solarus/lowlevel/Hq4xFilter.h
|
||||
include/solarus/lowlevel/InputEvent.h
|
||||
include/solarus/lowlevel/ItDecoder.h
|
||||
include/solarus/lowlevel/Logger.h
|
||||
include/solarus/lowlevel/Music.h
|
||||
include/solarus/lowlevel/Output.h
|
||||
include/solarus/lowlevel/OggDecoder.h
|
||||
include/solarus/lowlevel/PixelBits.h
|
||||
include/solarus/lowlevel/PixelFilter.h
|
||||
include/solarus/lowlevel/Point.h
|
||||
|
@ -146,11 +173,13 @@ include/solarus/lowlevel/Point.inl
|
|||
include/solarus/lowlevel/QuestFiles.h
|
||||
include/solarus/lowlevel/Random.h
|
||||
include/solarus/lowlevel/Rectangle.h
|
||||
include/solarus/lowlevel/Rectangle.inl
|
||||
include/solarus/lowlevel/Scale2xFilter.h
|
||||
include/solarus/lowlevel/Size.h
|
||||
include/solarus/lowlevel/Size.inl
|
||||
include/solarus/lowlevel/Sound.h
|
||||
include/solarus/lowlevel/SpcDecoder.h
|
||||
include/solarus/lowlevel/String.h
|
||||
include/solarus/lowlevel/Surface.h
|
||||
include/solarus/lowlevel/SurfacePtr.h
|
||||
include/solarus/lowlevel/System.h
|
||||
|
@ -174,7 +203,6 @@ include/solarus/lua/ScopedLuaRef.h
|
|||
include/solarus/movements/CircleMovement.h
|
||||
include/solarus/movements/FallingHeight.h
|
||||
include/solarus/movements/FallingOnFloorMovement.h
|
||||
include/solarus/movements/FollowMovement.h
|
||||
include/solarus/movements/JumpMovement.h
|
||||
include/solarus/movements/Movement.h
|
||||
include/solarus/movements/PathFinding.h
|
||||
|
@ -184,6 +212,7 @@ include/solarus/movements/PixelMovement.h
|
|||
include/solarus/movements/PlayerMovement.h
|
||||
include/solarus/movements/RandomMovement.h
|
||||
include/solarus/movements/RandomPathMovement.h
|
||||
include/solarus/movements/RelativeMovement.h
|
||||
include/solarus/movements/StraightMovement.h
|
||||
include/solarus/movements/TargetMovement.h
|
||||
include/solarus/third_party/hqx/common.h
|
||||
|
@ -198,4 +227,7 @@ include/solarus/third_party/snes_spc/blargg_endian.h
|
|||
include/solarus/third_party/snes_spc/blargg_source.h
|
||||
include/solarus/third_party/snes_spc/dsp.h
|
||||
include/solarus/third_party/snes_spc/spc.h
|
||||
lib/libsolarus-gui.so
|
||||
lib/libsolarus.so
|
||||
lib/libsolarus.so.1
|
||||
lib/libsolarus.so.${PKGVERSION}
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.10 2015/11/03 20:57:04 agc Exp $
|
||||
$NetBSD: distinfo,v 1.11 2017/01/11 23:42:56 rodent Exp $
|
||||
|
||||
SHA1 (solarus-1.4.2-src.tar.gz) = 145c34d617f66ed419aa18e69616b5e7331a0092
|
||||
RMD160 (solarus-1.4.2-src.tar.gz) = 3bada277c00ab929fc9bf16f475c8cff03ea7ee4
|
||||
SHA512 (solarus-1.4.2-src.tar.gz) = 8c015e169b0199f28b998171d69f013df4782d13a918e4bde70165077686f2eb2c9e35744468faf1742afbd47ad1996e778daccfb34209b33462964f5cee8e60
|
||||
Size (solarus-1.4.2-src.tar.gz) = 2443414 bytes
|
||||
SHA1 (patch-include_solarus_EntityData.h) = da21cd7fe6d752c27c1cc817ec71efc4ba23ff7e
|
||||
SHA1 (solarus-1.5.1-src.tar.gz) = 703a305b189711b2761a66d916b70f624c37825b
|
||||
RMD160 (solarus-1.5.1-src.tar.gz) = 504d3d582a50b8c87dd6a04fc3af5c277208e58a
|
||||
SHA512 (solarus-1.5.1-src.tar.gz) = fa308d5cecad313e9d263175da50e27ea9b41c2120a5b2df1a2fb0f503c325e27a1df46a3926ef45e05cf7add671f212138bf90644ff485a4bf0da6870e6095a
|
||||
Size (solarus-1.5.1-src.tar.gz) = 2273607 bytes
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-include_solarus_EntityData.h,v 1.1 2015/07/07 11:41:19 joerg Exp $
|
||||
|
||||
With the constt, EntityData::EntityField is not copy-assignable, but
|
||||
that is required elsewhere for use by .insert().
|
||||
|
||||
--- include/solarus/EntityData.h.orig 2015-07-04 14:10:49.000000000 +0000
|
||||
+++ include/solarus/EntityData.h
|
||||
@@ -63,7 +63,7 @@ class SOLARUS_API EntityData : public Lu
|
||||
bool operator==(const FieldValue& other) const;
|
||||
bool operator!=(const FieldValue& other) const;
|
||||
|
||||
- const EntityFieldType value_type;
|
||||
+ EntityFieldType value_type;
|
||||
std::string string_value;
|
||||
int int_value; // Also used for boolean.
|
||||
};
|
Loading…
Reference in a new issue