Remove a bit-rotted inline prototype for a libc function, unbreaking

build on netbsd-8.
This commit is contained in:
hauke 2017-07-08 19:38:18 +00:00
parent f4278044aa
commit bcf60221ce
2 changed files with 24 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.3 2017/04/13 14:35:53 hauke Exp $
$NetBSD: distinfo,v 1.4 2017/07/08 19:38:18 hauke Exp $
SHA1 (netatalk-2.2.5.tar.bz2) = 4367421213d68b8396cf35743e347e9c01bdf3b0
RMD160 (netatalk-2.2.5.tar.bz2) = ff0165806973b19db906406fd4b37dd49d505a27
@ -24,4 +24,5 @@ SHA1 (patch-etc_papd_print_cups.c) = 0bfa8d75691e11e3bbbc0bb59cd342fb5500b6ac
SHA1 (patch-etc_uams_uams_gss.c) = b9ff59c368e01d3f269e95f5eaeb239dc17e701c
SHA1 (patch-include_atalk_acl.h) = 62d67eaf089126b2c0bff0871b23f7a6707e119c
SHA1 (patch-include_atalk_ldapconfig.h) = d0bb4a1bf520b18228de6ab87b646f4496852fce
SHA1 (patch-libatalk_bstring_bstrlib.c) = f43818328237b908166f956de464f532d578d2c4
SHA1 (patch-macros_quota-check.m4) = b1484f83a2a6ba5bd50623ab525d5366bb71abaa

View file

@ -0,0 +1,22 @@
$NetBSD: patch-libatalk_bstring_bstrlib.c,v 1.1 2017/07/08 19:38:18 hauke Exp $
When a compiler complains about a missing prototype for a libc
function, just inserting one for what you think the interface might be
is probably not a good idea.
--- libatalk/bstring/bstrlib.c.orig 2013-03-05 06:24:48.000000000 +0000
+++ libatalk/bstring/bstrlib.c
@@ -2736,13 +2736,6 @@ struct genBstrList g;
#define exvsnprintf(r,b,n,f,a) {vsprintf (b,f,a); r = -1;}
#define START_VSNBUFF (256)
#else
-
-#ifdef __GNUC__
-/* Something is making gcc complain about this prototype not being here, so
- I've just gone ahead and put it in. */
-extern int vsnprintf (char *buf, size_t count, const char *format, va_list arg);
-#endif
-
#define exvsnprintf(r,b,n,f,a) {r = vsnprintf (b,n,f,a);}
#endif
#endif