libdrm: restore "return 0;" for linux drmParsePciBusInfo.
It was lost in a patching accident. From Yosuke Kawasaki in PR pkg/54534 Bump PKGREVISION
This commit is contained in:
parent
3659de2832
commit
bd56186d9a
3 changed files with 11 additions and 10 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.92 2019/04/23 09:51:47 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.93 2019/09/08 15:43:37 maya Exp $
|
||||
|
||||
DISTNAME= libdrm-2.4.98
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= x11 graphics
|
||||
MASTER_SITES= http://dri.freedesktop.org/libdrm/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.93 2019/04/23 09:51:47 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.94 2019/09/08 15:43:37 maya Exp $
|
||||
|
||||
SHA1 (libdrm-2.4.98.tar.bz2) = 4c8a11870a89f59c294bef0109939a7ffaa1fb26
|
||||
RMD160 (libdrm-2.4.98.tar.bz2) = 1896b9e53ca92d61c6aa7dd6b74303b0c794b01c
|
||||
|
@ -8,6 +8,6 @@ SHA1 (patch-ac) = 67c998df7dfc0dabc86320ea6d015cede3e464ea
|
|||
SHA1 (patch-include_drm_drm.h) = 48a912f40bf2b2a1c23edbe4446fa7869212f17b
|
||||
SHA1 (patch-libkms_vmwgfx.c) = d2204c0b79098c6c36b7f282b486c58c6354bd1d
|
||||
SHA1 (patch-libsync.h) = 1e0603e72a54a069fc9d2ab2c9559d22381a69d3
|
||||
SHA1 (patch-xf86drm.c) = 7519074f23f308e806274e003a68e66e8c01e8fc
|
||||
SHA1 (patch-xf86drm.c) = 58ec3ec995349834ea640b4cd0bf51ad1a2f5185
|
||||
SHA1 (patch-xf86drmMode.c) = 5f66d45a63b0915f22d0abe115aace13c53823a8
|
||||
SHA1 (patch-xf86drmMode.h) = a28b02887389be8670193c119f711901af61a6b2
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-xf86drm.c,v 1.4 2019/01/22 21:50:47 wiz Exp $
|
||||
$NetBSD: patch-xf86drm.c,v 1.5 2019/09/08 15:43:37 maya Exp $
|
||||
|
||||
Implement drmParseSubsystemType, drmParsePciBusInfo for NetBSD
|
||||
|
||||
--- xf86drm.c.orig 2019-01-22 16:32:41.000000000 +0000
|
||||
--- xf86drm.c.orig 2019-04-19 15:52:29.000000000 +0000
|
||||
+++ xf86drm.c
|
||||
@@ -86,7 +86,10 @@
|
||||
#endif
|
||||
|
@ -16,7 +16,7 @@ Implement drmParseSubsystemType, drmParsePciBusInfo for NetBSD
|
|||
#endif
|
||||
|
||||
#ifdef __OpenBSD__
|
||||
@@ -3013,6 +3016,65 @@ static int drmParseSubsystemType(int maj
|
||||
@@ -3031,6 +3034,65 @@ static int drmParseSubsystemType(int maj
|
||||
return bus_types[i].bus_type;
|
||||
}
|
||||
|
||||
|
@ -82,10 +82,10 @@ Implement drmParseSubsystemType, drmParsePciBusInfo for NetBSD
|
|||
return -EINVAL;
|
||||
#elif defined(__OpenBSD__) || defined(__DragonFly__)
|
||||
return DRM_BUS_PCI;
|
||||
@@ -3062,6 +3124,73 @@ static int drmParsePciBusInfo(int maj, i
|
||||
info->dev = dev;
|
||||
@@ -3081,6 +3143,73 @@ static int drmParsePciBusInfo(int maj, i
|
||||
info->func = func;
|
||||
|
||||
return 0;
|
||||
+#elif defined(__NetBSD__)
|
||||
+ int type, fd;
|
||||
+ drmSetVersion sv;
|
||||
|
@ -153,10 +153,10 @@ Implement drmParseSubsystemType, drmParsePciBusInfo for NetBSD
|
|||
+
|
||||
+ /* Success! */
|
||||
+ return 0;
|
||||
return 0;
|
||||
#elif defined(__OpenBSD__) || defined(__DragonFly__)
|
||||
struct drm_pciinfo pinfo;
|
||||
@@ -3229,6 +3358,48 @@ static int drmParsePciDeviceInfo(int maj
|
||||
int fd, type;
|
||||
@@ -3247,6 +3376,48 @@ static int drmParsePciDeviceInfo(int maj
|
||||
return parse_config_sysfs_file(maj, min, device);
|
||||
|
||||
return 0;
|
||||
|
|
Loading…
Reference in a new issue