Disable automatic detection of any library's that do not have there

buildlink3.mk included.

Bump PKGREVISION
This commit is contained in:
sbd 2012-01-09 07:08:25 +00:00
parent a2c9cec936
commit bd7ca2b973
3 changed files with 64 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.12 2012/01/09 07:07:10 sbd Exp $
# $NetBSD: Makefile,v 1.13 2012/01/09 07:08:25 sbd Exp $
DISTNAME= uwsgi-0.9.8.6
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 2
CATEGORIES= www python
MASTER_SITES= http://projects.unbit.it/downloads/

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.9 2012/01/09 07:07:10 sbd Exp $
$NetBSD: distinfo,v 1.10 2012/01/09 07:08:25 sbd Exp $
SHA1 (uwsgi-0.9.8.6.tar.gz) = bb835c3c14310640b24ebdbcf0aa91e8ce8bd5a6
RMD160 (uwsgi-0.9.8.6.tar.gz) = 78b92fe3a9b272ca5a2704b0db7d1956b9149a0b
Size (uwsgi-0.9.8.6.tar.gz) = 359620 bytes
SHA1 (patch-uwsgiconfig.py) = d7d7e3143658b1860f6d79f288d76ecb21aaf660

View file

@ -0,0 +1,60 @@
$NetBSD: patch-uwsgiconfig.py,v 1.3 2012/01/09 07:08:25 sbd Exp $
Find include/uuid/uuid.h and lib/libuuid.so under the BUILDLINK_DIR.
--- uwsgiconfig.py.orig 2011-09-11 05:54:27.000000000 +0000
+++ uwsgiconfig.py
@@ -443,7 +443,7 @@ class uConf(object):
has_json = False
has_uuid = False
- if os.path.exists('/usr/include/uuid/uuid.h') or os.path.exists('/usr/local/include/uuid/uuid.h'):
+ if False and ( os.path.exists('/usr/include/uuid/uuid.h') or os.path.exists('/usr/local/include/uuid/uuid.h')):
has_uuid = True
self.cflags.append("-DUWSGI_UUID")
if os.path.exists('/usr/lib/libuuid.so') or os.path.exists('/usr/local/lib/libuuid.so') or os.path.exists('/usr/lib64/libuuid.so') or os.path.exists('/usr/local/lib64/libuuid.so'):
@@ -541,7 +541,7 @@ class uConf(object):
self.cflags.append("-DUWSGI_INI")
self.gcc_list.append('ini')
- if self.get('yaml'):
+ if self.get('yamlOFF'):
self.cflags.append("-DUWSGI_YAML")
self.gcc_list.append('yaml')
if self.get('yaml_implementation') == 'libyaml':
@@ -552,7 +552,7 @@ class uConf(object):
self.cflags.append("-DUWSGI_LIBYAML")
self.libs.append('-lyaml')
- if self.get('json'):
+ if self.get('jsonOFF'):
if self.get('json') == 'auto':
jsonconf = spcall("pkg-config --cflags jansson")
if jsonconf:
@@ -572,7 +572,7 @@ class uConf(object):
self.libs.append('-ljansson')
has_json = True
- if self.get('ldap'):
+ if self.get('ldapOFF'):
if self.get('ldap') == 'auto':
if os.path.exists('/usr/include/ldap.h'):
self.cflags.append("-DUWSGI_LDAP")
@@ -583,7 +583,7 @@ class uConf(object):
self.gcc_list.append('ldap')
self.libs.append('-lldap')
- if has_uuid and self.get('zeromq'):
+ if has_uuid and self.get('zeromqOFF'):
if self.get('zeromq') == 'auto':
if os.path.exists('/usr/include/zmq.h') or os.path.exists('/usr/local/include/zmq.h'):
self.cflags.append("-DUWSGI_ZEROMQ")
@@ -631,7 +631,7 @@ class uConf(object):
self.libs.append('-lexpat')
self.gcc_list.append('xmlconf')
- if self.get('sqlite3'):
+ if self.get('sqlite3OFF'):
if self.get('sqlite3') == 'auto':
if os.path.exists('/usr/include/sqlite3.h') or os.path.exists('/usr/local/include/sqlite3.h'):
self.cflags.append("-DUWSGI_SQLITE3")