Package DeforaOS libSystem 0.2.2

Among the changes:
- extended String API (trimming)
- reworked the Array and Config classes
- build with SSP and PIE by default
- fixes and improvements to the build system
- additional tests
This commit is contained in:
khorben 2015-08-23 14:40:57 +00:00
parent dcdab0d03c
commit bdeca19a08
4 changed files with 25 additions and 21 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.11 2015/08/09 14:55:58 khorben Exp $
# $NetBSD: Makefile,v 1.12 2015/08/23 14:40:57 khorben Exp $
#
DISTNAME= libSystem-0.2.1
PKGNAME= deforaos-libsystem-0.2.1
DISTNAME= libSystem-0.2.2
PKGNAME= deforaos-libsystem-0.2.2
CATEGORIES= devel
MASTER_SITES= http://www.defora.org/os/download/download/4351/
MASTER_SITES= http://www.defora.org/os/download/download/4359/
MAINTAINER= khorben@defora.org
HOMEPAGE= http://www.defora.org/

View file

@ -1,11 +1,11 @@
# $NetBSD: buildlink3.mk,v 1.1 2012/12/16 23:55:22 khorben Exp $
# $NetBSD: buildlink3.mk,v 1.2 2015/08/23 14:40:57 khorben Exp $
BUILDLINK_TREE+= deforaos-libsystem
.if !defined(DEFORAOS_LIBSYSTEM_BUILDLINK3_MK)
DEFORAOS_LIBSYSTEM_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.deforaos-libsystem+= deforaos-libsystem>=0.1.2
BUILDLINK_API_DEPENDS.deforaos-libsystem+= deforaos-libsystem>=0.2.2
BUILDLINK_PKGSRCDIR.deforaos-libsystem?= ../../devel/deforaos-libsystem
.endif # DEFORAOS_LIBSYSTEM_BUILDLINK3_MK

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.6 2015/05/20 23:08:37 khorben Exp $
$NetBSD: distinfo,v 1.7 2015/08/23 14:40:57 khorben Exp $
SHA1 (libSystem-0.2.1.tar.gz) = a99a1a5aa5aa0c5516725263cb937a30186ee5db
RMD160 (libSystem-0.2.1.tar.gz) = 635dfe01c777238dd60aa771bab75ef05f4d6795
Size (libSystem-0.2.1.tar.gz) = 63274 bytes
SHA1 (patch-src_Makefile) = 98c22cc28de9bff4517c4880711a70741f5b18f2
SHA1 (libSystem-0.2.2.tar.gz) = faea622043ea4b5c1a65ff9d92d47ae9e3939867
RMD160 (libSystem-0.2.2.tar.gz) = f7fc7329c61f69893c646fe61f62855c04f1ee50
Size (libSystem-0.2.2.tar.gz) = 65486 bytes
SHA1 (patch-src_Makefile) = 8c2a2c7c453bc91b1acce3f47a94f0503810a97a
SHA1 (patch-tests_tests.sh) = b28b5557303cec42c1b24a6c5328fbca9b763366

View file

@ -1,13 +1,17 @@
$NetBSD: patch-src_Makefile,v 1.2 2015/05/20 23:08:37 khorben Exp $
$NetBSD: patch-src_Makefile,v 1.3 2015/08/23 14:40:57 khorben Exp $
Do not try to build targets that are created by existing targets, causes
problems with parallel builds and is unnecessary.
Always force -fPIC when compiling library code
--- src/Makefile.orig 2015-05-10 22:19:30.000000000 +0000
--- src/Makefile.orig 2015-08-10 23:56:33.000000000 +0000
+++ src/Makefile
@@ -1,4 +1,4 @@
-TARGETS = $(OBJDIR)libSystem.a $(OBJDIR)libSystem.so.0.0 $(OBJDIR)libSystem.so.0 $(OBJDIR)libSystem.so
+TARGETS = $(OBJDIR)libSystem.a $(OBJDIR)libSystem.so.0.0
OBJDIR =
PREFIX = /usr/local
DESTDIR =
@@ -6,8 +6,8 @@ LIBDIR = $(PREFIX)/lib
CC = cc
CPPFLAGSF= -I ../include
CPPFLAGS=
-CFLAGSF =
-CFLAGS = -W -Wall -g -O2 -pedantic -fPIC -D_FORTIFY_SOURCE=2 -fstack-protector-all
+CFLAGSF = -fPIC
+CFLAGS = -W -Wall -g -O2 -pedantic -D_FORTIFY_SOURCE=2 -fstack-protector-all
LDFLAGSF=
AR = ar
RANLIB = ranlib