Update to pforth-21.

V20
    - Expand PAD for ConvertNumberToText so "-1 binary .s" doesn't crash.
      Thank you Michael Connor of Vancouver for reporting this bug.

    - Removed FDROP in REPRESENT to fix stack underflow after "0.0 F.".
      Thank you Jim Rosenow of Minnesota for reporting this bug.
	- Changed pfCharToLower to function to prevent macro expansion
	bugs under VXWORKS
      Thank you Jim Rosenow of Minnesota for reporting this bug.

	- "0.0 F~" now checks actual binary encoding of floats. Before
	  this it used to just compare value which was incorrect. Now
	  "0.0 -0.0 0.0 F~" returns FALSE.

	- Fixed definition of INPUT$ in tutorial.
      Thank you Hampton Miller of California for reporting this bug.

	- Added support for producing a target dictionary with a different
	  Endian-ness than the host CPU.  See PF_BIG_ENDIAN_DIC and
	  PF_LITTLE_ENDIAN_DIC.

	- PForth kernel now comes up in a mode that uses BASE for
	  numeric input when started with "-i" option.  It used to
	  always consider numeric input as HEX. Initial BASE is decimal.

V21
	- Fixed some compiler warnings.
This commit is contained in:
jtb 2001-06-20 06:53:40 +00:00
parent 37dab3592a
commit be19c6c2ef
5 changed files with 55 additions and 31 deletions

View file

@ -1,16 +1,16 @@
# $NetBSD: Makefile,v 1.4 2001/04/21 01:19:09 jtb Exp $
# $NetBSD: Makefile,v 1.5 2001/06/20 06:53:40 jtb Exp $
DISTNAME= pfthunix19
PKGNAME= pforth-19
DISTNAME= pfthpc21
PKGNAME= pforth-21
CATEGORIES= lang
MASTER_SITES= http://www.softsynth.com/pforth/
EXTRACT_SUFX= .tar.Z
EXTRACT_SUFX= .zip
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.softsynth.com/pforth/
COMMENT= Portable ANS-like Forth
WRKSRC= ${WRKDIR}/pforth
WRKSRC= ${WRKDIR}
USE_GMAKE= YES
MAKEFILE= ${WRKSRC}/makefile

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2001/04/19 15:00:55 agc Exp $
$NetBSD: distinfo,v 1.3 2001/06/20 06:53:40 jtb Exp $
SHA1 (pfthunix19.tar.Z) = 3b21d757e6ecf2aa15114d5a549f37de3d68b789
Size (pfthunix19.tar.Z) = 206731 bytes
SHA1 (patch-aa) = 94ba259b058ae0ea6feb6137972878e20ad85e11
SHA1 (patch-ab) = 2c65db1281936e1a4f98608c645e3f95f24bf5fc
SHA1 (pfthpc21.zip) = 550de4405f593004ff6e957a1c294bd801167e5b
Size (pfthpc21.zip) = 295565 bytes
SHA1 (patch-aa) = 09b7fd486721664ff20d0260b43b8dfab727bc15
SHA1 (patch-ab) = bce3729fabfd196b11562ccdc2e559455e29176e

View file

@ -1,31 +1,47 @@
$NetBSD: patch-aa,v 1.1.1.1 2001/01/19 22:27:00 jtb Exp $
$NetBSD: patch-aa,v 1.2 2001/06/20 06:53:41 jtb Exp $
--- makefile.orig Tue Apr 7 00:43:01 1998
--- makefile.orig Mon Apr 6 17:13:12 1998
+++ makefile
@@ -27,7 +27,7 @@
@@ -12,7 +12,7 @@
OBJECTDIR = objects
EMBOBJECTDIR = embobjects
-FULL_WARNINGS = -O2 \
+FULL_WARNINGS = \
-fsigned-char \
-fno-builtin \
-fno-unroll-loops \
@@ -26,8 +26,9 @@
-Wmissing-prototypes \
-Wmissing-declarations
CCOPTS = -DPF_SUPPORT_FP $(FULL_WARNINGS)
-CCOPTS = -DPF_SUPPORT_FP $(FULL_WARNINGS)
-COMPILER = gcc
+COMPILER = $(CC)
+CFLAGS += -DPF_SUPPORT_FP $(FULL_WARNINGS)
+
+CDEFS = -DPF_DIC=\"${PREFIX}/lib/pforth/pforth.dic\"
EMBCCOPTS = -DPF_NO_INIT -DPF_NO_MALLOC -DPF_NO_FILEIO \
-DPF_NO_CLIB -DPF_STATIC_DIC
@@ -44,10 +44,10 @@
COMPILE = $(COMPILER) $(CCOPTS) $(CDEFS)
@@ -41,13 +42,13 @@
PFOBJS = ${PFTEMP:${SOURCEDIR}/%=${OBJECTDIR}/%}
PFEMBOBJS = ${PFTEMP:${SOURCEDIR}/%=${EMBOBJECTDIR}/%}
-COMPILE = $(COMPILER) $(CCOPTS) $(CDEFS)
+COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(CDEFS)
${OBJECTDIR}/%.o: $(PFINCLUDES) ${SOURCEDIR}/%.c
- $(COMPILE) -O -o ${OBJECTDIR}/$*.o -c ${SOURCEDIR}/$*.c
-
+ $(COMPILE) $(CFLAGS) -o ${OBJECTDIR}/$*.o -c ${SOURCEDIR}/$*.c
+ $(COMPILE) -o ${OBJECTDIR}/$*.o -c ${SOURCEDIR}/$*.c
+
${EMBOBJECTDIR}/%.o: $(PFINCLUDES) ${SOURCEDIR}/%.c ${SOURCEDIR}/pfdicdat.h
- $(COMPILE) -O -o ${EMBOBJECTDIR}/$*.o -c ${SOURCEDIR}/$*.c $(EMBCCOPTS)
+ $(COMPILE) $(CFLAGS) -o ${EMBOBJECTDIR}/$*.o -c ${SOURCEDIR}/$*.c $(EMBCCOPTS)
+ $(COMPILE) -o ${EMBOBJECTDIR}/$*.o -c ${SOURCEDIR}/$*.c $(EMBCCOPTS)
all: pforth pforth.dic
@@ -62,26 +62,26 @@
@@ -62,26 +63,26 @@
echo ${PFOBJS}
echo "EMBEDDED OBJECT FILES ------------------"
echo ${PFEMBOBJS}
@ -33,7 +49,8 @@ $NetBSD: patch-aa,v 1.1.1.1 2001/01/19 22:27:00 jtb Exp $
+
# build pforth by compiling 'C' source
pforth: $(PFINCLUDES) $(PFOBJS)
$(COMPILER) $(PFOBJS) -lm -o pforth
- $(COMPILER) $(PFOBJS) -lm -o pforth
+ $(CC) $(PFOBJS) -lm -o pforth
# build basic dictionary by running newly built pforth and including system.fth
pforth.dic: pforth
@ -50,8 +67,9 @@ $NetBSD: patch-aa,v 1.1.1.1 2001/01/19 22:27:00 jtb Exp $
pfemb: $(PFINCLUDES) $(PFEMBOBJS)
$(COMPILER) $(PFEMBOBJS) -lm -o pfemb
- $(COMPILER) $(PFEMBOBJS) -lm -o pfemb
-
+ $(CC) $(PFEMBOBJS) -lm -o pfemb
+
clean:
rm -f $(PFOBJS) $(PFEMBOBJS) pforth *.dic core ${SOURCEDIR}/pfdicdat.h pfemb

View file

@ -1,13 +1,17 @@
$NetBSD: patch-ab,v 1.1.1.1 2001/01/19 22:27:00 jtb Exp $
$NetBSD: patch-ab,v 1.2 2001/06/20 06:53:41 jtb Exp $
--- csrc/pf_main.c.orig Fri Jan 19 21:03:56 2001
--- csrc/pf_main.c.orig Tue Mar 31 22:34:50 1998
+++ csrc/pf_main.c
@@ -42,7 +42,7 @@
@@ -42,7 +42,12 @@
int main( int argc, char **argv )
{
- const char *DicName = "pforth.dic";
+ const char *DicName = "@PREFIX@/lib/pforth/pforth.dic";
+
+#ifdef PF_DIC
+ const char *DicName = PF_DIC;
+#else
const char *DicName = "pforth.dic";
+#endif
const char *SourceName = NULL;
char IfInit = FALSE;
char *s;

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2001/01/19 22:26:59 jtb Exp $
@comment $NetBSD: PLIST,v 1.2 2001/06/20 06:53:41 jtb Exp $
bin/pforth
lib/pforth/pforth.dic
share/doc/pforth/pf_ref.htm
@ -12,6 +12,7 @@ share/pforth/bloop.fth
share/pforth/c_struct.fth
share/pforth/case.fth
share/pforth/catch.fth
share/pforth/checkit.fth
share/pforth/condcomp.fth
share/pforth/coretest.fth
share/pforth/filefind.fth
@ -41,10 +42,11 @@ share/pforth/tester.fth
share/pforth/trace.fth
share/pforth/tut.fth
share/pforth/utils/clone.fth
share/pforth/utils/dump_s~1.fth
share/pforth/utils/load_f~1.fth
share/pforth/utils/make_a~1.fth
share/pforth/utils/dump_struct.fth
share/pforth/utils/load_file.fth
share/pforth/utils/make_all256.fth
share/pforth/utils/savedicd.fth
share/pforth/utils/trace.fth
share/pforth/wordslik.fth
@dirrm share/pforth/utils
@dirrm share/pforth