py-autocommand: fix build with setuptools v69; switch to wheel.mk; bump revision

This commit is contained in:
adam 2023-11-27 06:55:57 +00:00
parent 3d04b50224
commit be4475e994
4 changed files with 29 additions and 12 deletions

View File

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.2 2022/11/26 17:08:20 adam Exp $
# $NetBSD: Makefile,v 1.3 2023/11/27 06:55:57 adam Exp $
DISTNAME= autocommand-2.2.2
PKGREVISION= 1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= misc python
MASTER_SITES= ${MASTER_SITE_PYPI:=a/autocommand/}
@ -10,12 +11,12 @@ HOMEPAGE= https://github.com/Lucretiel/autocommand
COMMENT= Create a command-line program from a function
LICENSE= gnu-lgpl-v3
TEST_DEPENDS+= ${PYPKGPREFIX}-test>0:../../devel/py-test
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools-[0-9]*:../../devel/py-setuptools
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
USE_LANGUAGES= # none
PYTHON_VERSIONS_INCOMPATIBLE= 27
do-test:
cd ${WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYVERSSUFFIX} test
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,8 +1,9 @@
@comment $NetBSD: PLIST,v 1.1 2022/02/02 18:50:49 adam Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
@comment $NetBSD: PLIST,v 1.2 2023/11/27 06:55:57 adam Exp $
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/autocommand/__init__.py
${PYSITELIB}/autocommand/__init__.pyc
${PYSITELIB}/autocommand/__init__.pyo

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.2 2022/11/26 17:08:20 adam Exp $
$NetBSD: distinfo,v 1.3 2023/11/27 06:55:57 adam Exp $
BLAKE2s (autocommand-2.2.2.tar.gz) = cf173d9a16ed4589ee0105b9fed237f8a71c5001444f1d2aa42807eb1caf36ec
SHA512 (autocommand-2.2.2.tar.gz) = 7e78b3bb7eb62be8a308fe4406b0c72170f9a057010b02a1f8f0d2b33b5d19682d8795bb573728ebe941957ec60d86edd9db57659f63a4a2d788c7176907f067
Size (autocommand-2.2.2.tar.gz) = 22894 bytes
SHA1 (patch-setup.py) = e66b22146001d4162480c55b2032bee773472dd0

View File

@ -0,0 +1,14 @@
$NetBSD: patch-setup.py,v 1.1 2023/11/27 06:55:57 adam Exp $
Fix build with setuptools 69.
--- setup.py.orig 2023-11-27 06:43:19.679895559 +0000
+++ setup.py
@@ -13,7 +13,6 @@ setup(
],
package_dir={'': 'src'},
platforms='any',
- license='LGPLv3',
author='Nathan West',
url='https://github.com/Lucretiel/autocommand',
description='A library to create a command-line program from a function',