make sure to build against pkgsrc subversion

fix build on MacOS X - avoid absolute paths (they are filtered out by gcc
wrapper), and use GNU make

bump PKGREVISION
This commit is contained in:
jdolecek 2010-11-11 21:07:13 +00:00
parent cb391435b2
commit be6d2f58a2
3 changed files with 20 additions and 4 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.2 2010/09/07 16:50:58 drochner Exp $
# $NetBSD: Makefile,v 1.3 2010/11/11 21:07:13 jdolecek Exp $
#
VERS= 1.7.2
DISTNAME= pysvn-${VERS}
PKGNAME= ${PYPKGPREFIX}-pysvn-${VERS}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://pysvn.barrys-emacs.org/source_kits/
@ -18,6 +18,7 @@ PKG_DESTDIR_SUPPORT= user-destdir
DEPENDS+= ${PYPKGPREFIX}-expat-[0-9]*:../../textproc/py-expat
USE_LANGUAGES= c c++
USE_TOOLS= gmake
PSVNSRC= Source
PYSETUP= setup.py
@ -34,7 +35,8 @@ do-configure:
cd ${WRKSRC}/${PSVNSRC} && ${PYTHONBIN} ${PYSETUP} backport
.endif
cd ${WRKSRC}/${PSVNSRC} && \
${PYTHONBIN} ${PYSETUP} configure --fixed-module-name
${PYTHONBIN} ${PYSETUP} configure --fixed-module-name \
--svn-root-dir=${BUILDLINK_PREFIX.subversion-base}
do-install:
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/${PYSITELIB}/pysvn

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2010/08/15 10:33:20 drochner Exp $
$NetBSD: distinfo,v 1.2 2010/11/11 21:07:13 jdolecek Exp $
SHA1 (pysvn-1.7.2.tar.gz) = e8afa0c1f56c82f13f5e17c7dd120cfa82c8a24f
RMD160 (pysvn-1.7.2.tar.gz) = 85026cff619aeefde622b677f7b6697269beab4f
Size (pysvn-1.7.2.tar.gz) = 333643 bytes
SHA1 (patch-aa) = 9b4dad10ee5238b409fa00c986f11dc25ef97e72
SHA1 (patch-ab) = 7eb56e7c84dc58100f1182acae3dc21542c41f22

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2010/11/11 21:07:14 jdolecek Exp $
--- Source/setup_configure.py.orig 2010-11-11 19:59:49.000000000 +0000
+++ Source/setup_configure.py
@@ -932,7 +932,7 @@ LDLIBS= \
if self.verbose:
print( 'Info: Checking for %s in %s' % (name, full_check_file) )
if os.path.exists( full_check_file ):
- return os.path.abspath( dirname )
+ return dirname
raise SetupError( 'cannot find %s %s - use %s' % (name, check_file, kw) )